Bug 223537 - xm list race - prints an error if run when FC6 domU is shutdown
xm list race - prints an error if run when FC6 domU is shutdown
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-19 16:40 EST by Dave Wysochanski
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 22:16:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Wysochanski 2007-01-19 16:40:33 EST
Description of problem:

Looks like there's a race condition in "xm list" where it'll print an error
message instead of listing the running domains.  This happens when I shutdown
one of my domU's - it looks like maybe just at the moment of shutdown or
something like that.  If you re-run the command it works fine.

[root@dwysocha-rhel5 dwysocha]# xm list
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      482     8 r-----   4447.5
fc6                                       14      127     2 r-----     13.2
[root@dwysocha-rhel5 dwysocha]# xm list
Error: Device 0 not connected
Usage: xm list [options] [Domain, ...]

List information about all/some domains.
  -l, --long                     Output all VM details in SXP
  --label                        Include security labels

[root@dwysocha-rhel5 dwysocha]# which xm
/usr/sbin/xm
[root@dwysocha-rhel5 dwysocha]# rpm -qf /usr/sbin/xm
xen-3.0.3-12.el5
[root@dwysocha-rhel5 dwysocha]# uname -a
Linux dwysocha-rhel5 2.6.18-1.2961.el5xen #1 SMP Wed Jan 3 14:49:26 EST 2007
x86_64 x86_64 x86_64 GNU/Linux



Version-Release number of selected component (if applicable):
xen-3.0.3-12.el5


How reproducible:
It looks like everytime if you use something like this in a dom0 shell:
# while true; do xm list; usleep 500000; done

and then type "halt" in the domU console.  At the point at which the domU is
stopped, you'll see that error / usage statement.

  
Actual results:
"xm list" displays an error:

Error: Device 0 not connected
Usage: xm list [options] [Domain, ...]

List information about all/some domains.
  -l, --long                     Output all VM details in SXP
  --label                        Include security labels



Expected results:
"xm list" should display just dom0.


Additional info:
Comment 1 Dave Wysochanski 2007-01-23 13:16:10 EST
It looks like this is fixed in the latest packages.

Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      738     8 r-----   4238.8
fc6                                        3      255     2 r-----     62.9
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      738     8 r-----   4239.0
fc6                                        3      255     2 r-----     63.6
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      738     8 r-----   4239.6
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      738     8 r-----   4240.2
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      738     8 r-----   4240.3
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      738     8 r-----   4240.5
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      738     8 r-----   4240.6
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      738     8 r-----   4240.8
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0      738     8 r-----   4240.9

[root@dwysocha-rhel5 dwysocha]# rpm -qf `which xm`
xen-3.0.3-21.el5
Comment 2 Jay Turner 2007-01-25 22:16:18 EST
xen-3.0.3-22.el5 included in 20070124.1.

Note You need to log in before you can comment on or make changes to this bug.