Bug 223582 - Error: Missing Dependency: seamonkey = 1.0.7-0.6.fc5 is needed by package seamonkey-js-debugger
Error: Missing Dependency: seamonkey = 1.0.7-0.6.fc5 is needed by package sea...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: seamonkey (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kai Engert (:kaie)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-19 23:38 EST by John Guthrie
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: seamonkey-1.0.7-0.6.1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 15:37:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Guthrie 2007-01-19 23:38:15 EST
Description of problem:
I just upgraded from FC5 to FC6, when I try to update the seamonkey package, I
get the following:

euler_1023# rpm -q seamonkey
seamonkey-1.0.7-0.6.fc5
euler_1024# yum update seamonkey
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package seamonkey.i386 0:1.0.7-0.6.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: nspr >= 4.6.4 for package: seamonkey
--> Processing Dependency: seamonkey = 1.0.7-0.6.fc5 for package:
seamonkey-js-debugger
--> Processing Dependency: nss >= 3.11.4 for package: seamonkey
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package nspr.i386 0:4.6.4-0.6.1.fc6 set to be updated
---> Package nss.i386 0:3.11.4-0.6.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: seamonkey = 1.0.7-0.6.fc5 for package:
seamonkey-js-debugger
--> Finished Dependency Resolution
Error: Missing Dependency: seamonkey = 1.0.7-0.6.fc5 is needed by package
seamonkey-js-debugger

Is the seamonkey-js-debugger gone?  Or has it been obsoleted?  Or do I need to
delete the seamonkey-js-debugger package by hand.  (It would be kind of a shame
to lose a js-debugger.  Those can be handy at times.)

Version-Release number of selected component (if applicable):
1.0.7-0.6.fc5

How reproducible:
Every time.

Steps to Reproduce:
1.Install FC5
2.Install seamonkey and seamonkey-js-debugger
3.Upgrade to FC6
4.Run yum update seamonkey
  
Actual results:
I get the error message in the summary

Expected results:
I would expect seamonkey and seamonkey-js-debugger to be updated

Additional info:
Comment 1 Kai Engert (:kaie) 2007-01-20 10:49:54 EST
Mozilla Suite was in the past shipped as multiple separate packages.

Seamonkey Suite in Fedora Extras was usually shipped as a single package, that
includes all components. This is currently true in FC6, Rawhide, and it was true
for FC5 until recently:

On FC5 SeaMonkey was released as separate packages, following the Mozilla
package structure, in order to replace Mozilla in FC5 with SeaMonkey. SeaMonkey
in FC5 was also moved to Core.

So, as a workaround, you should be able to remove the individual packages you
had from FC5, and can install the single package from FC6, which should give you
what you want.

In order to resolve this bug, I think we need to produce a new SeaMonkey package
for Fedora Extras 6, which obsoletes the no longer available individual packages.

I will look into that.
Comment 2 Kai Engert (:kaie) 2007-02-07 15:37:46 EST
fixed as described in previous comment

Note You need to log in before you can comment on or make changes to this bug.