Bug 223590 - glibc detected error in rpm - double free or corruption
glibc detected error in rpm - double free or corruption
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-20 06:29 EST by Herbert Carl Meyer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 05:05:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Herbert Carl Meyer 2007-01-20 06:29:43 EST
Description of problem:
rpm fails attempting to install new kernel (see attached backtrace)

Version-Release number of selected component (if applicable):


How reproducible:
don't know, will attempt to re-download kernel rpm and retry. rpm worked
yesterday on upgrade of other pkg, yumex still seems to work.

Steps to Reproduce:
1. download 2895 kernel
2. rpm -ivh 
  
Actual results:
error (see backtrace)

Expected results:
install new kernel

Additional info: (backtrace)
[root@evilgnome 1.2895]# rpm -ivh kernel-2.6.19-1.2895.fc6.i686.rpm 
*** glibc detected *** rpm: double free or corruption (out): 0xb7991410 ***
======= Backtrace: =========
/lib/libc.so.6[0x52409d]
/lib/libc.so.6(cfree+0x90)[0x5276f0]
/usr/lib/librpmdb-4.4.so[0x6542f6]
/usr/lib/librpmdb-4.4.so[0x65e25b]
/usr/lib/librpmdb-4.4.so(rpmdbInitIterator+0x486)[0x65e766]
/usr/lib/librpm-4.4.so(rpmtsInitIterator+0x64)[0x78b854]
/usr/lib/librpm-4.4.so[0x757982]
/usr/lib/librpm-4.4.so[0x757c8d]
/usr/lib/librpm-4.4.so(rpmtsCheck+0x185)[0x7589f5]
/usr/lib/librpm-4.4.so(rpmInstall+0x11a1)[0x7817d1]
rpm[0x804b8d7]
/lib/libc.so.6(__libc_start_main+0xdc)[0x4d3f2c]
rpm[0x804a541]
======= Memory map: ========
00101000-0011a000 r-xp 00000000 fd:00 983065     /lib/ld-2.5.so
0011a000-0011b000 r-xp 00018000 fd:00 983065     /lib/ld-2.5.so
0011b000-0011c000 rwxp 00019000 fd:00 983065     /lib/ld-2.5.so
0011c000-00191000 r-xp 00000000 fd:00 2453746    /usr/lib/librpmio-4.4.so
00191000-00194000 rwxp 00074000 fd:00 2453746    /usr/lib/librpmio-4.4.so
00194000-001b7000 rwxp 00194000 00:00 0 
001b7000-001c2000 r-xp 00000000 fd:00 983117     /lib/libgcc_s-4.1.1-20070105.so.1
001c2000-001c3000 rwxp 0000a000 fd:00 983117     /lib/libgcc_s-4.1.1-20070105.so.1
0025d000-00282000 r-xp 00000000 fd:00 983131     /lib/libm-2.5.so
00282000-00283000 r-xp 00024000 fd:00 983131     /lib/libm-2.5.so
00283000-00284000 rwxp 00025000 fd:00 983131     /lib/libm-2.5.so
00286000-00288000 r-xp 00000000 fd:00 983071     /lib/libdl-2.5.so
00288000-00289000 r-xp 00001000 fd:00 983071     /lib/libdl-2.5.so
00289000-0028a000 rwxp 00002000 fd:00 983071     /lib/libdl-2.5.so
0028c000-0029f000 r-xp 00000000 fd:00 983073     /lib/libpthread-2.5.so
0029f000-002a0000 r-xp 00012000 fd:00 983073     /lib/libpthread-2.5.so
002a0000-002a1000 rwxp 00013000 fd:00 983073     /lib/libpthread-2.5.so
002a1000-002a3000 rwxp 002a1000 00:00 0 
00339000-0033a000 r-xp 00339000 00:00 0          [vdso]
00342000-0039f000 r-xp 00000000 fd:00 2453747    /usr/lib/libsqlite3.so.0.8.6
0039f000-003a1000 rwxp 0005c000 fd:00 2453747    /usr/lib/libsqlite3.so.0.8.6
003a3000-003c1000 r-xp 00000000 fd:00 2453745    /usr/lib/libneon.so.25.0.5
003c1000-003c2000 rwxp 0001d000 fd:00 2453745    /usr/lib/libneon.so.25.0.5
003c8000-003da000 r-xp 00000000 fd:00 2437604    /usr/lib/libz.so.1.2.3
003da000-003db000 rwxp 00011000 fd:00 2437604    /usr/lib/libz.so.1.2.3
00404000-00423000 r-xp 00000000 fd:00 983133     /lib/libexpat.so.0.5.0
00423000-00425000 rwxp 0001e000 fd:00 983133     /lib/libexpat.so.0.5.0
00427000-00462000 r-xp 00000000 fd:00 2452081    /usr/lib/libbeecrypt.so.6.4.0
00462000-00465000 rwxp 0003a000 fd:00 2452081    /usr/lib/libbeecrypt.so.6.4.0
004a9000-004bd000 r-xp 00000000 fd:00 2453748    /usr/lib/libelf-0.123.so
004bd000-004be000 rwxp 00013000 fd:00 2453748    /usr/lib/libelf-0.123.so
004be000-005f5000 r-xp 00000000 fd:00 983069     /lib/libc-2.5.so
005f5000-005f7000 r-xp 00137000 fd:00 983069     /lib/libc-2.5.so
005f7000-005f8000 rwxp 00139000 fd:00 983069     /lib/libc-2.5.so
005f8000-005fb000 rwxp 005f8000 00:00 0 
00626000-0062d000 r-xp 00000000 fd:00 983079     /lib/librt-2.5.so
0062d000-0062e000 r-xp 00006000 fd:00 983079     /lib/librt-2.5.so
0062e000-0062f000 rwxp 00007000 fd:00 983079     /lib/librt-2.5.so
00631000-00743000 r-xp 00000000 fd:00 2453749    /usr/lib/librpmdb-4.4.so
00743000-00747000 rwxp 00112000 fd:00 2453749    /usr/lib/librpmdb-4.4.so
00747000-00748000 rwxp 00747000 00:00 0 
0074a000-007a4000 r-xp 00000000 fd:00 2444450    /usr/lib/librpm-4.4.so
007a4000-007a7000 rwxp 0005a000 fd:00 2444450    /usr/lib/librpm-4.4.so
007a7000-007da000 rwxp 007a7000 00:00 0 
007da000-008ba000 r-xp 00000000 fd:00 2453679    /usr/lib/libstdc++.so.6.0.8
008ba000-008bd000 r-xp 000e0000 fd:00 2453679    /usr/lib/libstdc++.so.6.0.8
008bd000-008bf000 rwxp 000e3000 fd:00 2453679    /usr/lib/libstdc++.so.6.0.8
008bf000-008c5000 rwxp 008bf000 00:00 0 
00ca9000-00cbe000 r-xp 00000000 fd:00 983290     /lib/libselinux.so.1
00cbe000-00cc0000 rwxp 00015000 fd:00 983290     /lib/libselinux.so.1
00ccf000-00cd1000 r-xp 00000000 fd:00 984996     /lib/libcom_err.so.2.1
00cd1000-00cd2000 rwxp 00001000 fd:00 984996     /lib/libcom_err.so.2.1
00cd4000-00cdb000 r-xp 00000000 fd:00 2453704    /usr/lib/libkrb5support.so.0.1
00cdb000-00cdc000 rwxp 00006000 fd:00 2453704    /usr/lib/libkrb5support.so.0.1
00cf5000-00d30000 r-xp 00000000 fd:00 984999     /lib/libsepol.so.1
00d30000-00d31000 rwxp 0003b000 fd:00 984999     /lib/libsepol.so.1
00d31000-00d3b000 rwxp 00d31000 00:00 0 
00d3d000-00d62000 r-xp 00000000 fd:00 2453705    /usr/lib/libk5crypto.so.3.0
00d62000-00d63000 rwxp 00025000 fd:00 2453705    /usr/lib/libk5crypto.so.3.0
00d65000-00d8f000 r-xp 00000000 fd:00 2453707    /usr/lib/libgssapi_krb5.so.2.2
00d8f000-00d90000 rwxp 00029000 fd:00 2453707    /usr/lib/libgssapi_krb5.so.2.2
00dbc000-00dcb000 r-xp 00000000 fd:00 983250     /lib/libresolv-2.5.so
00dcb000-00dcc000 r-xp 0000e000 fd:00 983250     /lib/libresolv-2.5.so
00dcc000-00dcd000 rwxp 0000f000 fd:00 983250     /lib/libresolv-2.5.so
00dcd000-00dcf000 rwxp 00dcd000 00:00 0 
02000000-02084000 r-xp 00000000 fd:00 2453706    /usr/lib/libkrb5.so.3.2
02084000-02086000 rwxp 00084000 fd:00 2453706    /usr/lib/libkrb5.so.3.2
02088000-020c9000 r-xp 00000000 fd:00 984998     /lib/libssl.so.0.9.8b
020c9000-020cd000 rwxp 00040000 fd:00 984998     /lib/libssl.so.0.9.8b
02bf3000-02d0f000 r-xp 00000000 fd:00 984997     /lib/libcrypto.so.0.9.8b
02d0f000-02d21000 rwxp 0011c000 fd:00 984997     /lib/libcrypto.so.0.9.8b
02d21000-02d25000 rwxp 02d21000 00:00 0 
02e5c000-02e63000 r-xp 00000000 fd:00 2424840    /usr/lib/libpopt.so.0.0.0
02e63000-02e64000 rwxp 00006000 fd:00 2424840    /usr/lib/libpopt.so.0.0.0
0337e000-0338e000 r-xp 00000000 fd:00 2437658    /usr/lib/libbz2.so.1.0.3
0338e000-0338f000 rwxp 0000f000 fd:00 2437658    /usr/lib/libbz2.so.1.0.3
08046000-0805b000 r-xp 00000000 fd:00 1966134    /bin/rpm
0805b000-0805d000 rw-p 00015000 fd:00 1966134    /bin/rpm
0805d000-08067000 rw-p 0805d000 00:00 0 
08b22000-0917a000 rw-p 08b22000 00:00 0 
b7800000-b7821000 rw-p b7800000 00:00 0 
b7821000-b7900000 ---p b7821000 00:00 0 
b7991000-b7af3000 rw-p b7991000 00:00 0 
b7af3000-b7b61000 rw-s 00000000 fd:00 134868     /var/lib/rpm/__db.003
b7b61000-b7ca3000 rw-s 00000000 fd:00 134863     /var/lib/rpm/__db.002
b7ca3000-b7ca9000 rw-s 00000000 fd:00 134862     /var/lib/rpm/__db.001
b7cde000-b7cff000 rw-p b7cde000 00:00 0 
b7cff000-b7d06000 r--s 00000000 fd:00 2491202    /usr/lib/gconv/gconv-modules.cache
b7d27000-b7f27000 r--p 00000000 fd:00 2453594    /usr/lib/locale/locale-archive
b7f27000-b7f2f000 rw-p b7f27000 00:00 0 
bf8b7000-bf8e1000 rw-p bf8b7000 00:00 0          [stack]
Aborted
Comment 1 Herbert Carl Meyer 2007-01-21 05:53:47 EST
error is not repeatable. I installed kernel sucessfully this morning. rpm
version is 4.4.2-32.
Comment 2 Jeff Johnson 2007-02-06 18:24:40 EST
This problem should be reproduced or closed. Reproducing seems nearly impossible ...
Comment 3 Herbert Carl Meyer 2007-02-07 05:05:19 EST
has not reoccured. i will close it.

Note You need to log in before you can comment on or make changes to this bug.