Bug 223635 - Creating full headers from new kernel source package (2895.fc6) does not create include/linux/config.h
Creating full headers from new kernel source package (2895.fc6) does not crea...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-20 19:48 EST by Michael Gebhardt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-21 20:15:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of grep commands for definition of CHECKSUM_HW in the 2895 and 2869 kernel headers (built from the Source RPM package) (8.71 KB, text/plain)
2007-01-21 11:21 EST, Michael Gebhardt
no flags Details

  None (edit)
Description Michael Gebhardt 2007-01-20 19:48:33 EST
Description of problem:

When creating the full set of kernel headers using the latest 2895.fc6 kernel
source package, include/linux/config.h is not created. Up to this release it has
always been created under the 'vanilla' directory in include/linux. I am unable
to compile and use my cisco vpn client to log into my corporate network because
of the lack of this file.


Version-Release number of selected component (if applicable):

kernel-2.6.19-1.2895.fc6.src.rpm 


How reproducible:

easily.
Steps to Reproduce:
1.Create the full kernel headers using the above package
2.Look for include/linux/config.h under the BUILD directory when complete.
3.You will not find it. Up to this version it has always been created.
  
Actual results:
include/linux/config.h is not created

Expected results:
include/linux/config.h would found under the 'vanilla' directory in
include/linux where it should be

Additional info:
None. It has worked fine, and been created up to this kernel source package.
Comment 1 Michael Gebhardt 2007-01-21 11:21:07 EST
Created attachment 146092 [details]
Output of grep commands for definition of CHECKSUM_HW in the 2895 and 2869 kernel headers (built from the Source RPM package)

Cisco VPN client creates invalid module when built against the 2895 kernel
header source package due to the lack of definition of CHECKSUM_HW in many
header files.

Note You need to log in before you can comment on or make changes to this bug.