Bug 223656 - Intel HDA sound stops working after kernel upgrade to 2.6.19-1.2895
Intel HDA sound stops working after kernel upgrade to 2.6.19-1.2895
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 225046 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-21 05:45 EST by Mario Pascucci
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.19-1.2911.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-15 13:30:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Debug info (7.58 KB, text/plain)
2007-01-25 15:51 EST, Martin West
no flags Details

  None (edit)
Description Mario Pascucci 2007-01-21 05:45:34 EST
Description of problem:
Hardware: HP Compaq nx7300 notebook (2 week of life).
Sound works fine with kernel 2.6.18-1.2869
After kernel update to 2.9.19-1.2895, sound stops working at all.
system-config-sound utility recognize the soundcard (Intel 82801G ICH7 HDA), but
 in the combo "PCM Device" ther aren't any (blank).
In the udev start phase the "mute audio" button in the notebook is lighted (as
you press it to mute) and cannot be enabled.

Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2895.fc6
module snd-hda-intel


How reproducible:
Always.


Steps to Reproduce:
1.Upgrade kernel to latest 2.6.19-1.2895
2.restart system to switch to new kernel
3.after restart sound is disabled
  
Actual results:
sound disabled

Expected results:
sound working

Additional info:
in the dmesg there is some messages:

ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 16 (level, low) -> IRQ 16
PCI: Setting latency timer of device 0000:00:1b.0 to 64
si3054: cannot initialize. EXT MID = 0000
ACPI: PCI interrupt for device 0000:00:1b.0 disabled
HDA Intel: probe of 0000:00:1b.0 failed with error -13

The same messages you obtain if you unload and reload module snd-hda-intel.

lspci -v reports
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
        Subsystem: Hewlett-Packard Company Unknown device 30a2
        Flags: fast devsel, IRQ 16
        Memory at f4580000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
        Capabilities: [70] Express Unknown type IRQ 0
Comment 1 Mario Pascucci 2007-01-24 16:06:12 EST
Using Alsa original drivers (rel. 1.0.14rc2), installing only kernel modules,
solves the problem.
Comment 2 Martin West 2007-01-25 03:22:52 EST
Have the same problem on a Lenovo N100.

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 02)
        Subsystem: Lenovo Unknown device 2066
        Flags: fast devsel, IRQ 22
        Memory at b0000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
        Capabilities: [70] Express Unknown type IRQ 0
        Capabilities: [100] Virtual Channel
        Capabilities: [130] Unknown (5)

Advanced Linux Sound Architecture Driver Version 1.0.13 (Tue Nov 28 14:07:24
2006 UTC).
cat: /proc/asound/card0/codec*: No such file or directory
Comment 3 Martin West 2007-01-25 03:38:09 EST
When I tried the suggested solution, I got 

[root@localhost ~]# modprobe snd-hda-intel
FATAL: Error inserting snd_hda_intel
(/lib/modules/2.6.19-1.2895.fc6/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown
symbol in module, or unknown parameter (see dmesg)

This was after downloading 14rc2, ./configure;make;make install-modules

rmmod snd-hda-intel

Thanks
Comment 4 Martin West 2007-01-25 03:54:38 EST
porblem resolved itself after reboot - DOH
Comment 5 Martin West 2007-01-25 15:14:21 EST
Although alsa initialises ok, dont get any sound out of the speakers -
investigating.
Comment 6 Martin West 2007-01-25 15:51:56 EST
Created attachment 146624 [details]
Debug info
Comment 7 Jan Pacak 2007-02-14 02:03:36 EST
the same problem with  MCP51

[root@localhost ~]# lspci -v -s 10.1
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
        Subsystem: ASUSTeK Computer Inc. Unknown device 1339
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
        Memory at dc6b8000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [44] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
        Capabilities: [6c] HyperTransport: MSI Mapping

dmesg afder modprobe snd-hda-intel:

ACPI: PCI Interrupt Link [LAZA] enabled at IRQ 22
ACPI: PCI Interrupt 0000:00:10.1[B] -> Link [LAZA] -> GSI 22 (level, low) -> IRQ 22
PCI: Setting latency timer of device 0000:00:10.1 to 64
Unable to handle kernel NULL pointer dereference at 0000000000000000 RIP:
 [<ffffffff88b6e96c>] :snd_hda_codec:get_input_type+0x73/0x97
PGD 45f10067 PUD 45eec067 PMD 0
Oops: 0002 [1] SMP
last sysfs file: /class/sound/sequencer2/dev
CPU 1
Modules linked in: snd_hda_intel snd_hda_codec snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm
snd_timer snd soundcore snd_page_alloc autofs4 hidp rfcomm l2cap sunrpc
ip6t_REJECT ip6table_filter ip6_tables ip_conntrack_netbios_ns ipt_REJECT
xt_state ip_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables
cpufreq_ondemand dm_mirror dm_multipath dm_mod video sbs i2c_ec button battery
asus_acpi ac ipv6 parport_pc lp parport ide_cd joydev nvidia(P)(U) ohci1394
sdhci k8_edac sg ieee1394 edac_mc i2c_nforce2 cdrom mmc_core tpm_infineon tpm
tpm_bios shpchp i2c_core k8temp pcspkr forcedeth serio_raw hwmon hci_usb
bluetooth sata_nv libata sd_mod scsi_mod ext3 jbd ehci_hcd ohci_hcd uhci_hcd
Pid: 3796, comm: modprobe Tainted: P      2.6.19-1.2895.fc6 #1
RIP: 0010:[<ffffffff88b6e96c>]  [<ffffffff88b6e96c>]
:snd_hda_codec:get_input_type+0x73/0x97
RSP: 0018:ffff810045fb1b40  EFLAGS: 00010202
RAX: 0000000000000007 RBX: ffff81005c8102b0 RCX: 0000000000000000
RDX: 0000000000000001 RSI: 0000000000000000 RDI: ffff81005c810280
RBP: 0000000000000000 R08: ffff81007fdc21b8 R09: 0000003000000020
R10: 0000000000000002 R11: 0000000000000001 R12: ffff81005c381210
R13: ffff81005c381200 R14: ffff81006140c000 R15: ffff81007f668b80
FS:  00002aaaaaad9240(0000) GS:ffff81007ff0abc0(0000) knlGS:00000000f6c91b90
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000000000000000 CR3: 0000000045ee3000 CR4: 00000000000006e0
Process modprobe (pid: 3796, threadinfo ffff810045fb0000, task ffff810046120040)
Stack:  ffffffff88b6f4d6 ffff81005c810280 ffff81004614cac0 ffff81004614cac0
 ffffffff802fc05b ffff810045ed49a0 000003b94614cbc0 ffff81004614cac0
 0000000000008000 0000000000010000 ffffffff802fc65c ffff810045fd4780
Call Trace:
 [<ffffffff88b6f4d6>] :snd_hda_codec:build_generic_controls+0x247/0x32e
 [<ffffffff88b6e4e1>] :snd_hda_codec:snd_hda_build_controls+0x1d/0x83
 [<ffffffff88ba362c>] :snd_hda_intel:azx_probe+0x707/0x720
 [<ffffffff8034e9ee>] pci_device_probe+0xcd/0x135
 [<ffffffff803aec25>] really_probe+0x4c/0xdf
 [<ffffffff803aee77>] __driver_attach+0x90/0xcc
 [<ffffffff803ae1d3>] bus_for_each_dev+0x43/0x6e
 [<ffffffff803ae51b>] bus_add_driver+0x6b/0x18d
 [<ffffffff8034ebea>] __pci_register_driver+0x7f/0xa0
 [<ffffffff802a492d>] sys_init_module+0x1728/0x18e3
 [<ffffffff8025c11e>] system_call+0x7e/0x83
 [<000000300dccd96a>]


Code: 83 0e 04 83 e2 0f 48 c7 c1 ca 8c b7 88 48 c7 c0 d4 8c b7 88
RIP  [<ffffffff88b6e96c>] :snd_hda_codec:get_input_type+0x73/0x97
 RSP <ffff810045fb1b40>
CR2: 0000000000000000

2.6.18.* works ok... stopped working after upgrade to 2.6.19 :-(
Comment 8 Chuck Ebbert 2007-02-15 10:22:35 EST
*** Bug 225046 has been marked as a duplicate of this bug. ***
Comment 9 Martin West 2007-02-16 05:39:12 EST
Still have a problem ...

Feb 16 10:14:50 lenovo1 kernel: ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22
(level, low) -> IRQ 21
Feb 16 10:14:50 lenovo1 kernel: si3054: cannot initialize. EXT MID = 0000
Feb 16 10:14:50 lenovo1 kernel: ACPI: PCI interrupt for device 0000:00:1b.0 disabled
Feb 16 10:14:50 lenovo1 kernel: HDA Intel: probe of 0000:00:1b.0 failed with
error -13

[root@lenovo1 ~]# uname -a
Linux lenovo1.thecla.com 2.6.19-1.2911.fc6 #1 SMP Sat Feb 10 15:51:47 EST 2007
i686 i686 i386 GNU/Linux
Comment 10 Martin West 2007-02-16 06:44:45 EST
applying the work around gets the sound working again.
Comment 11 Martin West 2007-02-16 06:48:11 EST
PS - to get the sound out of the speakers I had to use alsamixer and enable the
external - not all the mixers provide the external controls.

Note You need to log in before you can comment on or make changes to this bug.