This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 223665 - ESSID set via iwconfig is shortened by the last character
ESSID set via iwconfig is shortened by the last character
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-21 11:28 EST by Jan Schäfer
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-31 12:28:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Schäfer 2007-01-21 11:28:42 EST
Description of problem: ESSID set via iwconfig is shortened by the last character

Version-Release number of selected component (if applicable):
wireless-tools-28-1.fc6

How reproducible: Try to set the ESSID on the console or via system-config-network


Steps to Reproduce:
1. iwconfig wlan0 essid "Name of your Network"
or
1. put in the network name in the configuration dialog and change foreward to
the next dialog and then back
  
Actual results:
The ESSID is shortened by one character
"MyNetwork" becomes "MyNetwor"

Expected results:
The ESSID is not shortended

Additional info:
A workaround is to put in an additional character
"MyNetworkX" becomes the right "MyNetwork" and everthing works.
Comment 1 Matěj Cepl 2007-01-29 12:28:07 EST
Cannot reproduce with this package (but I don't have space in ESSID and using
iwconfig).
Comment 2 Christopher Aillon 2007-01-29 17:18:40 EST
I think this is actually a kernel problem.  Is this using the rt2x00 drivers? 
Does reverting to an older kernel, such as kernel-2.6.18-1.2869.fc6 fix the problem?
Comment 3 Jan Schäfer 2007-01-30 01:59:54 EST
@Matej: I don't have a space in my ESSID either.

@Christopher: Yes I'm using the rt2x00 drivers. The problem occured after the
last kernel update.
Comment 4 Christopher Aillon 2007-01-30 13:16:40 EST
Okay, over to kernel.
Comment 5 John W. Linville 2007-01-30 14:17:28 EST
Where are you getting the rt2x00 drivers?

There was an upstream change to the internal wireless extensions API.  Some 
drivers had to be modified as a result.  Since the rt2x00 drivers are outside 
the kernel, their maintainers will need to make the appropriate changes.
Comment 6 Jan Schäfer 2007-01-30 16:47:37 EST
I used the lastest BETA rt2500 driver (v1.1.0-b4) for the RT2500 chip set as
listed on the project site:

http://rt2x00.serialmonkey.com/wiki/index.php?title=Downloads

I'll try the nightly CVS tarball for the old rt2500 and also for the new rt2x00
driver.
Comment 7 Jan Schäfer 2007-01-30 17:18:34 EST
The nightly CVS tarballs 

rt2500-cvs-2007013015
rt2x00-cvs-2007013015

are working correcty for me now. Thanks for pushing me in the right direction.
I'll file a bug report in the rt2x00 project now.

Note You need to log in before you can comment on or make changes to this bug.