Bug 22367 - No Lithuanian locale in new glibc
Summary: No Lithuanian locale in new glibc
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-15 20:43 UTC by Nerijus Baliūnas
Modified: 2016-11-24 15:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-15 20:44:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nerijus Baliūnas 2000-12-15 20:43:58 UTC
There is /usr/share/locale/lt_LT directory in glibc-2.1.3-21, but not in
glibc-2.2-5.
Also Lithuanian locale should use iso-8859-13 charset, not iso-8859-4.

Comment 1 Jakub Jelinek 2000-12-15 20:55:22 UTC
You're looking at wrong place. There is /usr/lib/locale/lt_LT
in glibc-2.2-5 and it uses iso-8859-13 locale.
/usr/share/locale/locale.alias even contains
lithuanian      lt_LT.ISO-8859-13
(note that locale files (as opposed to message catalogues) are now
under /usr/lib, because they are endian dependent (thus cannot be
shared e.g. between small and big endian hosts).
The fact that there is no /usr/share/locale/lt_LT just means there
are no lithuanian message catalogues installed.


Note You need to log in before you can comment on or make changes to this bug.