Bug 223672 - forcedeth 0.56 -> 0.57 breaks Marvell 88E1116
forcedeth 0.56 -> 0.57 breaks Marvell 88E1116
Status: CLOSED DUPLICATE of bug 222556
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-21 13:41 EST by Andy Michael
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-02 19:02:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Michael 2007-01-21 13:41:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:

I'm running an Asus M2N32 WS Professional motherboard which has an Nvidia nForce 590 SLI chipset with twin Marvell 88E1116 PHY Ethernets.  It works flawlessly under kernel-2.6.18-1.2869.fc6, but when I change to kernel-2.6.19-1.2895.fc6 the Ethernet ports run for about five to ten minutes before locking up.  I can disable and enable the ports and they'll run for another five to ten minutes before locking up again.  As forcedeth has changed from 0.56 to 0.57 between the two kernels I assume there's a bug in 0.57?


Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2895.fc6

How reproducible:
Always


Steps to Reproduce:
1. Just boot from kernel-2.6.19-1.2895.fc6!
2.
3.

Actual Results:
The Ethernet ports lock up after five to ten minutes.  No packets sent or received.

Expected Results:
Ethernet ports should carry on working!

Additional info:
Comment 1 Konstantin Olchanski 2007-01-23 16:30:03 EST
Me Too! Same symptoms on the ASUS CROSSHAIR mobo (NVidia MCP55).

These kernels work fine:
2.6.18-1.2869.fc6
2.6.9-42.40.ELsmp (RHEL4 kernel from jbaron)

These kernels have intermittent ethernet (ifconfig down/up restarts it)
2.6.19-1.2895.fc6
linux-2.6.19.2 (vanilla kernel)

K.O.
Comment 2 Bob Halley 2007-01-24 13:06:50 EST
I also have the NFORCE-MCP55.  With 2.6.18-1.2869, all is well.  With
2.6.19-1.2895, I get a hard hang after a while (in my case, about 21 hours).  I
had to reboot to de-wedge it.

I too suspect the changes made to forcedeth between 0.56 and 0.57.

I'm happy to help gather more info, just tell me what you want.
Comment 3 Jan "Yenya" Kasprzak 2007-01-26 10:48:22 EST
Just a "me too" - two identical boxes with MCP55, 2.6.18-1.2869 works,
2.6.19-1.2895.fc6 stops receiving data after a while (I _think_ it is
timing-related, because usually the hang occurs when the disk activity is higher).

The NIC just stops receiving packets (according to the stats in ifconfig(8)
output). Sending packets may work (at least the kernel thinks it is OK, because
the Tx counter keeps increasing). Nothing is logged in dmesg(8), all ifconfig(8)
error counters are zero.

Running

ifconfig eth0 down
ifup eth0

temporarily fixes the problem.
Comment 4 Phil Smith 2007-01-29 14:12:31 EST
Sounds like the same as me. Asus M2N-E motherboard with nForce 570 using
forcedeth. Fine with x86_64 kernel-2.6.18-1.2869.fc6 but not with
2.6.19-1.2895.fc6. Ethernet problems bad enough to take down local network switch.  

Another machine with the same kernel version (but 32 bit Athlon) and almost all
the same software works OK on an Asus A7N8X-E motherboard.

Problem occurred about 10-20 min after a "yum update" for the new kernel and
happened again about 10-20 min after a reboot.  Booting back to previous kernel
fixed it.
Comment 5 Phil Smith 2007-01-31 07:03:16 EST
Didn't mention in Comment #4 that the Asus M2N-E has the nVIDIA MCP55 with the
Marvell 88E1116.

See also http://weblog.infoworld.com/venezia/archives/009949.html with the same
problem.
Comment 6 Tom Hughes 2007-01-31 09:19:29 EST
I have the same problem on a board with the MCP55 chipset.
Comment 7 Petr Vanicek 2007-01-31 10:39:48 EST
Sun Ultra 20 M2 I have the same problem.
Comment 8 Philippe Rigault 2007-01-31 19:35:17 EST
Another me too on Sun Ultra 20 M2 (NFORCE-MCP55)
Comment 9 Philippe Rigault 2007-02-02 14:20:08 EST
To further point at the NFORCE-MCP55 chipset, I can confirm that version 0.57 
works fine on an older Sun Ultra20 that has another (NFORCE-CK804) chipset.
Comment 10 Philippe Rigault 2007-02-02 14:22:54 EST
Severity should be set to high, as it renders the box unusable.
Comment 11 John Thacker 2007-02-02 19:02:59 EST
Yeah, this the same problem as bug 222556 created a little bit before this one.
 Might as well mark them as duplicates.

*** This bug has been marked as a duplicate of 222556 ***
Comment 12 Andy Michael 2007-03-11 15:48:07 EDT
Just to confirm that this is fixed by kernel 2.6.19-1.2911.6.5.fc6

Note You need to log in before you can comment on or make changes to this bug.