Bug 223735 - Compiz depends on Gnome
Compiz depends on Gnome
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-21 20:57 EST by Karl Robillard
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 21:55:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl Robillard 2007-01-21 20:57:20 EST
Description of problem:

The compiz package requires a ton of Gnome packages.  A window manager should 
not require a multimedia framework, a mail database, and CD-ROM burning 
software. 

Here is the complete dependency list:

 at-spi                  x86_64     1.7.11-2.fc6     core              303 k
 control-center          x86_64     1:2.16.0-11.fc6  updates           2.7 M
 eel2                    x86_64     2.16.1-1.fc6     updates           370 k
 evolution-data-server   x86_64     1.8.2-2.fc6      updates           3.4 M
 gnome-desktop           x86_64     2.16.0-1.fc6     core              828 k
 gnome-icon-theme        noarch     2.16.0.1-3.fc6   updates           2.9 M
 gnome-media             x86_64     2.16.1-2.fc6     core              2.4 M
 gnome-menus             x86_64     2.16.0-2.fc6     core              170 k
 gnome-panel             x86_64     2.16.1-3.fc6     updates           3.3 M
 gnome-session           x86_64     2.16.0-7.fc6     updates           413 k
 gnome-volume-manager    x86_64     2.15.0-4.fc6     updates           407 k
 gstreamer               x86_64     0.10.10-2.fc6    updates           572 k
 gstreamer-plugins-base  x86_64     0.10.10-1.fc6    updates           646 k
 gstreamer-plugins-good  x86_64     0.10.4-1.fc6     core              588 k
 gstreamer-tools         x86_64     0.10.10-2.fc6    updates            18 k
 gthumb                  x86_64     2.7.8-3.fc6      core              1.9 M
 libavc1394              x86_64     0.5.3-1.fc6      core               46 k
 libdv                   x86_64     0.104-4.fc6.1    core               79 k
 libgail-gnome           x86_64     1.1.3-1.2.1      core               28 k
 libgnomeprint22         x86_64     2.12.1-9.fc6     updates           408 k
 libgnomeprintui22       x86_64     2.12.1-6         core              317 k
 libiec61883             x86_64     1.1.0-1.fc6      updates            37 k
 liboil                  x86_64     0.3.8-2.1        core              136 k
 libsoup                 x86_64     2.2.98-1.fc6     updates           147 k
 libxklavier             x86_64     3.0-2.fc6        updates            87 k
 nautilus-cd-burner      x86_64     2.16.0-6.fc6     updates           483 k
 nautilus-extensions     x86_64     2.16.2-5.fc6     updates            38 k
 

How reproducible:

 > yum install compiz

  
Additional info:

I do not like Gnome.  I do not want Gnome.  I installed beryl rather than 
compiz.
Comment 1 Kristian Høgsberg 2007-03-28 21:55:43 EDT
We require gnome-session in the RPM which is what pulls in the bulk of the GNOME
dependencies.  At this point there is no clean way to provide the user friendly
integration we have without pulling in that package.

Note You need to log in before you can comment on or make changes to this bug.