Bug 22376 - php-4.0.3pl1 from 7.0 errata fails to install gd.so ld
php-4.0.3pl1 from 7.0 errata fails to install gd.so ld
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Need Real Name
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-15 19:57 EST by Scott Russell
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-20 14:44:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Russell 2000-12-15 19:57:33 EST
The updated php RPMs from the Red Hat 7.0 errata changed the compile option
of GD in the spec file from "--with-gd" to "--with-gd=shared". According to
php docs this should create a GD ld for php. After installing the updates
GD functions stop working and phpinfo() does not report GD as available for
use. (The ld for GD is apparently missing?)

Fixed by editing the php.spec file and changing --with-gd=shared to
--with-gd then rebuilding the RPM. A better fix would be to provide a
php-gd-4.0.3pl1-2.i386.rpm package.
Comment 1 Nalin Dahyabhai 2000-12-20 12:13:32 EST
We've got a PHP 4.0.4 errata in the pipeline for this.
Comment 2 Scott Russell 2000-12-20 14:17:17 EST
Will the php-4.0.4 errata apply to 6.2 as well?
Comment 3 Nalin Dahyabhai 2000-12-20 14:43:58 EST
I'm afraid not.  There are already multiple versions of PHP (2.x and 3.x)
available for 6.2.  Major version updates are not usually introduced as errata
unless they're security-related.
Comment 4 Need Real Name 2001-02-03 14:39:00 EST
php-4.0.4 installed and still not working with GD

Note You need to log in before you can comment on or make changes to this bug.