This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 223939 - X800 XT AIW AGP card causes crash soon after booting in FC-6. Doesn't in FC-5.
X800 XT AIW AGP card causes crash soon after booting in FC-6. Doesn't in FC-5.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-23 01:19 EST by Geoffrey Morrison
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-09 17:22:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg config. (588 bytes, text/plain)
2007-02-04 14:51 EST, Geoffrey Morrison
no flags Details
Xorg config backup. (769 bytes, application/octet-stream)
2007-02-04 14:56 EST, Geoffrey Morrison
no flags Details
Xorg log. (53.84 KB, text/plain)
2007-02-04 14:56 EST, Geoffrey Morrison
no flags Details
Xorg old log. (53.84 KB, text/plain)
2007-02-04 14:57 EST, Geoffrey Morrison
no flags Details
Xorg setup log (3.91 KB, text/plain)
2007-02-04 14:57 EST, Geoffrey Morrison
no flags Details
I removed the nVidia Card. Performance improves. Still crashes randomly, but soon. (990 bytes, application/octet-stream)
2007-02-18 15:54 EST, Geoffrey Morrison
no flags Details
More requested files. (863 bytes, application/octet-stream)
2007-02-18 15:55 EST, Geoffrey Morrison
no flags Details
More requested files. (55.71 KB, text/plain)
2007-02-18 15:56 EST, Geoffrey Morrison
no flags Details
More requested files. (55.76 KB, text/plain)
2007-02-18 15:56 EST, Geoffrey Morrison
no flags Details
More requested files. (3.91 KB, text/plain)
2007-02-18 15:57 EST, Geoffrey Morrison
no flags Details
More requested files. (990 bytes, application/octet-stream)
2007-02-18 16:03 EST, Geoffrey Morrison
no flags Details

  None (edit)
Description Geoffrey Morrison 2007-01-23 01:19:40 EST
Description of problem: X800 XT AIW card causes crash in FC-6 somewhat soon
after booting with default driver. However, card works in FC-5. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Crashes every boot.
2.
3.
  
Actual results:


Expected results:


Additional info: I know I could try fgrlx, etc (this may likely succeed). Get
around problem with installed BFG Geforce FX-5500 PCI card (used also to boot
into Win98 since ATi will not provide drivers for Win98 for any AGP chipset
post-generation 9800XT)--this PCI card works great--true multi-res and sys
doesn't crash at idle. (May try advanced drivers and Gatos at later time with
AIW card.) After using AGP card for Windows XP, have to reboot, make bios change
from AGP to PCI detection, then switch VGA cable from AGP card to PCI card.
(Perhaps existence of installed PCI card is prob....)

I suspect this crashing could be a problem for those w/o an alternate pci (or
secondary AGP) card installed or with only an ATi AGP card post-generation
9800XT. Crashing may not give time to try (easily) to install fgrlx....

Sys also uses socket 754 Abit 3rd eye board and with 32-bit AMD Sempron 3300+
CPU, 1G Rosewill DDR-400 mem stick, Samsung 160GB 1.5 SATA drive (HD160jj).
Rosewill 500W PS. No OC. 

This is not urgent to me--I just felt you should be aware of this....
Comment 1 Geoffrey Morrison 2007-01-23 01:22:52 EST
Also, Rosewill PV1960 19" LCD monitor is not detected (as plug and play) with
AIW card, but is with BFG 5500 card. 
Comment 2 Matěj Cepl 2007-01-24 10:47:45 EST
a) no, you really shouldn't try fgrlx -- we don't support binary-only drivers
and if you would file a bug with this driver, we would close the bug until you
would be able to reproduce it with open source drivers.
b) it would be really helpful if you could attach as uncompressed individual
attachments to this bug your X server config file (/etc/X11/xorg.conf) and X
server log file (/var/log/Xorg.*.log). Could you please also try to run without
any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video
card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Geoffrey Morrison 2007-02-04 14:51:24 EST
Created attachment 147322 [details]
Xorg config.

At this point, the pci card is still in.... Other info you requested is coming.
Comment 4 Geoffrey Morrison 2007-02-04 14:56:26 EST
Created attachment 147323 [details]
Xorg config backup.
Comment 5 Geoffrey Morrison 2007-02-04 14:56:54 EST
Created attachment 147324 [details]
Xorg log.
Comment 6 Geoffrey Morrison 2007-02-04 14:57:22 EST
Created attachment 147325 [details]
Xorg old log.
Comment 7 Geoffrey Morrison 2007-02-04 14:57:53 EST
Created attachment 147326 [details]
Xorg setup log
Comment 8 Geoffrey Morrison 2007-02-18 15:54:48 EST
Created attachment 148303 [details]
I removed the nVidia Card. Performance improves. Still crashes randomly, but soon.

Sorry I've been so slow getting back to you. I just put a Sapphire 9600XT-U in;
I'm not having any problem with the Sapphire card at all. (The driver works OK
with that level of ATi card.) A few minutes ago, I removed the nVidia FX
5500-based PCI card before this and got the Xorg files; removing this PCI card
helped, some.... I think I'll "roost" here for awhile with this card (alone)
unless you wish me to do something else with the X800XT.... 

Anyway, I was able (haltingly) to get further along in config of the X800XT AIW
after removing the 5500 PCI card(res. 800X600 --> 1280X1064), also, I was able
to choose generic LCD as the monitor type; I was not able to before. Certain
text in dialog boxes and other text seems to have (and had) colored artifacts.
Randomly, the sys still crashes (always soon: within minutes or seconds) with
the X800XT card. I wish it was a 9800XT or 9800Pro AIW, instead.... The card
does not show artifacts in Windows XP, and it certainly does not crash like
this in that OS. I cannot get Omega Drivers to work with it in Windows 98SE,
either--in that OS, it's limited to 640X480 and 16 colors with Standard VGA. It
doesn't crash 98SE, however.
Comment 9 Geoffrey Morrison 2007-02-18 15:55:50 EST
Created attachment 148304 [details]
More requested files.
Comment 10 Geoffrey Morrison 2007-02-18 15:56:20 EST
Created attachment 148305 [details]
More requested files.
Comment 11 Geoffrey Morrison 2007-02-18 15:56:56 EST
Created attachment 148306 [details]
More requested files.
Comment 12 Geoffrey Morrison 2007-02-18 15:57:09 EST
Created attachment 148307 [details]
More requested files.
Comment 13 Geoffrey Morrison 2007-02-18 16:03:59 EST
Created attachment 148308 [details]
More requested files.

One more comment: After I removed the PCI card, then after X couldn't start,
the OS did reconfigure for the X800XT Radeon (automatically), and X did start,
automatically. With the PCI card in, I would have to change the driver in the
"Display" preferences to the ATi driver from the NV driver, reboot, change the
bios setting from PCI to AGP, and re-position the monitor cable.
Comment 14 Geoffrey Morrison 2007-04-04 13:27:56 EDT
matej, 

I doubt if the prob has disappeared. I'm surprised that no one else seems to 
have had this pop up....

I'm installing the the AIW card yet again. And, if I need the PCI card for 
Fedora again, I'll install it. And, I'll relate if behavior changes (with FC-6 
auto-upgrades). 

As a side note, I've tried to get networking in FC-6 on this sys using 
ndiswrapper (with a common D-link usb wireless adapter that works well in XP) 
to work without success. I think the brilliant solution proposed by a chemist 
frustrated with Fedora and poor networking driver support for wireless access 
adapters (i.e., using a wireless access point feeding the nic instead) is 
better (I'll soon find out). Ndiswrapper often is required because of poor 
vendor support for Linux. I don't think attempting to get networking to work 
affects the video driver problem, but I thought you should be aware....
Comment 15 Adam Jackson 2007-04-09 19:06:59 EDT
If you rename /usr/lib/xorg/modules/extensions/libdri.so to something else, does
X start?  (Effectively you're just disabling DRI.)
Comment 16 Geoffrey Morrison 2007-04-13 01:57:41 EDT
Ajax, I'll give that a try. I still need to replace the 9600xt with the X800XT
AIW.  (I've been struggling with networking in Linux; the access point idea
seems to be a failure, so far, even in Windows.) I did replace the heatsink on
the  AIW card with one of those large blue Kingwin heatpipe heatsinks, as well
as adding copper vga ramsinks. I think the card, as is often the case with that
model, runs hot, and I've had good luck in the past with that heatpipe cooler
(it's somewhat of an extreme solution, just short of water cooling; the video
card assembly becomes quite large, taking up at least two slots). I think the
card should perform better, also.
Comment 17 Geoffrey Morrison 2007-06-09 17:22:15 EDT
Sorry, I just finally got the file you wished renamed deleted (I finally had the
bright idea to use bash, "rm"--duh). The driver for my Logitech trackball didn't
load, so that may be why I had enough time to delete that file.

The PC no longer crashes, but resolutions with the radeon driver are limited to
800X600 and 640X480 at 56 and 60 hz. Garbled output on TV out instead of no
signal--it seems to be "trying" to write correctly to TV, an improvement.

The vesa driver appears to work and offers a much fuller choice of resolutions.
The desktop doesn't fill up the screen, however, and tv-out gives not output. 

If it's OK with you, I desire to upgrade that sys to Fedora 7 "Moonshine."
Frankly, fc-6 "Zod" has been troublesome for many users. It's OK with me if you
wish to mark this problem as solved, with a few limitations. I can now use Linux
on that sys with out switching drivers, bios settings, or cards. Thanks!

As for networking, I solved that problem: I think a very good answer is the new
powerline (homeplug) ethernet devices. (Panasonic's version doesn't rely upon an
OS for config at all, so I think it's currently the best choice for Linux.) I
seem to use the remote terminal (with the AIW) for surfing more than this main
node at the router--internet away from the router even using Linux seems to be
seamless and trouble-free with this solution. As for wireless, I think one needs
an expensive wireless ethernet bridge if ndiswrapper or drivers for cards/usb
stubs can't be made to work, yet, transmission issues (distance/obstructions)
must still be solved (with expensive repeaters or antennae).

Note You need to log in before you can comment on or make changes to this bug.