Bug 223969 - Package requires stricter BR (libgnomeui2-devel, gnome-icon-theme)
Summary: Package requires stricter BR (libgnomeui2-devel, gnome-icon-theme)
Alias: None
Product: Fedora
Classification: Fedora
Component: evince   
(Show other bugs)
Version: rawhide
Hardware: All All
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
Whiteboard: bzcl34nup
Depends On:
TreeView+ depends on / blocked
Reported: 2007-01-23 12:36 UTC by Moritz Barsnick
Modified: 2008-05-07 01:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-07 01:05:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Moritz Barsnick 2007-01-23 12:36:01 UTC
Description of problem:
The current SPEC file of evince requires stricter (or enhanced) BuildRequires.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. use FC6
2. rpmbuild --rebuild [...] evince-0.7.1-1.fc7.src.rpm
Actual results:

checking for FRONTEND_CORE... configure: error: Package requirements (gtk+-2.0 
>= 2.8.15 libgnomeui-2.0 >= 2.14.0 gnome-icon-theme >= 2.17.1 libglade-2.0) 
were not met:

Requested 'gnome-icon-theme >= 2.17.1' but version of gnome-icon-theme is

Expected results:
BR catches this ahead of time.

Additional info:
-BuildRequires: libgnomeui-devel
+BuildRequires: libgnomeui-devel >= 2.14.0
+BuildRequires: gnome-icon-theme >= 2.17.1
just from looking at the "Package requirements" output above and porting it 
into BR. :-)

Comment 1 Moritz Barsnick 2007-01-23 12:46:17 UTC
D'uh. use the source, Luke. :)
Looking into configure.ac, one might see that it's even stricter (though not 
affecting FC6, obviously):


So additionally:
-%define dbus_version 0.60
+%define dbus_version 0.71
-BuildRequires:  libgnomeprintui22-devel
+BuildRequires:  libgnomeprintui22-devel >= 2.6.0

and possibly:
+BuildRequires: libxml2-devel >= 2.5.0
+BuildRequires: gnome-keyring-devel >= 0.4.0

and perhaps even some versioned Requires:, depending on whether the version is 
coded into the soname of the libs or not.

All only if you want to be totally correct about it (which doesn't hurt, does 

Comment 2 Bug Zapper 2008-04-03 18:55:54 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 3 Bug Zapper 2008-05-07 01:05:48 UTC
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:

Note You need to log in before you can comment on or make changes to this bug.