Bug 224074 - address book does not work properly when language is set to Dutch
address book does not work properly when language is set to Dutch
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks: 229658
  Show dependency treegraph
 
Reported: 2007-01-23 16:56 EST by Armijn Hemel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: evolution-data-server-1.8.3-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-22 14:51:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing the problem. (860 bytes, patch)
2007-02-21 16:15 EST, Patrick Monnerat
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 405531 None None None Never

  None (edit)
Description Armijn Hemel 2007-01-23 16:56:43 EST
Description of problem:

When I have my system set to Dutch the address book doesn't work properly.
Contacts do not show up when "any category" is selected. It does work when the
system is set to English. I have to support a few people whose knowledge of
English is not that good and this really bugs them.


Version-Release number of selected component (if applicable):

evolution-2.8.2.1-3.fc6

How reproducible:

Always

Steps to Reproduce:
1. Set system language to Dutch
2. add contacts
3. make new message
  
Actual results:

Contacts do not show up in "any category"

Expected results:

Contacts should be visible in the "any category", no matter what language is
selected.

Additional info:

I don't know if just Dutch is affected. I will try with other languages, at
least the once I can decipher :P
Comment 1 Armijn Hemel 2007-01-23 17:09:20 EST
I tested some more with various languages (German, Spanish, Afrikaans). There it
works, but it seems that for those languages the category selector was not
translated. If I choose there I get "Any Category" in English instead of "Any
Category" in $LANGUAGE.

It must be some weird translation thing that is preventing the correct working.
How can I test this better (as in, how can I regenerate the .po files?)
Comment 2 Armijn Hemel 2007-01-23 17:36:49 EST
This actually happens in the dataserver, changing
Comment 3 Armijn Hemel 2007-01-23 17:39:04 EST
#: ../libedataserverui/e-name-selector-dialog.c:122
msgid "Any Category"
msgstr "Alle categorieën"

in nl.po should indicate where the error is. None of the other languages have
this string translated, only the Dutch one. This is also the part where the
error seems to occur.
Comment 4 Armijn Hemel 2007-01-25 17:01:10 EST
Removing this line (and thus defaulting to English in this piece of the user
interface) gets rid of my problem. So, I now have confirmation that it happens
because of this translation. Why it happens I don't know...
Comment 5 Patrick Monnerat 2007-02-20 14:57:15 EST
Same problem in french.
LANG=fr_FR.UTF8

The proposed temporary bypass by suppressing the "Toute catégorie" translation
is satisfactory for now.

I just note that both translations have a non-ASCII character (accentuated e).
This might be the problem, although I did not tested it.
Comment 6 Patrick Monnerat 2007-02-21 16:15:30 EST
Created attachment 148535 [details]
Patch fixing the problem.

This patch fixes the problem properly (without affecting translations).
The bug was not accent-related: the translated string in the menu was compared
to the untranslated "Any Category" string at menu change time, causing failure
for non-english strings.
The solution retained in the patch is to check the menu item index being 0
rather than comparing strings; this is possible since we know that the "Any
category" menu item is always the first.
Comment 7 Matthew Barnes 2007-02-22 08:01:30 EST
Thanks for the patch!  As it turns out, I just recently fixed this upstream [1].
 The string "Any Category" is already translated in other places; it appears
this instance was simply overlooked.  But your solution would work as well.

I'll get this fixed in Fedora Core 6 and Rawhide.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=405531
Comment 9 Matthew Barnes 2007-02-22 14:51:27 EST
Fixed in evolution-data-server-1.8.3-2.fc6.

This should hit Fedora Updates Testing in the next day or so.

Note You need to log in before you can comment on or make changes to this bug.