Bug 224085 - kernel-2.6.19-1.2895.fc6 errors in compile
kernel-2.6.19-1.2895.fc6 errors in compile
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Depends On:
  Show dependency treegraph
Reported: 2007-01-23 19:14 EST by Dave Feldbauer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-24 03:46:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave Feldbauer 2007-01-23 19:14:48 EST
Description of problem:after install kernel update 2.6.19-1.2895.fc6 (updating
from 2.6.18-1.2869.fc6) I tried to remake network drivers for realtek rtl8187l
usb wireless card.  I have compiled these drivers in the older kernel and they
compiled and worked.  Now on compile i get this error 

/r8187_core.c:2421: error: ‘struct net_device’ has no member named
when trying to compile the drivers

Version-Release number of selected component (if applicable):

How reproducible:

Every time

Steps to Reproduce:
1.compile drivers from Realtek rtl8187_linux_26.1010.zip
Actual results:

compiling exits with errors

/r8187_core.c:2421: error: ‘struct net_device’ has no member named
when trying to compile the drivers
Expected results:
drivers should compile

Additional info:

please contact for any additional logs or info
Comment 1 Jakub Jelinek 2007-01-24 03:46:33 EST
That doesn't sound like a gcc bug, simply you downloaded some outdated kernel
module sources that is incompatible with recent changes in the kernel.

Note You need to log in before you can comment on or make changes to this bug.