Bug 224138 - Problems with video capture cards.
Problems with video capture cards.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xawtv (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 07:19 EST by Paul van de Velde
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 05:11:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul van de Velde 2007-01-24 07:19:56 EST
Description of problem:
Video capture card not working with PV-149.
But I have seen other video capture cards also reported as not working.
See for this: http://www.mail-archive.com/mjpeg-
users@lists.sourceforge.net/msg07044.html 

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
[root@localhost dev]# xawtv -hwscan 
This is xawtv-3.95, running on Linux/i686 (2.6.18-1.2849.fc6) 
looking for available devices 
/dev/video0: OK [ -device /dev/video0 ] 
type : v4l2 
name : BT878 video (ProVideo PV150) 
flags: overlay capture 

/dev/video1: OK [ -device /dev/video1 ] 
type : v4l2 
name : BT878 video (ProVideo PV150) 
flags: overlay capture 

/dev/video2: OK [ -device /dev/video2 ] 
type : v4l2 
name : BT878 video (ProVideo PV150) 
flags: overlay capture 

/dev/video3: OK [ -device /dev/video3 ] 
type : v4l2 
name : BT878 video (ProVideo PV150) 
flags: overlay capture 

But getting: 
[root@localhost dev]# xawtv -device /dev/video0 
This is xawtv-3.95, running on Linux/i686 (2.6.18-1.2849.fc6) 
WARNING: v4l-conf is compiled without DGA support. 
WARNING: couldn't find framebuffer base address, try manual 
configuration ("v4l-conf -a <addr>") 
ioctl: VIDIOC_OVERLAY(int=1): Invalid argument 
ioctl: VIDIOC_OVERLAY(int=1): Invalid argument 
ioctl: VIDIOC_OVERLAY(int=1): Invalid argument 
ioctl: VIDIOC_OVERLAY(int=1): Invalid argument 
ioctl: VIDIOC_OVERLAY(int=1): Invalid argument 
ioctl: VIDIOC_OVERLAY(int=1): Invalid argument 
ioctl: VIDIOC_OVERLAY(int=1): Invalid argument
  
XAWTV does not work.

After some investigations I found:

It seems to be a FC6 issue. You have to find the framebuffer address 
under /dev/log/Xorg.0.log. Do a search for framebuffer and you will find the 
address. 

The address is 0xF000 0000. One can set it n XAWTV with the command: 
v4l-conf -a 0xF0000000. 

Now the question is how to do this adaptation for ZoneMinder? 
This last step I could not find out and for this reason I would like to have the
bug fixed. As if the Framebuffer address is correctly set the last application 
will also work.

Actual results:
XAWTV not working.


Expected results:
XAWTV should start up correctly

Additional info:
Comment 1 Ngo Than 2007-01-25 05:11:51 EST
xawtv is not included in FC6 and Extras. You should report the problem
to the Autor please. Thanks

Note You need to log in before you can comment on or make changes to this bug.