Bug 224165 - rebuild error on a rawhide system
rebuild error on a rawhide system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Radek Bíba
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 09:20 EST by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-02 07:18:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2007-01-24 09:20:22 EST
Description of problem:
/bin/sh ../libtool --silent --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I.
-I.. -I../dcop -I../kdecore -I../kio/kssl -I../kjs -I.. -I../dcop -I../libltdl
-I../kdefx -I../kdecore -I../kdecore -I../kdecore/network -I../kdeui -I../kio
-I../kio/kio -I../kio/kfile -I.. -I/usr/lib/qt-3.3/include -I.
-I/usr/include/kde   -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wno-long-long -Wundef
-ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion
-Wchar-subscripts -Wall -W -Wpointer-arith -fno-builtin -g -O2
-fno-schedule-insns -fno-inline -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables -Wformat-security
-Wmissing-format-attribute -Wno-non-virtual-dtor -fno-reorder-blocks
-fno-exceptions -fno-check-new -fno-common  -DQT_CLEAN_NAMESPACE
-DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -c -o
publicservice.lo publicservice.cpp
remoteservice.cpp: In member function 'void DNSSD::RemoteService::resolveAsync()':
remoteservice.cpp:105: error: invalid conversion from 'void
(*)(_DNSServiceRef_t*, DNSServiceFlags, uint32_t, DNSServiceErrorType, const
char*, const char*, uint16_t, uint16_t, const char*, void*)' to 'void
(*)(_DNSServiceRef_t*, DNSServiceFlags, uint32_t, DNSServiceErrorType, const
char*, const char*, uint16_t, uint16_t, const unsigned char*, void*)'
remoteservice.cpp:105: error:   initializing argument 7 of 'DNSServiceErrorType
DNSServiceResolve(_DNSServiceRef_t**, DNSServiceFlags, uint32_t, const char*,
const char*, const char*, void (*)(_DNSServiceRef_t*, DNSServiceFlags, uint32_t,
DNSServiceErrorType, const char*, const char*, uint16_t, uint16_t, const
unsigned char*, void*), void*)'
make[2]: *** [remoteservice.lo] Error 1

Version-Release number of selected component (if applicable):
kdelibs-3.5.5-1.fc7
Comment 1 Rex Dieter 2007-04-30 13:31:14 EDT
what arch?
Comment 2 Karsten Hopp 2007-05-01 10:33:35 EDT
most likely x86_64, but I'm not sure
Comment 3 Ngo Than 2007-05-02 07:18:56 EDT
i cannot reproduce it. it seems to be fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.