Bug 224232 - kdump.conf core_collector parameter doesn't work without kernel-debuginfo installed
kdump.conf core_collector parameter doesn't work without kernel-debuginfo ins...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 13:36 EST by Ryan Kelley
Modified: 2009-09-09 01:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-05 07:27:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Kelley 2007-01-24 13:36:34 EST
Description of problem:
mkdumprd fails with error:
"kernel-debuginfo-`uname -r` is not installed.  You need this to use 
makedumpfile!" 
when trying to use the "core_collector makedumpfile" command 
in /etc/kdump.conf.

kernel-debuginfo package is not shipped with RHEL5.

Version-Release number of selected component (if applicable):
RHEL5 Beta 2

How reproducible:
always

Steps to Reproduce:
1. add "core_collector makedumpfile -c" to /etc/kdump.conf
2. reboot or run /etc/init.d/kdump restart
3. rebuild of kdump ramdisk will fail with above error.
  
Actual results:
the core_collector parameter in /etc/kdump.conf does not work (for example to 
automatically compress core files).

Expected results:
the core_collector command should be functional without the kernel-debuginfo 
package installed (or that package should ship with the OS).

Additional info:
Comment 2 Jarod Wilson 2007-03-02 19:45:42 EST
This behavior is entirely intentional as well as correct when you're using makedumpfile -c as a 
core_collector. The makedumpfile utility *requires* debuginfo to properly compress vmcores. However, 
since using makedumpfile isn't a requirement (and in fact isn't possible for some types of dumps), kernel-
debuginfo isn't a hard Requires: for the kexec-tools package. The core_collector parameter works just fine 
if you use something other than makedumpfile (in fact, out of the box, I believe core_collector actually 
winds up being set to 'cp' behind the scenes).

Oh, and kernel-debuginfo *is* available for RHEL5. I can't remember if we were going to ship them on a 
CD, or they're only available via ftp or what, but they do exist and are (or will be) available.
Comment 3 Neil Horman 2007-03-05 07:27:56 EST
Yeah, this is notabug.  debuginfo packages are required when using makedumpfile,
and there is currently no real way around that.  IIRC, the debuginfo packages
will eventually be available via ftp or RHN.

Note You need to log in before you can comment on or make changes to this bug.