This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 22427 - problems building CPAN modules with standard perl
problems building CPAN modules with standard perl
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-17 18:10 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-17 18:11:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-17 18:10:58 EST
Please see the description I posted to the guiness-list with the answer
from Jakub Jelinek who asked me to send a bugzilla.
Below is a list that locate sem.h prints on my machine:
$ locate sem.h
/usr/local/include/sys/sem.h
/usr/include/linux/sem.h
/usr/include/bits/sem.h
/usr/include/sys/sem.h
/usr/src/linux-2.2.5/include/linux/sem.h
/usr/src/linux-2.2.16/include/linux/sem.h
/usr/i386-glibc21-linux/include/bits/sem.h
/usr/i386-glibc21-linux/include/linux/sem.h
/usr/i386-glibc21-linux/include/sys/sem.h

Regards,

Kerem Yaman


On Mon, Dec 11, 2000 at 01:34:12AM -0500, Kerem Yaman wrote:
> Does anybody know why I could be getting the following error when trying
> to install some CPAN packages on 7.0 standard perl installation. I have
> not played with Perl for a while (proabably since 5.2 or so). So I am
> not sure if this is a known problem or not. And I don't see a newer
> version of perl than I have on the errate pages.
> 
> During make of MIME::Base64 I get:
> 
> gcc -c  -fno-strict-aliasing -O2 -march=i386 -mcpu=i686
> -DVERSION=\"2.11\" -DXS_VERSION=\"2.11\" -fPIC
> -I/usr/lib/perl5/5.6.0/i386-linux/CORE  Base64.c
> In file included from Base64.xs:33:
> /usr/lib/perl5/5.6.0/i386-linux/CORE/perl.h:3205: redefinition of `union
> semun'
> make: *** [Base64.o] Error 1
>   /usr/bin/make  -- NOT OK
> Running make test
>   Can't test without successful make
> Running make install
>   make had returned bad status, install seems impossible
> 
> I also get it when installing other packages but this one does depend on
> other CPAN packages so I know the problem is in the redefinition of
> `union semun' line right here.

Please file this into http://bugzilla.redhat.com/bugzilla/
It might as well be bug in that Base64 code, glibc does not define union
semun in its headers, so Perl is correct in declaring it.
Maybe some source includes some kernel headers which define it (such as
<linux/sem.h>), that would be the bug.

        Jakub
Comment 1 David Lawrence 2001-02-13 18:10:34 EST
I was not able to get these compile errors to occur on a standard 7.0 install
using perl-5.6.0-9. I was also unable to get this to happen on a machine running
fisher beta which now has perl-5.6.0-11 installed. Does this still occur if you
upgrade to the latest perl rpm from rawhide? Please try upgrading and reopen
this bug report if it still occurs.
Comment 2 Need Real Name 2001-02-20 22:46:31 EST
Thanks, it was library conflicts on my machine causing the problem it works now.

Note You need to log in before you can comment on or make changes to this bug.