Bug 224305 - The code of testplan error messages need to be re-worded
The code of testplan error messages need to be re-worded
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: XINSUN
Yu Shao
:
Depends On:
Blocks: 238481
  Show dependency treegraph
 
Reported: 2007-01-25 00:41 EST by heyinglong
Modified: 2008-10-28 02:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 02:17:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Test Plan Error Msg List (1.65 KB, patch)
2008-08-10 23:32 EDT, XINSUN
no flags Details | Diff
Patch Fix. (3.17 KB, patch)
2008-08-15 09:52 EDT, XINSUN
no flags Details | Diff
Patch Improve. (6.10 KB, patch)
2008-08-19 05:25 EDT, XINSUN
no flags Details | Diff

  None (edit)
Description heyinglong 2007-01-25 00:41:25 EST
Description of problem:

The code of testplan error messages need to be re-worded.  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 XINSUN 2008-08-10 23:32:40 EDT
Created attachment 313905 [details]
Test Plan Error Msg List

This attachment lists all the error messages relate to Testplan.
Comment 2 Rob Landry 2008-08-11 10:34:16 EDT
Parse failure - based on the message it looks like we should address the code and not limit to 150 characters.

Testplan_leverage_format_error - probably need to smarten this up a bit, leverage #'s can be bug ID's or test ID's, so either split this into two errors or just simplify this into the "leverage ID".

Test_does_not_exist - "...press back and enter a" instead of "select a".

Test_ID_is_in_this_certification - seems ok to me.

hwcert_group_access_denied - should probably call the generic group permission error instead of being it own.  Will also need to check the remainder of the catalog code to see if anything else calls this one off version.

Missing Test Plan Class - this would be a marked improvement if it provided the description for each line that is missing a class.

Testplan_freeze_error - error message doesn't make much sense, I think it's again trying to tell the user they don't have permission to change something but this time it's not group permissions but because the test plan is frozen, probably the simply solution is to have an error message which is "permission denied, testplan frozen" or similar?
Comment 3 XINSUN 2008-08-15 09:52:12 EDT
Created attachment 314389 [details]
Patch Fix.
Comment 4 XINSUN 2008-08-15 10:14:21 EDT
(In reply to comment #2)
> Parse failure - based on the message it looks like we should address the code
> and not limit to 150 characters.
>

Done in above patch (id=314389).Remove the "Parse failure" error,and not limit to 150 characters.

> Testplan_leverage_format_error - probably need to smarten this up a bit,
> leverage #'s can be bug ID's or test ID's, so either split this into two errors
> or just simplify this into the "leverage ID".

Done.  simplify this into the "leverage ID".



> Test_does_not_exist - "...press back and enter a" instead of "select a".

Done, use "enter a".


 
> Test_ID_is_in_this_certification - seems ok to me.
> 
> hwcert_group_access_denied - should probably call the generic group permission
> error instead of being it own.  Will also need to check the remainder of the
> catalog code to see if anything else calls this one off version.
> 

No change yet in above patch. because the current user-error.html.tmpl does not have the generic group permission error, so suggest still use that error msg?

> Missing Test Plan Class - this would be a marked improvement if it provided the
> description for each line that is missing a class.

No change yet in above patch,Because this error msg is only throw for checking if each required testplan item has a selected class when frozen testplan.Need more info?

> Testplan_freeze_error - error message doesn't make much sense, I think it's
> again trying to tell the user they don't have permission to change something
> but this time it's not group permissions but because the test plan is frozen,
> probably the simply solution is to have an error message which is "permission
> denied, testplan frozen" or similar?

change the error msg to "Permission denied, testplan frozen."


Thanks a lot.
Nicho
Comment 5 Rob Landry 2008-08-18 14:34:48 EDT
hwcert_group_access_denied - rephrase to something similar to:

    [% title = "Permission Denied" %]
    You do not have permission to 


Missing Test Plan Class - this error message would be much more useful if it was more similar to:

    [% title = "Missing Class" %]

The test plan could not be frozen because the follow line items do have have classes defined:

{list of testplan line descriptions that are missing a class).


testplan_freeze_error - I think your saying this shows up because it can't freeze an already frozen testplan?  If so it should be name so that the error cause is obvious by the error name, also the text should be 'testplan already frozen' and we should verify in the UI that this isn't something that you can select.
Comment 6 XINSUN 2008-08-19 05:25:52 EDT
Created attachment 314522 [details]
Patch Improve.

Note You need to log in before you can comment on or make changes to this bug.