Bug 22447 - Pdflatex core dumps if png file included
Pdflatex core dumps if png file included
Status: CLOSED DUPLICATE of bug 21263
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-18 09:08 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-27 20:11:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-18 09:08:51 EST
I have RedHat 6.1 Cartman distribution and tetex worked
fine up to the point when I upgraded several things including kernel and
glibc
for the latest updates (from RedHat errata/updates).
Then pdflatex started to core-dump regularly on any
png file included by \includegraphics. I fixed it by upgrading to tetex
from
RedHat 6.2 distribution and it works fine now.

I think that the problem is reproducible and
more people might have the same problem, however I did not downgrade back
to
old glibc libraries to verify whether it works.

If this is problem of glibc, than
I would be very happy to have this fixed, because I would actually
like to use an earlier version of tetex with special czech
localization (tetex-0.9cs-10), that has an exacly same problem as
original tetex-1.0.6-7 from RedHat. I am not very happy to use
the newest tetex-1.0.6-11 as it lacks this localization, 
that is very important to me. Or I would like to know what was changed
between tetex-1.0.6-7 and tetex-1.0.6-11 so that I could make 
the fix of tetex-0.9cs-10 as well (if I find sources).

Many further details follow:

Problem run of pdflatex:

bash[tesar@pc208 ~/tex] pdflatex mari2001.tex
.....
[9] <prepro-schema.pdf 893.3375pt, 201.75374pt, obj 139>
<use prepro-schema.pdf>
Overfull \vbox (98.77191pt too high) has occurred while \output is active
[10 <./prepro-schema.pdf>] <mapa2.png 853.18748pt, 702.62498pt, obj 149>
<use mapa2.png>
Overfull \vbox (98.77191pt too high) has occurred while \output is active
[11 <./mapa2.png>pdflatex: xfopen.c:43: xfclose: Assertion `f' failed.
Aborted (core dumped)
bash[tesar@pc208 ~/tex] $

My new glibc and kernel that probably caused troubles with tetex:

bash[tesar@pc208 ~] $ rpm -qa | grep glibc 
glibc-devel-2.1.3-21
compat-glibc-5.2-2.0.7.1
glibc-2.1.3-21

bash[tesar@pc208 ~] $ rpm -qa | grep kernel
kernel-pcmcia-cs-2.2.16-3
kernel-2.2.16-3
kernel-utils-2.2.16-3
kernelcfg-0.5-5
kernel-smp-2.2.16-3
kernel-headers-2.2.16-3
kernel-source-2.2.16-3

My original tetex packages:

tetex-1.0.6-7
tetex-afm-1.0.6-7
tetex-doc-1.0.6-7
tetex-dvilj-1.0.6-7
tetex-dvips-1.0.6-7
tetex-fonts-1.0.6-7
tetex-latex-1.0.6-7
tetex-xdvi-1.0.6-7

replaced by packages from RedHat 6.2 and it worked then:

tetex-1.0.6-11
tetex-afm-1.0.6-11
tetex-doc-1.0.6-11
tetex-dvilj-1.0.6-11
tetex-dvips-1.0.6-11
tetex-fonts-1.0.6-11
tetex-latex-1.0.6-11
tetex-xdvi-1.0.6-11

Regards,

Ludvik
Comment 1 Jeff Johnson 2000-12-27 20:11:37 EST
Can you provide a test case of the failure?
Comment 2 Jeff Johnson 2000-12-27 21:11:02 EST

*** This bug has been marked as a duplicate of 21263 ***

Note You need to log in before you can comment on or make changes to this bug.