Bug 224554 - bmptoppm stopps with "BMPlencolormap: internal error!"
Summary: bmptoppm stopps with "BMPlencolormap: internal error!"
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: netpbm   
(Show other bugs)
Version: 6
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-26 13:50 UTC by Herbert Gasiorowski
Modified: 2013-07-02 23:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 14:08:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image to reproduce this bug (test.ppm) (16.42 KB, image/x-portable-pixmap)
2007-01-27 10:55 UTC, Herbert Gasiorowski
no flags Details

Description Herbert Gasiorowski 2007-01-26 13:50:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:
Using kickstart to install fedora 0.94 with (any)
"xconfig" option causes anaconda to exit abnormally.

Version-Release number of selected component (if applicable):

netpbm-progs-10.35-6.fc6

How reproducible:
Always

Steps to Reproduce:
1. execute "ppmtobmp test.ppm | bmptoppm > x.ppm"
    

Actual Results:
ppmtobmp: analyzing colors...
ppmtobmp: 6 colors found
ppmtobmp: Writing 4 bits per pixel with a color palette
bmptoppm: BMPlencolormap: internal error!

Expected Results:
With previous versions the following is shown and a BMP is produced:
ppmtobmp: analyzing colors...
ppmtobmp: 6 colors found
ppmtobmp: Writing 4 bits per pixel with a color palette
bmptoppm: Windows BMP, 100x56x4
bmptoppm: WRITING PPM IMAGE

Additional info:

Comment 1 Jindrich Novy 2007-01-26 15:49:42 UTC
Could you please attach the test.ppm image?

Comment 2 Jindrich Novy 2007-01-26 16:01:59 UTC
Never mind, I reproduced it successfully with my sample image.

Comment 3 Herbert Gasiorowski 2007-01-27 10:55:35 UTC
Created attachment 146742 [details]
Image to reproduce this bug (test.ppm)

Just to make shure (I thought I had attached it - but something went wrong ...)

Comment 4 Jindrich Novy 2007-01-29 12:44:52 UTC
Ok, bmptopnm uses condition dependent on uninitialized BMPheader structure
member what causes the internal error as it doesn't read the header at all when
the uninitialized member is zero.

It is now fixed since 10.35-10 in rawhide. FC updates are comming soon.

Comment 5 Alexey Tourbin 2007-08-19 19:40:45 UTC
Actually this bug was added with netpbm-10.22-cmapsize.patch.
You then revert the change with netpbm-10.27-bmptopnm.patch.
You should merge both patches so that they annihilate each other.

-- 
Alexey Tourbin
ALT Linux Team

Comment 6 Jindrich Novy 2007-08-20 12:48:52 UTC
Fixed, thanks.


Note You need to log in before you can comment on or make changes to this bug.