This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 22460 - Fortran compiler error
Fortran compiler error
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: egcs (Show other bugs)
6.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-18 14:41 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 18:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-18 14:41:20 EST
Hi,

I converting a piece of software that is running properly under AIX 4.2.1
when compiled with xlf but i'm having an error under Linux, here the basic
information:

g77 -v:
g77 version 2.95.1 19990816 (release) (from FSF-g77 version 0.5.25 19990816
(release))
Driving: g77 -v -c -xf77-version /dev/null -xnone
Reading specs from /usr/local/lib/gcc-lib/i686-pc-linux-gnu/2.95.1/specs
gcc version 2.95.1 19990816 (release)
 /usr/local/lib/gcc-lib/i686-pc-linux-gnu/2.95.1/cpp -lang-c -v -D__GNUC__=2
-D__GNUC_MINOR__=95 -D__ELF__ -D__unix__ -D__i386__ -D__linux__ -D__unix
-D__linux -Asystem(posix) -D_LANGUAGE_FORTRAN -traditional -Acpu(i386)
-Amachine(i386) -Di386 -D__i386 -D__i386__ -Di686 -Dpentiumpro -D__i686
-D__i686__ -D__pentiumpro -D__pentiumpro__ /dev/null /dev/null
GNU CPP version 2.95.1 19990816 (release) (i386 Linux/ELF)
#include "..." search starts here:
#include <...> search starts here:
 /usr/local/include
 
/usr/local/lib/gcc-lib/i686-pc-linux-gnu/2.95.1/../../../../i686-pc-linux-gn
u/include
 /usr/local/lib/gcc-lib/i686-pc-linux-gnu/2.95.1/include
 /usr/include
End of search list.
The following default directories have been omitted from the search path:
 /usr/local/lib/gcc-lib/i686-pc-linux-gnu/2.95.1/../../../../include/g++-3
End of omitted list.
 /usr/local/lib/gcc-lib/i686-pc-linux-gnu/2.95.1/f771 -fnull-version -quiet
-dumpbase g77-version.f -version -fversion -o /tmp/ccyYej4C.s /dev/null
GNU F77 version 2.95.1 19990816 (release) (i686-pc-linux-gnu) compiled by
GNU C version 2.95.1 19990816 (release).
GNU Fortran Front End version 0.5.25 19990816 (release)
 as -V -Qy -o /tmp/ccLFGWdN.o /tmp/ccyYej4C.s
GNU assembler version 2.9.1 (i386-redhat-linux), using BFD version
2.9.1.0.24
 ld -m elf_i386 -dynamic-linker /lib/ld-linux.so.2 -o /tmp/ccSzEA5g
/tmp/ccLFGWdN.o /usr/lib/crt1.o /usr/lib/crti.o
/usr/local/lib/gcc-lib/i686-pc-linux-gnu/2.95.1/crtbegin.o
-L/usr/local/lib/gcc-lib/i686-pc-linux-gnu/2.95.1 -L/usr/local/lib -lg2c -lm
-lgcc -lc -lgcc /usr/local/lib/gcc-lib/i686-pc-linux-gnu/2.95.1/crtend.o
/usr/lib/crtn.o
 /tmp/ccSzEA5g
__G77_LIBF77_VERSION__: 0.5.25 19990816 (release)
@(#)LIBF77 VERSION 19990503
__G77_LIBI77_VERSION__: 0.5.25 19990816 (release)
@(#) LIBI77 VERSION pjw,dmg-mods 19990503
__G77_LIBU77_VERSION__: 0.5.25 19990816 (release)
@(#) LIBU77 VERSION 19980709

Here's the error when i'm compiling:

if (   0 ) to_simex.com cts17main.f
if ( ! 0 ) /usr/bin/g77 -g -c -fdollar-ok -fno-automatic -finit-local-zero
-ffixed-line-length-132 -fugly-logint -ftypeless-boz -c cts17main.f 
../../../gcc/f/sta.c:510: failed assertion `!ffesta_confirmed_other_'
g77: Internal compiler error: program f771 got fatal signal 6
make: *** [main_lib.a] Error 1

Any clue of what can cause this problem?

Thanxs a lot for your help...
Dominic


P.S.  let me know if you need my input file...
Comment 1 Daniel Roesen 2000-12-18 15:44:15 EST
*** Bug 22461 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Roesen 2000-12-18 15:55:06 EST
*** Bug 22461 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2000-12-18 19:03:56 EST
Um, that's not the compiler we shipped in 6.1. If you'll look at
the include paths it's looking for, you'll note it's looking in
/usr/local/lib and other places.

I suggest uninstalling whatever compiler that is and trying
the egcs-g77 package that shipped with 6.1.
Comment 4 Jakub Jelinek 2000-12-19 04:49:15 EST
We never shipped gcc 2.95.x (g77 -v gives you
g77 version 2.95.1 19990816
), for 6.1 we shipped g77 from egcs 1.1.x and for 7.0 we shipped g77 2.96.
If you find bugs in g77 2.96, we're surely interested in detailed bug reports.
Comment 5 Need Real Name 2000-12-19 09:50:13 EST
I did reinstall the compiler provided with RedHat 6.1, here's the output of g77 -v.

still have the same error...

g77 version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release) (from FSF-g77 version 0.5.24-19981002)
Driving: g77 -v -c -xf77-version /dev/null -xnone
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/specs
gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)
 /usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/cpp -lang-c -v -undef -D__GNUC__=2 -D__GNUC_MINOR__=91 -D__ELF__ -D__unix__ -D__i386__ 
-D__i386__ -D__linux__ -D__unix -D__i386 -D__linux -Asystem(posix) -D_LANGUAGE_FORTRAN -traditional -Asystem(unix) -Acpu(i386) 
-Amachine(i386) -Di386 -D__i386 -D__i386__ -D__tune_i386__ /dev/null /dev/null
GNU CPP version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release) (i386 Linux/ELF)
#include "..." search starts here:
#include <...> search starts here:
 /usr/local/include
 /usr/i386-redhat-linux/include
 /usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/include
 /usr/include
End of search list.
 /usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/f771 -fnull-version -quiet -dumpbase g77-version.f -version -fversion -o /tmp/ccxtCuTL.s /dev/null
GNU F77 version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release) (i386-redhat-linux) compiled by GNU C version egcs-2.91.66 19990314/Linux 
(egcs-1.1.2 release).
GNU Fortran Front End version 0.5.24-19981002
 as -V -Qy -o /tmp/ccafpIas.o /tmp/ccxtCuTL.s
GNU assembler version 2.9.1 (i386-redhat-linux), using BFD version 2.9.1.0.24
 ld -m elf_i386 -dynamic-linker /lib/ld-linux.so.2 -o /tmp/ccl2pbOc /tmp/ccafpIas.o /usr/lib/crt1.o /usr/lib/crti.o 
/usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/crtbegin.o -L/usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66 -L/usr/i386-redhat-linux/lib -lg2c -lm -lgcc -lc -lgcc 
/usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/crtend.o /usr/lib/crtn.o
 /tmp/ccl2pbOc
__G77_LIBF77_VERSION__: 0.5.24
@(#)LIBF77 VERSION 19970919
__G77_LIBI77_VERSION__: 0.5.24-19981021
@(#) LIBI77 VERSION pjw,dmg-mods 19980617
__G77_LIBU77_VERSION__: 0.5.24-19990305
@(#) LIBU77 VERSION 19980709
Comment 6 Jakub Jelinek 2004-10-03 18:34:01 EDT
egcs-1.1.2 or even gcc-2.96-RH is now too old and no testcase has
been provided.  There is nothing we can do.
If you are able to reproduce with contemporary GCC (3.[34] or 4.0),
please reopen with a self-contained testcase.

Note You need to log in before you can comment on or make changes to this bug.