Bug 224620 - AVC_PATH audit records
AVC_PATH audit records
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Viro
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-26 13:37 EST by Steve Grubb
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:22:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2007-01-26 13:37:18 EST
Description of problem:
When no audit rules are loaded and an avc is logged from SE Linux, we are not
getting the AUDIT_AVC_PATH record. The SE Linux users really would like this
information since it identifies the file that is involved in the avc.

Version-Release number of selected component (if applicable):
2.6.18-6el5
Comment 3 RHEL Product and Program Management 2007-04-02 20:46:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Alexander Viro 2007-06-01 10:06:37 EDT
patch posted on linux-audit and selinux list, ACKed, backport
posted on rhkernel-list, got one ACK and no NAKs.
Comment 6 Eric Paris 2007-06-04 17:21:35 EDT
moving to state POST since it was posted to the internal list.
Comment 7 Don Zickus 2007-06-15 20:31:03 EDT
in 2.6.18-27.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 10 errata-xmlrpc 2007-11-07 14:22:28 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.