Bug 224638 - jbd __cleanup_transaction skips last buffer on checkpoint list
jbd __cleanup_transaction skips last buffer on checkpoint list
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Brian Brock
: OtherQA
: 238001 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-26 15:22 EST by Eric Sandeen
Modified: 2010-10-22 08:40 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:18:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2007-01-26 15:22:01 EST
__cleanup_transaction in jbd does (abridged):

static int __cleanup_transaction(journal_t *journal, transaction_t *transaction)
{
        struct journal_head *jh, *next_jh, *last_jh;
        struct buffer_head *bh;

        jh = transaction->t_checkpoint_list;
        last_jh = jh->b_cpprev;
        next_jh = jh;
        do {
                jh = next_jh;
                bh = jh2bh(jh);
                ...
                next_jh = jh->b_cpnext;
                ...
                jh = next_jh;
       } while (jh != last_jh);

That last "jh = next_jh" clearly makes the loop skip the last item on the jh list.

A patch to remove it went upstream quite some time ago:

http://linux.bkbits.net:8080/linux-2.6/?PAGE=gnupatch&REV=1.3104.1.2

and I think this looks like one of those "obviously correct" fixes we should 
try to get in.  It -may- account for some of the problems related to 
bug# 205610, although I do not think it will resolve all those issues.

-Eric
Comment 2 ray dejean 2007-03-22 11:53:40 EDT
Eric,

This patch definitely helped our mail server.  It was crashing 1-2 times daily.
 Since the patch, it's been up 28 days.  Any ETA when this patch would make it
into a kernel errata? thanks...

ray
Comment 3 Jeff Layton 2007-03-22 12:15:16 EDT
It's on the proposed list for 4.6
Comment 4 Jason Baron 2007-03-29 15:58:28 EDT
patch has been upstream for a while, and fixes some serious downtown issues see
comment #2.
Comment 5 Jason Baron 2007-03-29 16:01:02 EDT
s/downtown/uptown. i mean downtime :)
Comment 8 Eric Sandeen 2007-03-30 16:53:45 EDT
I have placed 42.0.10 kernels with the added fix for this bug at:

http://people.redhat.com/esandeen/bz224638/

If anyone needs a kernel other than i686 and x86_64, smp, please let me know.

Note these kernels are only for testing, and are not official RHEL4 released
kernels.

Thanks,
-Eric
Comment 10 Suzanne Yeghiayan 2007-04-11 18:10:11 EDT
This RHEL 4.5 proposed exception did not receive all 3 acks and thus was not
approved for 4.5.
Moved to 4.6.
Comment 13 RHEL Product and Program Management 2007-04-18 18:36:11 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 14 Jason Baron 2007-05-11 14:52:34 EDT
committed in stream U6 build 55.2. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 17 Eric Sandeen 2007-05-31 14:20:36 EDT
*** Bug 238001 has been marked as a duplicate of this bug. ***
Comment 28 John Poelstra 2007-08-29 13:06:11 EDT
A fix for this issue should have been included in the packages contained in the
RHEL4.6 Beta released on RHN (also available at partners.redhat.com).  

Requested action: Please verify that your issue is fixed to ensure that it is
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 29 John Poelstra 2007-09-05 18:25:17 EDT
A fix for this issue should have been included in the packages contained in 
the RHEL4.6-Snapshot1 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed to ensure that it is 
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed, 
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent 
symptoms of the problem you are having and change the status of the bug to 
FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test 
results to Issue Tracker.  If you need assistance accessing 
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 30 John Poelstra 2007-09-11 20:40:12 EDT
A fix for this issue should be included in RHEL4.6-Snapshot2--available soon on
partners.redhat.com.  

Please verify that your issue is fixed to ensure that it is included in this
update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 31 John Poelstra 2007-09-20 00:29:18 EDT
A fix for this issue should have been included in the packages contained in the
RHEL4.6-Snapshot3 on partners.redhat.com.  

Please verify that your issue is fixed to ensure that it is included in this
update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 33 John Poelstra 2007-09-26 19:34:53 EDT
A fix for this issue should be included in the packages contained in
RHEL4.6-Snapshot4--available now on partners.redhat.com.  

Please verify that your issue is fixed ASAP to ensure that it is included in
this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 36 errata-xmlrpc 2007-11-15 11:18:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html

Note You need to log in before you can comment on or make changes to this bug.