Bug 224680 - JMicron SATA controller is incorrectly recognized
JMicron SATA controller is incorrectly recognized
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-26 18:54 EST by Vladimir Mosgalin
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.20-1.2944.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-02 12:32:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output for 2.6.20-1.2937.fc6 (26.41 KB, text/plain)
2007-03-29 06:08 EDT, Chris P
no flags Details
lspci-vv on working 2.6.19-1.2911.6.5.fc6 (24.80 KB, text/plain)
2007-04-19 17:49 EDT, George Shearer
no flags Details
lspci -vv on NON-working 2.6.20-1.2944.fc6 (24.30 KB, text/plain)
2007-04-19 18:51 EDT, George Shearer
no flags Details
bootlog of 2.6.20-1.2944 with pci=nobios (no change) (20.98 KB, text/plain)
2007-04-19 18:52 EDT, George Shearer
no flags Details
bootlog of 2.6.20-1.2944 with pci=conf1 (no change) (20.91 KB, text/plain)
2007-04-19 18:53 EDT, George Shearer
no flags Details
bootlog of 2.6.20-1.2944 with pci=conf2 (kernel panic!) (9.71 KB, text/plain)
2007-04-19 18:54 EDT, George Shearer
no flags Details

  None (edit)
Description Vladimir Mosgalin 2007-01-26 18:54:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.1) Gecko/20061208 Firefox/2.0.0.1

Description of problem:
I tried out kernel 2.6.19-1.2895 from updates and now I can't access SATA drives on my JMicron controller. Looks like new kernel incorrectly recognized JMB363 as JMB361. This is regression since 2.6.18-1.2856.

Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2895.fc6.x86_64

How reproducible:
Always


Steps to Reproduce:
Boot the system.

Actual Results:
From dmesg:
JMB361: IDE controller at PCI slot 0000:04:00.0
ACPI: PCI Interrupt 0000:04:00.0[A] -> GSI 17 (level, low) -> IRQ 17
JMB361: chipset revision 2
JMB361: 100% native mode on irq 17
JMB361: dma_base is invalid
ide0: JMB361 Bus-Master DMA disabled (BIOS)
JMB361: dma_base is invalid
ide1: JMB361 Bus-Master DMA disabled (BIOS)
Probing IDE interface ide0...
Probing IDE interface ide1...
JMB361: IDE controller at PCI slot 0000:04:00.1
ACPI: PCI Interrupt 0000:04:00.1[B] -> GSI 18 (level, low) -> IRQ 18
JMB361: chipset revision 2
JMB361: 100% native mode on irq 18
    ide2: BM-DMA at 0xa000-0xa007, BIOS settings: hde:pio, hdf:pio
    ide3: BM-DMA at 0xa008-0xa00f, BIOS settings: hdg:DMA, hdh:DMA

As a result, AHCI driver ignores SATA drive on jmicron controller.

Expected Results:
With 2.6.18, it was
JMB363: IDE controller at PCI slot 0000:04:00.1
GSI 18 sharing vector 0xE1 and IRQ 18
ACPI: PCI Interrupt 0000:04:00.1[B] -> GSI 18 (level, low) -> IRQ 225
JMB363: chipset revision 2
JMB363: 100% native mode on irq 225
    ide2: BM-DMA at 0xa000-0xa007, BIOS settings: hde:pio, hdf:pio
    ide3: BM-DMA at 0xa008-0xa00f, BIOS settings: hdg:DMA, hdh:DMA

AHCI finds another sata device and all works well.

Additional info:
JMB361 and 363 are very alike, the only difference is that JMB361 has only PATA port and JMB363 has PATA and two SATA ports. They have different PCI IDs - 
197b:2363 for JMB363 and 197b:2361 for JMB361.

I have Gigabyte GA-P965-DS4 MB, JMicron controller is on board. I have 7 SATA hard drives (6 on ICH8R and one on JMicron, one port on JMicron is free). Returning back to 2.6.18 kernel, since I can't work without that drive.
Comment 1 Ethan Swint 2007-02-22 20:32:38 EST
also confirmed on on x86_64
Comment 2 Ethan Swint 2007-02-22 20:36:36 EST
Lots of people echo this problem in fedoraForums.  It affects owners of
GA-965P-(D)S3 and Asus P5B owners, which are some of the most popular boards out
there right now for Core 2 Duo.  Looks like there is a fix in 2.6.20; is this
coming to FC6?
Comment 3 Chuck Ebbert 2007-02-23 09:27:53 EST
This should be fixed in FC6 2911 kernels.
Comment 4 Ethan Swint 2007-02-23 10:07:41 EST
Hmmm... 2.6.19-2911 didn't work on my machine (GA-965P-S3) and I spent several
hours on it with fellow Linux/Unix User Group members.  Any hardware
confirmations of this working, i.e. is it me or is it possible the 2911 kernel
is still broken?
Comment 5 Ethan Swint 2007-02-23 10:18:25 EST
Did a 2x check - the troubles were with the most current kernel as of 11 Feb.  I
thought I remembered 2911, but maybe not, as 2911 was posted on 13 Feb:
http://fedoranews.org/cms/node/2648
Would they have been available on the 11th?
Comment 6 Chuck Ebbert 2007-02-23 10:26:16 EST
kernel 2911 was posted to testing on Feb 12 and released on the 13th.

If you want to test, please get kernel 2.6.19-1.2911.6.3 from testing.
It has many more bug fixes:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/6/
Comment 7 Carl Brune 2007-02-25 11:23:54 EST
I can verify this bug is present in 2.6.19-1.2911.fc6.i686. I'm trying to use an
optical drive with the Jmicron controller on a Gigabyte 965p-ds3.rev2
motherboard. It work fine with 2.6.18-1.2798.fc6.i686. I triedd the testing
kernel 2.6.19-1.2911.6.3.fc6.i686 and the bug is still present.
Comment 8 Ethan Swint 2007-02-25 21:25:14 EST
Is there anything in '2911.fc6.3 that would change the status of this bug from
the file mentioned in #7?
Comment 9 vadym 2007-03-20 09:30:40 EDT
same thing with 2925.fc6.i686. bug is still there. HDD on JMicron363 SATA + PATA
OpticalDD on JMicron363 work in 2798.fc6.i686 but not with any recent kernels. 
For my case the following's proven not to solve problem : all BIOS SATA/IDE
options + irqpoll/all-generic-ide kernel options. Tried even FC7-test1,-test2:
they just don't see SATA HDD on JMB363. 
The only workaround for me - to connect SATA HDD to ICH8 SATA port; drawback is
HDD becomes twice slower than on JMB363 and PATA OpticalDD invisibility. 
Comment 10 Vladimir Mosgalin 2007-03-20 10:29:02 EDT
FYI, I'm using kernel-rt-2.6.20-0119.rt8 from
http://people.redhat.com/~mingo/realtime-preempt/
It doesn't have this problem.

> HDD becomes twice slower than on JMB363

Something is definitely wrong with your system. I have a lot of hard drives on
ICH8 and they work very fast, faster than on jmicron.
Comment 11 Chuck Ebbert 2007-03-20 16:41:28 EDT
If I build a test kernel for this issue will someone test it?

And can I get confirmation that JMB363 is still being reported as 361
with kernel 2925?
Comment 12 Ethan Swint 2007-03-20 22:13:01 EDT
I haven't tested 2925, but I'd be willing to test a new kernel.
Comment 13 Chuck Ebbert 2007-03-26 10:47:28 EDT
Test kernels (version 1.2937) for this issue are at:

http://people.redhat.com/cebbert

Please test and report back.
Comment 14 Chris P 2007-03-28 03:32:45 EDT
(In reply to comment #13)

> Please test and report back.

I have tested this kernel on a GA-965P-DS3.
This is the first kernel that has booted correctly since the installation kernel.
Comment 15 Chuck Ebbert 2007-03-28 18:53:27 EDT
(In reply to comment #14)
> I have tested this kernel on a GA-965P-DS3.
> This is the first kernel that has booted correctly since the installation kernel.

Can you post contents of /var/log/dmesg after booting the new kernel?
Comment 16 Chris P 2007-03-29 06:08:25 EDT
Created attachment 151184 [details]
dmesg output for 2.6.20-1.2937.fc6
Comment 17 George Shearer 2007-04-06 17:14:41 EDT
I'd like to confirm this bug. Here are the details of my config:

This motherboard has an intel P965 chipset (ICH8). All 4 SATA drives are always
recognized by Linux. It also has a JMicro IDE controller, to which I have a PATA
CD-Rom drive attached, and a single SATA drive. As of this posting, I am running
the latest BIOS provided by Gigabyte, F10.

I am currently running kernel 2.6.19-1.2911.6.5.fc6.i686 happily on my Gigabyte
GA-P965-DS3 motherboard, with FIVE SATA hard drives and CD-ROM all detected.

However, all newer kernels released so far (as of this posting) no longer
recognize the SATA drive attached to my JMicro IDE port, however, it still
recognizes the CDROM drive.

It may be of interest to note possible BIOS settings, and how the affect
detection of my IDE devices. The ICH8 managed ports have an option called AHCI
which can be enabled or disabled. If I enable this option, Linux does not see
any of them. Interestingly, during the BIOS screen, a 'secondary' Intel AHCI
BIOS is booted and detects the IDE drives, as opposed to the main bios.

The JMicro ports have an option of IDE, AHCI, or RAID. Linux
2.6.19-1.2911.6.5.fc6.i686 will detect my SATA drive on this controller AND the
CD-ROM PATA drive if this is set to IDE. However, if it's set to anything other
than IDE, only the CD-ROM is detected.

Any FC6-released kernel thats newer than 2.6.19-1.2911.6.5.fc6.i686 behaves
identically as noted above, however, no matter what setting is used in BIOS, the
JMicro SATA drive is NOT detected...
Comment 18 George Shearer 2007-04-08 19:53:19 EDT
kernel-2.6.20-1.2943.fc6 from the testing repo still behaves as noted in comment
#17. It still does not recognize my SATA drive attached to the JMicro
controller. Here is a snipit from the bootlog:

Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
jmicron_init_one: device = 2363, driver_data = 1
JMB363: IDE controller at PCI slot 0000:05:00.0
PCI: Device 0000:05:00.0 not available because of resource collisions
ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 19 (level, low) -> IRQ 18
JMB363: BIOS configuration fixed.
JMB363: chipset revision 2
JMB363: 100% native mode on irq 18
JMB363: dma_base is invalid
ide0: JMB363 Bus-Master DMA disabled (BIOS)
JMB363: dma_base is invalid
ide1: JMB363 Bus-Master DMA disabled (BIOS)
Probing IDE interface ide0...
Probing IDE interface ide1...
jmicron_init_one: device = 2363, driver_data = 1
JMB363: IDE controller at PCI slot 0000:05:00.1
PCI: Enabling device 0000:05:00.1 (0000 -> 0001)
ACPI: PCI Interrupt 0000:05:00.1[B] -> GSI 16 (level, low) -> IRQ 16
JMB363: chipset revision 2
JMB363: 100% native mode on irq 16
PCI: Setting latency timer of device 0000:05:00.1 to 64
    ide2: BM-DMA at 0x8000-0x8007, BIOS settings: hde:DMA, hdf:pio
    ide3: BM-DMA at 0x8008-0x800f, BIOS settings: hdg:DMA, hdh:pio
Probing IDE interface ide2...
hde: ASUS CD-S520/A4, ATAPI CD/DVD-ROM drive
hde: hw_config=0000
hde: hw_config=0000
ide2 at 0x7000-0x7007,0x7402 on irq 16
Probing IDE interface ide3...
Probing IDE interface ide0...
Probing IDE interface ide1...
Probing IDE interface ide3...

Comment 19 George Shearer 2007-04-14 16:00:04 EDT
The latest Fedora-released kernel (2944) still has this bug. /dev/hdg is NOT
recognized.. nor is it presented as a /dev/sdXX... So, no change.

Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
jmicron_init_one: device = 2363, driver_data = 1
JMB363: IDE controller at PCI slot 0000:05:00.0
PCI: Device 0000:05:00.0 not available because of resource 2 collisions
ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 19 (level, low) -> IRQ 18
JMB363: BIOS configuration fixed.
JMB363: chipset revision 2
JMB363: 100% native mode on irq 18
JMB363: dma_base is invalid
ide0: JMB363 Bus-Master DMA disabled (BIOS)
JMB363: dma_base is invalid
ide1: JMB363 Bus-Master DMA disabled (BIOS)
jmicron_init_one: device = 2363, driver_data = 1
JMB363: IDE controller at PCI slot 0000:05:00.1
PCI: Enabling device 0000:05:00.1 (0000 -> 0001)
ACPI: PCI Interrupt 0000:05:00.1[B] -> GSI 16 (level, low) -> IRQ 16
JMB363: chipset revision 2
JMB363: 100% native mode on irq 16
    ide2: BM-DMA at 0x8000-0x8007, BIOS settings: hde:DMA, hdf:pio
    ide3: BM-DMA at 0x8008-0x800f, BIOS settings: hdg:DMA, hdh:pio
hde: ASUS CD-S520/A4, ATAPI CD/DVD-ROM drive
hde: hw_config=0000
hde: hw_config=0000
ide2 at 0x7000-0x7007,0x7402 on irq 16
Comment 20 Chuck Ebbert 2007-04-16 19:09:12 EDT
(In reply to comment #19)
> PCI: Device 0000:05:00.0 not available because of resource 2 collisions

The new debug message worked, anyway.

Can you post output of the command 'lspci -vv' for working and non-working
kernels?

Also can you try some PCI boot options after that:
 pci=nobios
or
 pci=conf1
or
 pci=conf2

Try them one at a time, not all at once. They go after the "root=<whatever>"
line if /etc/grub.conf


Comment 21 George Shearer 2007-04-19 17:49:23 EDT
Created attachment 153069 [details]
lspci-vv on working 2.6.19-1.2911.6.5.fc6

Sorry it took me so long to get these to ya.
Comment 22 George Shearer 2007-04-19 18:51:33 EDT
Created attachment 153075 [details]
lspci -vv on NON-working 2.6.20-1.2944.fc6
Comment 23 George Shearer 2007-04-19 18:52:49 EDT
Created attachment 153076 [details]
bootlog of 2.6.20-1.2944 with pci=nobios (no change)
Comment 24 George Shearer 2007-04-19 18:53:41 EDT
Created attachment 153077 [details]
bootlog of 2.6.20-1.2944 with pci=conf1 (no change)
Comment 25 George Shearer 2007-04-19 18:54:58 EDT
Created attachment 153078 [details]
bootlog of 2.6.20-1.2944 with pci=conf2 (kernel panic!)
Comment 26 George Shearer 2007-05-02 10:49:55 EDT
Just tried the new kernel-2.6.20-1.2948.fc6.. Still does not recognize my hard
drive. So, I'm STILL running on kernel-2.6.19-1.2911.6.5.fc6 which has a buggy
sky2 driver :(

Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
jmicron_init_one: device = 2363, driver_data = 1
JMB363: IDE controller at PCI slot 0000:05:00.0
PCI: Device 0000:05:00.0 not available because of resource 2 collisions
ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 19 (level, low) -> IRQ 18
JMB363: BIOS configuration fixed.
JMB363: chipset revision 2
JMB363: 100% native mode on irq 18
JMB363: dma_base is invalid
ide0: JMB363 Bus-Master DMA disabled (BIOS)
JMB363: dma_base is invalid
ide1: JMB363 Bus-Master DMA disabled (BIOS)
Probing IDE interface ide0...
Probing IDE interface ide1...
jmicron_init_one: device = 2363, driver_data = 1
JMB363: IDE controller at PCI slot 0000:05:00.1
PCI: Enabling device 0000:05:00.1 (0000 -> 0001)
ACPI: PCI Interrupt 0000:05:00.1[B] -> GSI 16 (level, low) -> IRQ 16
JMB363: chipset revision 2
JMB363: 100% native mode on irq 16
PCI: Setting latency timer of device 0000:05:00.1 to 64
    ide2: BM-DMA at 0x8000-0x8007, BIOS settings: hde:DMA, hdf:pio
    ide3: BM-DMA at 0x8008-0x800f, BIOS settings: hdg:DMA, hdh:pio
Probing IDE interface ide2...
hde: ASUS CD-S520/A4, ATAPI CD/DVD-ROM drive
hde: hw_config=0000
hde: hw_config=0000
ide2 at 0x7000-0x7007,0x7402 on irq 16
Probing IDE interface ide3...
Probing IDE interface ide0...
Probing IDE interface ide1...
Probing IDE interface ide3...
Comment 27 Vladimir Mosgalin 2007-05-02 11:16:42 EDT
Huh? If it's recognized as JMB363, it SHOULD work! The problem was with JMB363
recognized as JMB361. As a matter or fact, I'm using  2.6.20-1.2944.fc6 which
has sky2 fix for a while and have no problems with jmicron, both sata and ide
channels work perfectly.


jmicron_init_one: device = 2363, driver_data = 1
JMB363: IDE controller at PCI slot 0000:06:00.1
ACPI: PCI Interrupt 0000:06:00.1[B] -> GSI 18 (level, low) -> IRQ 18
JMB363: chipset revision 2
JMB363: 100% native mode on irq 18
    ide0: BM-DMA at 0xa000-0xa007, BIOS settings: hda:pio, hdb:pio
    ide1: BM-DMA at 0xa008-0xa00f, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
hda: TOSHIBA ODD-DVD SD-M1802, ATAPI CD/DVD-ROM drive
hdb: PIONEER DVD-RW DVR-110D, ATAPI CD/DVD-ROM drive
hda: hw_config=603f
hda: hw_config=603f
hdb: hw_config=6b00
hdb: hw_config=6b00
ide0 at 0x9000-0x9007,0x9402 on irq 18
Probing IDE interface ide1...
Probing IDE interface ide1...

later on:

ahci 0000:06:00.0: AHCI 0001.0000 32 slots 2 ports 3 Gbps 0x3 impl SATA mode
ahci 0000:06:00.0: flags: 64bit ncq pm led clo pmp pio slum part 
ata7: SATA max UDMA/133 cmd 0xFFFFC20000020100 ctl 0x0 bmdma 0x0 irq 17
ata8: SATA max UDMA/133 cmd 0xFFFFC20000020180 ctl 0x0 bmdma 0x0 irq 17
scsi6 : ahci
ata7: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata7.00: ATA-7, max UDMA7, 488395055 sectors: LBA48 NCQ (depth 31/32)
ata7.00: ata7: dev 0 multi count 16
ata7.00: configured for UDMA/133
scsi7 : ahci
ata8: SATA link down (SStatus 0 SControl 300)
scsi 6:0:0:0: Direct-Access     ATA      SAMSUNG SP2504C  VT10 PQ: 0 ANSI: 5
SCSI device sde: 488395055 512-byte hdwr sectors (250058 MB)
sde: Write Protect is off
sde: Mode Sense: 00 3a 00 00
SCSI device sde: write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
SCSI device sde: 488395055 512-byte hdwr sectors (250058 MB)
sde: Write Protect is off
sde: Mode Sense: 00 3a 00 00
SCSI device sde: write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
 sde: sde1 sde2 < sde5 sde6 sde7 sde8 sde9 sde10 sde11 sde12 >
sd 6:0:0:0: Attached scsi disk sde


ata7/ata8 are sata devices on jmicron (06:00):
$ /sbin/lspci |grep 06:00
06:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI
Controller (rev 02)
06:00.1 IDE interface: JMicron Technologies, Inc. JMicron 20360/20363 AHCI
Controller (rev 02)


Can you post "/sbin/lspci|grep JMicron" output? Also, are you sure your jmicron
is in ahci mode?

I think this bug should be closed.
Comment 28 George Shearer 2007-05-02 11:24:21 EDT
Please see comment #17, it has details that you may be interested in.  The
bottom line:

If I boot kernel-2.6.19-1.2911.6.5.fc6, my drive is there and works happily.

If I boot any newer kernel, it is not there.
Comment 29 Vladimir Mosgalin 2007-05-02 11:35:52 EDT
I don't understand what exactly do you mean by "SATA drive attached to my JMicro
IDE port,".

And like I said, I have two PATA devices (ODD) and one SATA HDD attached
jmicron, they all work with newer 2.6.20 kernels. Jmicron is in AHCI mode, of
course - there is absolutely no reason to use anything else when AHCI is available.

I don't understand your problem, you are not providing enough details. Please
turn on AHCI, boot system with 2.6.20-1.2944.fc6 (I guess
kernel-2.6.20-1.2948.fc6 should be fine too) and post COMPLETE dmesg (in
attachment). Also please post /sbin/lspci output.

I don't like
PCI: Device 0000:05:00.0 not available because of resource 2 collisions
line in your output, but I'd like to see if it appears when AHCI is turned on.

Also, have you tried turning off unused devices? Like internal
soundcard/firewire/com1/com2/lpt (or setting lpt to spp mode)? Whatever this
resource collision thing is, it surely doesn't sound nice.
Comment 30 George Shearer 2007-05-02 11:41:00 EDT
I stand corrected. I just set the JMicro conroller to AHCI mode in my bios, and
now my drive is recognized by kernel-2.6.20-1.2948.fc6. 

Please understand, that this is the first kernel since
kernel-2.6.19-1.2911.6.5.fc6 that this has worked. (I've tried AHCI mode on
every kernel release.)

However, it appears to be working happily. now if I can just get sbp2 working
with xen :)
Comment 31 Eli Wapniarski 2007-05-04 02:50:03 EDT
Obviously some workaround is in place, but... as you can see from the output, 
bus mastering is disabled.  This is on an Asus P5B-V. Yep... duo 64bit cpu.

Linux version 2.6.20-1.2948.fc6

micron_init_one: device = 2363, driver_data = 1
JMB363: IDE controller at PCI slot 0000:02:00.0
PCI: Device 0000:02:00.0 not available because of resource 2 collisions
ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16 (level, low) -> IRQ 16
JMB363: BIOS configuration fixed.
JMB363: chipset revision 2
JMB363: 100% native mode on irq 16
JMB363: dma_base is invalid
ide0: JMB363 Bus-Master DMA disabled (BIOS)
JMB363: dma_base is invalid
ide1: JMB363 Bus-Master DMA disabled (BIOS)
Probing IDE interface ide0...
Probing IDE interface ide1...
jmicron_init_one: device = 2363, driver_data = 1
JMB363: IDE controller at PCI slot 0000:02:00.1
PCI: Enabling device 0000:02:00.1 (0000 -> 0001)
ACPI: PCI Interrupt 0000:02:00.1[B] -> GSI 17 (level, low) -> IRQ 17
JMB363: chipset revision 2
JMB363: 100% native mode on irq 17
PCI: Setting latency timer of device 0000:02:00.1 to 64
    ide2: BM-DMA at 0xa400-0xa407, BIOS settings: hde:pio, hdf:pio
    ide3: BM-DMA at 0xa408-0xa40f, BIOS settings: hdg:pio, hdh:pio
Probing IDE interface ide2...
hde: ASUS DVD-E616P2, ATAPI CD/DVD-ROM drive
hde: hw_config=0000
hde: hw_config=0000
ide2 at 0xac00-0xac07,0xa882 on irq 17
Comment 32 Vladimir Mosgalin 2007-05-04 04:33:39 EDT
Dunno, works for me. Have you tried things I suggested (turning on AHCI, turning
off unused devices)?
Comment 33 Ethan Swint 2007-05-27 22:52:59 EDT
The later kernels will boot for me, but I get frequent soft lockups and error
messages from the HDs:
May 27 04:30:34 localhost kernel: hda: status error: status=0x59 { DriveReady
SeekComplete DataRequest Error }
May 27 04:30:34 localhost kernel: hda: status error: error=0x44 { AbortedCommand
LastFailedSense=0x04 }
May 27 04:30:34 localhost kernel: ide: failed opcode was: unknown
May 27 04:30:34 localhost kernel: hda: drive not ready for command

The last kernel which has worked without these problems is 2.6.18-1.2869.fc6
Comment 34 Vladimir Mosgalin 2007-05-28 11:54:29 EDT
Are you sure your HDD is OK? I suggest checking its SMART status, also you
should check interface cable. Try unplugging/plugging it again, try replacing it.

Note You need to log in before you can comment on or make changes to this bug.