Bug 224844 - Older satellites error out sat-syncing virtualization_host group arch types
Older satellites error out sat-syncing virtualization_host group arch types
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
wes hayutin
:
: 221324 (view as bug list)
Depends On:
Blocks: 166615
  Show dependency treegraph
 
Reported: 2007-01-27 00:03 EST by Pradeep Kilambi
Modified: 2007-04-18 13:58 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhn500h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 09:53:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2007-01-27 00:03:45 EST
Description of problem:

the older satellites < 5.0 error out when trying to satellite-sync against
hosted. Basically hosted exports the virtualization_host arch type to sats, this
would work for 5.0 sats but older ones cannot understand it and hence error out..

Version-Release number of selected component (if applicable):


How reproducible:

always

  
Actual results:

trace back..

Expected results:

older satellites should be able to sync successfully.

Additional info:
Comment 1 Pradeep Kilambi 2007-01-27 00:17:24 EST
This should now be fixed, turns out kinda tricky. Basically what i have done is
add some code to check if the version of client is older than 5.0 , for this
we'll need to bump the server and sat-5.0 xml_dump_versions to 3.1 and older
clients remain at 3.0 in /etc/rhn/default/rhn_server_satexport.conf

< xml_dump_version = 3.1
---
> xml_dump_version = 3.0

We basically check if the client is older if so enable virt_filter which
basically  restricts server from exporting the virt* data from
rhnServerGroupType to the sat- client

the code is checked in subversion: Committed revision 109928


tested this with a 5.0(with client version bump to 3.1) and 4.1(client version
still 3.0) satellite against webdev(version bump to 3.1).

and now syncs seems to complete successfully on older and newer version of
satellites.
Comment 2 Pradeep Kilambi 2007-02-09 15:06:32 EST
*** Bug 221324 has been marked as a duplicate of this bug. ***
Comment 3 wes hayutin 2007-02-14 14:52:16 EST
sat sync is working on rhn 415.. verified
Comment 4 wes hayutin 2007-03-09 11:00:29 EST
sat sync working in stage sat=4.0
Comment 5 Brandon Perkins 2007-03-13 09:53:27 EDT
Closed in rhn500h Release.

Note You need to log in before you can comment on or make changes to this bug.