Bug 22488 - anaconda hangs during package install on net install
anaconda hangs during package install on net install
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-19 00:10 EST by Jeremy Katz
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-09 09:19:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2000-12-19 00:10:02 EST
Sorry I can't give any more information on this one, but I'll give what I
got and will check with cds when they get here tomorrow or Wednesday.
anaconda seems to hang by the time it reaches a third of the way into the
installation of packages with any network install method, nfs or ftp, both
workstation installs and custom installs.

With NFS install, everything works fine until it gets through with some
number of packages at which point everything completely freezes requiring a
reboot.  With an ftp install, I can still switch consoles and look at
what's running, manual inspection of /proc (since ps is not in the image)
shows init, ash, and python running, but that's about all I can give.

This is on a P200 with Matrox Mystique that's main purpose in life is
blowing away what's installed for testing.  If you've got anything specific
for me to try, let me know and I'll give it a whirl tomorrow, otherwise,
I'll try again tomorrow and see if I can find anything else.
Comment 1 Michael Fulbright 2000-12-19 11:33:47 EST
What network card are you using?
Comment 2 Jeremy Katz 2000-12-19 13:34:42 EST
It's a Linksys PNIC based card using the tulip driver.  Don't think it's the 
card/driver, as I've got the same card in another machine which has been 
running 2.[34] for ages and was the server host for all of my network install 
testing during Winston
Comment 3 Michael Fulbright 2000-12-27 12:37:07 EST
We have seen this behavior with the tulip driver.  Seems to be a kernel issue.
Comment 4 Jeremy Katz 2001-01-09 09:18:59 EST
For what it's worth, I didn't see this on a beta2 install last night, but it
could just be network differences since the kernel between beta1 and beta2
hasn't changed all that much.  I'll keep trying to reproduce, but would
conditionally say that it looks like it's fixed.
Comment 5 Jeremy Katz 2001-01-26 14:39:55 EST
Haven't seen it since beta1 and current rawhide looks fine on that box for
network installs, so closing

Note You need to log in before you can comment on or make changes to this bug.