Bug 224925 - master user fails current fc5 dovecot but not fc6 dovecot
master user fails current fc5 dovecot but not fc6 dovecot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Janousek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-27 01:06 EST by Dale Bewley
Modified: 2014-01-21 17:56 EST (History)
2 users (show)

See Also:
Fixed In Version: dovecot-1.0-0.beta8.4.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-07 07:03:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dale Bewley 2007-01-27 01:06:28 EST
Description of problem:
The dovecot-1.0-0.beta8.3.fc5 build of Dovecot does not properly support "master
user" logins. It seems to ignore the auth_master_user_separator setting.

However, if I build the SRPM of dovecot-1.0-1.1.rc15.fc6 on FC5 and use the same
dovecot.conf this feature does work.

Can you push this version out for FC5?

Version-Release number of selected component (if applicable):
dovecot-1.0-0.beta8.3.fc5

How reproducible:
Every time

Steps to Reproduce:
1. Config as http://wiki.dovecot.org/MasterPassword
2. Try logging in as USER*MASTERUSER
3. Observe dovecot login as that full string rather than MASTERUSER
  
Actual results:
dovecot-1.0-0.beta8.3.fc5
Jan 26 18:57:01 mail dovecot: auth(default): client in: AUTH    1       PLAIN  
service=IMAP    secured lip=::ffff:169.237.222.111      rip=::ffff:169.237.222.333
Jan 26 18:57:01 mail dovecot: auth(default): client out: CONT   1
Jan 26 18:57:01 mail dovecot: auth(default): client in: CONT<hidden>
Jan 26 18:57:01 mail dovecot: auth(default):
passdb(zimbra,::ffff:169.237.222.333,master): Master user logging in as
dlbewley*zimbra
Jan 26 18:57:01 mail dovecot: auth(default): client out: OK     1      
user=dlbewley*zimbra
Jan 26 18:57:01 mail dovecot: auth(default): master in: REQUEST 146     19330   1
Jan 26 18:57:01 mail dovecot: auth(default):
passwd(dlbewley*zimbra,::ffff:169.237.222.333): unknown user
Jan 26 18:57:01 mail dovecot: auth(default):
userdb(dlbewley*zimbra,::ffff:169.237.222.333): user not found from userdb
Jan 26 18:57:01 mail dovecot: auth(default): master out: NOTFOUND       146
Jan 26 18:57:01 mail dovecot: imap-login: Internal login failure:
user=<dlbewley*zimbra>, method=PLAIN, rip=::ffff:169.237.222.333,
lip=::ffff:169.237.222.111, TLS


Expected results:
dovecot-1.0-1.1.rc15 on FC5
Jan 26 21:27:37 mail dovecot: auth(default): client in: AUTH    1   PLAIN  
service=IMAP    lip=::ffff:169.237.222.111  rip=::ffff:169.237.111.111 
resp=<hidden>
Jan 26 21:27:37 mail dovecot: auth(default):
passdb(zimbra,::ffff:169.237.111.111,master): Master user logging in as dlbewley
Jan 26 21:27:37 mail dovecot: auth(default): client out: OK 1   user=dlbewley
Jan 26 21:27:37 mail dovecot: auth(default): master in: REQUEST 8   28380   1
Jan 26 21:27:37 mail dovecot: auth(default): master out: USER   8   dlbewley   
system_user=dlbewley    uid=500 gid=500 home=/home/dlbewley master_user=zimbra
Jan 26 21:27:37 mail dovecot: imap-login: Login: user=<dlbewley>, method=PLAIN,
rip=::ffff:169.237.111.111, lip=::ffff:169.237.222.111


Additional info:
http://wiki.dovecot.org/MasterPassword
Comment 1 Tomas Janousek 2007-01-30 08:35:14 EST
I can't reproduce this. The fc5 SRPM built on RHEL5 works and I don't see any
relevant changes in the changelog neither. Could you attach your dovecot.conf?

Since this works here, I'm not sure whether plain pushing of newer version is
appropriate. It would require me to do some config file compatibility changes so
I'd rather try to solve the problem for this version.
Comment 2 Dale Bewley 2007-02-17 18:50:13 EST
My test was with imapsync 1.182, however, I think for the test that did work I
must have done via telnet rather than imapsync, but I don't remember.

Timo has fixed it and it now works for me. I just took the FC6 SRPM, used the
RC22  tarball and applied this patch.
http://dovecot.org/list/dovecot/2007-February/019758.html

You can close this ticket and roll the FC6 RPM back to FC5 at your leisure, or not.

Thanks for looking into it, and sorry for being slow to respond.
Comment 3 Tomas Janousek 2007-02-26 09:08:14 EST
I will rather apply the patch alone, upgrading to a newer version would need to
solve the configuration differencies somehow.
Comment 4 Tomas Janousek 2007-03-09 05:19:47 EST
Applied, I'll push the update when something bigger comes out.
Comment 5 Fedora Update System 2007-05-07 22:20:04 EDT
dovecot-1.0-0.beta8.4.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.