Bug 225055 - wine use causes shutdown problem
wine use causes shutdown problem
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-01-28 04:40 EST by Mike
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-04-16 11:37:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mike 2007-01-28 04:40:44 EST
Description of problem:
running Fedora Core6 on a modern PC.
Any time I invoke wine, either running a windows program or winecfg, (which run
fine), when I go to "System" "Shutdown" the panels and icons dissapear, the
keyboard becomes inactive but I'm left with the desktop wallpaper and an active
mouse cursor, then I have to turn the power off.
However if I do "poweroff" at a terminal, initially I get the same wallpaper and
mouse, but after several seconds the computer does shutdown.

I've checked in system monitor that no wine programs are still running after I
terminate the windows app

Also running core4 on this PC, that doesn't have this problem, but it's wine
version  0.9.27

How reproducible: every time

Steps to Reproduce:
1. use wine in some way
2. shutdown computer
Actual results:
don't get a terminal screen with the shut down progress on it.
get desktop wallpaper and an active mouse cursor.
If shutdown initated from gnome or kde that's how it stays.
If shutdown initiated from terminal with "poweroff", after a while the mouse
becomes inactive, then system shuts down.

Expected results:
Normal shutdown sequence

Additional info:

I sent this to wine bugzilla earlier today, but got a reply from them saying it
was more likely a FC6 problem.
Comment 1 Andreas Bierfert 2007-01-28 06:21:35 EST
Can you please try to upgrade to 0.9.29 and start with a clean ~/.wine directory
and see if it still is an issue?
Comment 2 Mike 2007-01-29 04:57:49 EST
Sorry Andreas, somehow I missed saying that I have version 0.9.29 in core6.
It's 0.9.27 in core4 were I have no problem.

I'll completely uninstall wine and start again, and report back.
Comment 3 Mike 2007-01-29 08:30:12 EST
OK used yumex to uninstall all wine components listed.
Deleted ~/.wine directory.
Installed wine, wine core and their depedencies with yumex, from FC6 extras repo.
Typed winecfg in terminal, that reported creating ~/.wine successfully.
I then set audio driver to alsa in the wine configure gui.
Terminated all applications.
Did "poweroff" in terminal.
Problem is still there.

Not sure if this will help, but I've just had an email from a person with a
similar sounding problem in a slackware installation, his was caused by
compiling the exec-shield patch into his kernel.

Comment 4 Andreas Bierfert 2007-01-29 09:12:43 EST
Thanks the information. Exec shield is part of the fedora kernel as well. Look
at /proc/sys/kernel/exec-shield. Here it is enabled on both my amd64 and my i386
box and both work fine but if you want try setting its value to 0 and retry if
the problem still exists.
Comment 5 Mike 2007-01-30 06:35:54 EST
Yes it's enabled on mine as well, with just a 1.
I tried changing that to a 0 as root but it won't let me.
I get this message I've never seen before.

Warning the file has changed since reading it!!
Do you want to write to it (y/n)? 
I type y and get this.
E667: Esync failed.
Press enter or type command to continue.

Problem does still exist.

Comment 6 Mike 2007-02-03 07:46:14 EST
Uninstalled wine 0.9.29.fc6 today with rpm -e
Even that caused shutdown problem.
I'm in the process of reinstalling the version that works in core4 (0.9.27.fc4)
to see if that makes any difference, but I have a few dependency problems to
resolve first. I'll get back with any results.
Comment 7 Mike 2007-02-09 06:31:05 EST
Used openoffice today and that also caused problem.
tried writer, impress and spreadsheet, all of them cause the problem.
Wine has been unistalled for over a week, haven't been able to install core4

tomorrow I get a new data alocation so I'll completely update the system. If
that fixes problem I'll report back.

Comment 8 Andreas Bierfert 2007-04-16 11:37:39 EDT
If it is the same with open office or other apps and wine is not installed I'd
say it is not a wine bug. Since there has been no activity I will close this
bug. Feel free to reopen if the issue still occurs.
Comment 9 Mike 2007-04-17 04:48:19 EDT
Just returned from a 2 month holiday, when I applied the latest updates it
sorted the problem. Now running wine and open office no problems.

Note You need to log in before you can comment on or make changes to this bug.