Bug 225110 - Wine crashes immediately
Wine crashes immediately
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-28 19:00 EST by Devin Henderson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 11:40:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Devin Henderson 2007-01-28 19:00:47 EST
Wine will not run for me at all. It crashes right away with the error messages
below. This looks very similar to bug 6735 but I'm on an Intel Pentium M and ATI
FireGL T2 with fglrx (ThinkPad T41p laptop). Wine worked under FC5 but seemingly
ever since I installed FC6 I can't get it to do anything. For example:

[devin@localhost ~]$ wine notepad
wine: Unhandled page fault on read access to 0x00340023 at address 0x602acb35
(thread 000f), starting debugger...
err:ntdll:RtlpWaitForCriticalSection section 0x708d81a0 "x11drv_main.c:
X11DRV_CritSection" wait timed out in thread 000f, blocked by 0000, retrying (60
sec)
err:seh:raise_exception Unhandled exception code c0000194 flags 0 addr 0x602b33a0
err:seh:raise_exception Unhandled exception code c000013a flags 0 addr 0x602ac657


Or,


[devin@localhost ~]$ rm -Rf ~/.wine/
[devin@localhost ~]$ wineprefixcreate 
wine: Unhandled page fault on read access to 0x00340023 at address 0x602acb35
(thread 0009), starting debugger...
wine: Unhandled page fault on read access to 0x00000000 at address 0x76d3385c
(thread 000b), starting debugger...
wine: Unhandled page fault on read access to 0x00000000 at address 0x6b0d385c
(thread 000d), starting debugger...
err:ntdll:RtlpWaitForCriticalSection section 0x607d31a0 "x11drv_main.c:
X11DRV_CritSection" wait timed out in thread 0009, blocked by 0000, retrying (60
sec)
err:ntdll:RtlpWaitForCriticalSection section 0x6076b1a0 "x11drv_main.c:
X11DRV_CritSection" wait timed out in thread 000d, blocked by 0000, retrying (60
sec)
Comment 1 Devin Henderson 2007-01-28 19:01:52 EST
Sorry, the reference to bug # 6735 should point here:

http://bugs.winehq.org/show_bug.cgi?id=6735
Comment 2 Devin Henderson 2007-01-28 20:43:30 EST
wine.i386                                0.9.29-1.fc6           installed  

and

kmod-fglrx.i686                          8.33.6-1.2.6.19_1.2895 installed       
Comment 3 Andreas Bierfert 2007-01-29 02:55:56 EST
Did you try without the fglrx stuff installed? Would be great if you could try
that and report back as I don't have ati cards around (atleast non which are
supported by fglrx).
Comment 4 Devin Henderson 2007-01-29 16:52:10 EST
Andreas,

I uninstalled fglrx and it works! ... Sure hope we can get this fixed. I need
fglrx to take advantage of my video card, but I would also like wine running so
that I can run Internet Explorer (I'm a web developer). Please let me know if I
can give you any more information or if you figure anything out on this. Thanks!

Comment 5 Andreas Bierfert 2007-01-29 19:15:02 EST
You could check the wine bugzilla and file a bug agains wine but I guess that
they will say that it is a problem with fglrx ... will see if I can find out
more on the issue...
Comment 6 Devin Henderson 2007-01-30 17:30:25 EST
Andreas,

I had previously reported this bug to bugs.winehq.org and they pointed me in
this direction assumedly because they thought this was a Fedora issue. That bug
can be found here: http://bugs.winehq.org/show_bug.cgi?id=7276

Yesterday someone posted a link to this bug:
http://bugs.winehq.org/show_bug.cgi?id=4561

According to that page, this is a problem with ATI FireGL cards. Supposedly
adding Option "UseFastTLS" "2" to the video card section of xorg.conf will fix
the problem. However, when I added this option to my xorg.conf direct rendering
stopped working :( I tried to restore my xorg.conf but have not been able to get
direct rendering to work again! I don't know what is going on.

I will try to get fglrx working again. In the mean time, can anyone else verify
whether or not adding Option "UseFastTLS" "2" to xorg.conf solves this problem?!

Thanks 
Comment 7 Andreas Bierfert 2007-04-16 11:40:22 EDT
Since fglrx causes a lot of wine problems which are not packaging related I will
close this bug here. Please discuss possible fglrx issues with upstream wine.
Fell free to add more information here on how this issue can be avoided. Maybe
encourage upstream wine to ship a README.fglrx e.g.....

Note You need to log in before you can comment on or make changes to this bug.