Bug 225155 - Unexpected ext/XFS corruption
Unexpected ext/XFS corruption
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-29 09:47 EST by Jan Engelhardt
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: f6 updates
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 15:07:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (13.75 KB, image/png)
2007-01-29 10:13 EST, Jan Engelhardt
no flags Details
Screenshot of XFS errors (20.27 KB, image/png)
2007-02-11 14:56 EST, Jan Engelhardt
no flags Details

  None (edit)
Description Jan Engelhardt 2007-01-29 09:47:58 EST
Description of problem:
XFS gets corrupted right at the first run from harddisk. (Yes, I know XFS is not
supported, but really, right after the initial install?) Can be fixed up with
xfs_repair, but files get damaged when not fixed up.

Version-Release number of selected component (if applicable):
ftp-1.gwdg.de/pub/linux/fedora/linux/core/6/i386/iso/FC-6-i386-DVD.iso

How reproducible:


Steps to Reproduce:
1. install FC6 in textmode, with xfs (linux text xfs)
2. deselect all install components but Administrative Tools
3.
  
Actual results:
Filesystem corruption.

Expected results:
Not die on me right away.

Additional info:
It seems that the filesystem was not cleanly unmounted after the install from
CD, because fsck.xfs gave a warning, and the rpm database was bust.
Comment 1 Jan Engelhardt 2007-01-29 10:13:29 EST
Created attachment 146831 [details]
screenshot

Something similar happens to ext3. Though it's limited to the time-problem.
(XFS got both the time issue and corruption.)
Comment 2 Dave Jones 2007-02-03 16:00:32 EST
The XFS issue was fixed up in the first update after release I think.
Comment 3 Eric Sandeen 2007-02-03 19:47:01 EST
for xfs, this is probably a dup of bug #212201 but I would need some actual
information to know for sure (xfs_repair output maybe?  fsck.xfs is a no-op, not
interesting...)

Are things any better if you boot w/ selinux=0 and do not enable selinux on the
install?

If it is the xfs selinux/attr problem, Dave has a patch to fix this but it's not
available in an update yet...

you've mentioned corruption on both ext3 and xfs, but haven't offered any info
to show me how it's corrupted, so it'll be hard to move forward on this.

Thanks,
-Eric
Comment 4 Jan Engelhardt 2007-02-11 14:56:56 EST
Created attachment 147863 [details]
Screenshot of XFS errors
Comment 5 Eric Sandeen 2007-02-11 16:33:32 EST
That block number looks well out of range.  Does xfs_repair find anything?  And,
do you have selinux enabled on this box, or are you using extended attributes
via beagle, or other application?
Comment 6 Eric Sandeen 2007-09-17 15:07:34 EDT
In lieu of other info, assuming this is the attr2 bug that plagued early F6, and
it's fixed now.  If you can show otherwise, please re-open.

Thanks,

-Eric

Note You need to log in before you can comment on or make changes to this bug.