Bug 225194 - Unable to mount - not built with HAL support
Unable to mount - not built with HAL support
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: exo (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-29 13:20 EST by Michael Cronenworth
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.3.2-1.fc6.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 20:32:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Cronenworth 2007-01-29 13:20:37 EST
Description of problem: After inserting a CD or DVD the icon for the disc shows
up on the desktop and in Thunar under XFCE 4.4.0. However, trying to double
click to mount produces the error: "exo-mount: Cannot mount by HAL device UDI,
because HAL support was disabled for this build."


Version-Release number of selected component (if applicable): XFCE 4.4.0, exo
0.3.2-1


How reproducible: Always


Steps to Reproduce:
1. Insert Disc
2. Double-click to mount
3.
  
Actual results: Not mounted


Expected results: Mounted disc


Additional info: Should be a simple recompile.
Comment 1 Kevin Fenzi 2007-01-30 00:57:29 EST
Thanks for the bug report. 
I will see about pushing out a fixed exo soon... 

Comment 2 Kevin Fenzi 2007-01-30 16:32:37 EST
I just pushed a corrected exo out. It should be released as an update soon. 

If you would like to test it out, there is an unsigned package available
directly from the build system at: 

http://buildsys.fedoraproject.org/plague-results/fedora-6-extras/exo/0.3.2-1.fc6.1/

Please let me know if this solves your issue. 
Note that gtk-doc is broken in devel currently, so this update was only pushed 
out for fc6 at this time. 
Comment 3 Michael Cronenworth 2007-01-30 17:56:29 EST
This solves my issue. I see nice names now instead of "fd0" etc. :)

Thanks!

P.S. Please add "thunar-volman" to Extras when you get a chance. This is an
important plug-in for Thunar to really unleash the power of HAL/DBUS. I have it
manually installed.
Comment 4 Kevin Fenzi 2007-01-30 20:32:09 EST
Glad to hear it. 

I am going to go ahead and close this bug now. If you spot any problems, 
please do file a new bug or re-open this one. ;) 

Thanks for the bug report!

FYI, Christopher has a thunar-volman package ready to submit.
It was waiting on this hal support:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=225083

Note You need to log in before you can comment on or make changes to this bug.