Bug 225236 - Merge Review: acl
Merge Review: acl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-29 15:59 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-26 09:39:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-29 15:59:01 EST
Fedora Merge Review: acl

http://cvs.fedora.redhat.com/viewcvs/devel/acl/
Comment 1 Kevin Fenzi 2007-02-03 11:46:05 EST
I'll review this package. 
Comment 2 Kevin Fenzi 2007-02-03 12:08:35 EST
OK - Package meets naming and packaging guidelines
OK - Spec file matches base package name.
OK - Spec has consistant macro usage.
OK - Meets Packaging Guidelines.
OK - License (LGPL)
OK - License field in spec matches
OK - License file included in package
OK - Spec in American English
OK - Spec is legible.
OK - Sources match upstream md5sum:
4edd450bbee60d6c4b3c51ae80499b00  acl_2.2.39-1.tar.gz
4edd450bbee60d6c4b3c51ae80499b00  acl_2.2.39-1.tar.gz.1
OK - BuildRequires correct
OK - Spec handles locales/find_lang
OK - Package has %defattr and permissions on files is good.
OK - Package has a correct %clean section.
See below - Package has correct buildroot
OK - Package is code or permissible content.
OK - Packages %doc files don't affect runtime.

OK - Headers/static libs in -devel subpackage.
OK - Spec has needed ldconfig in post and postun
OK - .so files in -devel subpackage.
See below - -devel package Requires: %{name} = %{version}-%{release}
OK - .la files are removed.

OK - Package compiles and builds on at least one arch.
OK - Package has no duplicate files in %files.
OK - Package doesn't own any directories other packages own.
OK - Package owns all the directories it creates.
See below - No rpmlint output.
 - final provides and requires are sane:
     (include output of for i in *rpm; do echo $i; rpm -qp --provides $i; echo
=; rpm -qp --requires $i; echo; done
      manually indented after checking each line.  I also remove the rpmlib junk
and anything provided by glibc.)

SHOULD Items:

 - Should build in mock.
 - Should build on all supported archs
 - Should function as described.
 - Should have sane scriptlets.
 - Should have subpackages require base package with fully versioned depend.
 - Should have dist tag
 - Should package latest version
 - check for outstanding bugs on package.

Issues:

1. buildroot should be the standard.

2. Could add smp_mflags to build?

3. The devel package should probibly "Requires" the full %{name} =
%{version}-%{release}

4. Our good friend rpmlint says:
rpmlint on ./libacl-2.2.39-1.1.i386.rpm
W: libacl summary-ended-with-dot Dynamic library for access control list support.

Remove the .

W: libacl no-documentation

Ignore.

rpmlint on ./acl-2.2.39-1.1.src.rpm
W: acl summary-ended-with-dot Access control list utilities.

Remove .

W: acl prereq-use /sbin/ldconfig

Ignore.

W: acl macro-in-%changelog defattr

Should be %%defattr in the changelog

rpmlint on ./acl-2.2.39-1.1.i386.rpm
W: acl summary-ended-with-dot Access control list utilities.

Remove .

rpmlint on ./libacl-devel-2.2.39-1.1.i386.rpm
W: libacl-devel no-version-dependency-on libacl 2.2.39

Should be full verion...

W: libacl-devel summary-ended-with-dot Access control list static libraries and
headers.
W: libacl-devel symlink-should-be-relative /usr/lib/libacl.so /lib/libacl.so

I think that could be ignored.
Comment 3 Karsten Hopp 2007-02-23 05:47:41 EST
>W: acl prereq-use /sbin/ldconfig
>Ignore.

This needs to be fixed. 'Requires(post): /sbin/ldconfig'

fixed in acl-2.2.39-3.fc7, rpmlint doesn't complain anymore.
Comment 4 Kevin Fenzi 2007-02-23 22:36:42 EST
In reply to commet #3: 

My understanding is that when you have post/postun with -p /sbin/ldconfig, 
since that tells rpm to run that instead of a shell command that it correctly 
adds the dependency for that command. Still, it doesn't hurt to have it in there. 

Everything else looks to be fixed from what I can see, so this package is
APPROVED. Feel free to close this rawhide once it's been pushed out and tested. 

Note You need to log in before you can comment on or make changes to this bug.