Bug 225357 - CPANPLUS needs Module::Pluggable for configuration
CPANPLUS needs Module::Pluggable for configuration
Product: Fedora
Classification: Fedora
Component: perl-CPANPLUS (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-01-29 22:01 EST by Ian Burrell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-30 11:10:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ian Burrell 2007-01-29 22:01:19 EST
The current version (0.076-1) of perl-CPANPLUS needs Module::Pluggable for the
initial configuration.  After just installing perl-CPANPLUS, I get following
error message when running "cpanp".

Can't locate Module/Pluggable.pm in @INC (@INC contains: /root/.cpanplus/lib
/usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/
ad-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7
5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl
386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
i /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl
-thread-multi /usr/lib/perl5/5.8.8 .) at
line 135.
BEGIN failed--compilation aborted at /usr/bin/cpanp line 14.

It looks like Module::Pluggable is loaded dynamically which is why it isn't
included in the automatic requires list.  My impression is that this is only
needed for initial configuration.  If CPANPLUS is already configured, it works
fine.  Since Module::Pluggable is available in Extras, it would probably be best
to add an explicit Requires.
Comment 1 Steven Pritchard 2007-01-30 10:41:28 EST
I'm building now with that and a couple of other missing explicit dependencies 

Note You need to log in before you can comment on or make changes to this bug.