Bug 225395 - Connection with Evolution to a LDAP server with DN
Connection with Evolution to a LDAP server with DN
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-30 07:15 EST by Bernard Duclos
Modified: 2008-03-16 17:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-16 17:32:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 522831 None None None Never

  None (edit)
Description Bernard Duclos 2007-01-30 07:15:10 EST
Description of problem:
I try to configure “Contacts” with a connection to a LDAP server (Domino).
If the LDAP server allows the anonymous login, there is no problem.
If I configure “Contacts” to use a distinguished name for 
authentication, “Contacts” asks me the password before establishing the server 
connection and all is OK.
But if the LDAP server disables the anonymous login, even if I 
configure “Contacts” with the correct login (DN), the access to the LDAP server 
failed (no password is required).
With WireShark, I see that “Contacts” always sends the first BindRequest with 
anonymous login. If the first BindRequest is OK (it is the case if LDAP server 
allows anonymous login), “Contacts” send a second BindRequest with login 
information (DN). But if the first BindRequest (anonymous login) 
failed, “Contacts” doesn’t try the DN login. 


Version-Release number of selected component (if applicable):
Evolution 2.8.2.1 under FC6

How reproducible:
Always

Steps to Reproduce:
1.Declare a connection to a LDAP server wich required a DN login
2.Try to search a contact
3.
  
Actual results:
"Contacts" doesn't find the contact and doesn't request a password for the login

Expected results:
Contacts must request a password for the login to the LDAP server.

Additional info:
Comment 1 Matthew Barnes 2007-10-05 01:06:27 EDT
Is this problem still present on Fedora 8 Test 2 or later?
Comment 2 Bernard Duclos 2007-10-05 03:57:12 EDT
I'm sorry but I don't have a system to install Fedora 8 Test x.
I only use final releases of Fedora.
When the final release of Fedora 8 will be available, I will check if this
problem is still present...
Comment 3 Matthew Barnes 2007-10-05 10:14:30 EDT
Okay, thanks for responding.  Setting this back to NEEDINFO to help me track it
easier.
Comment 4 Matěj Cepl 2007-12-10 16:48:01 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Evolution.
If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 5 Bernard Duclos 2007-12-12 08:18:18 EST
This problem is still present on Fedora 8 (Evolution 2.12.2)...
Comment 6 Matthew Barnes 2008-03-16 17:32:11 EDT
Moving this upstream.  Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=522831

Note You need to log in before you can comment on or make changes to this bug.