Bug 225628 - Merge Review: bsh
Merge Review: bsh
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 12:47 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 14:12:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jochen: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 12:47:39 EST
Fedora Merge Review: bsh

http://cvs.fedora.redhat.com/viewcvs/devel/bsh/
Initial Owner: pcheung@redhat.com
Comment 2 Jochen Schmitt 2007-03-29 12:17:52 EDT
Good:
+ Local build works fine.
* Binaries packages are ok.
+ License ok.
+ naming seems ok.

Bad:
- Rpmlint have warnings on source package:
W: bsh non-standard-group Development/Java
W: bsh strange-permission bsh-1.3.0-src.tar.bz2 0660
W: bsh strange-permission bsh.spec 0660
W: bsh strange-permission bsh-build.patch 0660
- Unnecceasry BR
uildRequires: perl should not be included
  (wiki: Packaging/Guidelines#Exceptions)
- Surce0 doesn't contains a full-qualified URL


Comment 3 Permaine Cheung 2007-03-29 12:34:27 EDT
(In reply to comment #2)
> Good:
> + Local build works fine.
> * Binaries packages are ok.
> + License ok.
> + naming seems ok.
> 
> Bad:
> - Rpmlint have warnings on source package:
> W: bsh non-standard-group Development/Java
The group is ok
> W: bsh strange-permission bsh-1.3.0-src.tar.bz2 0660
> W: bsh strange-permission bsh.spec 0660
> W: bsh strange-permission bsh-build.patch 0660
Fixed all the permission.
> - Unnecceasry BR
> uildRequires: perl should not be included
Got rid of it
>   (wiki: Packaging/Guidelines#Exceptions)
> - Surce0 doesn't contains a full-qualified URL
Source0 is created from cvs co, followed by creating the src tar ball, hence
there's no full-qualified URL for it.

Update spec file and srpm at the same location.
Thanks!
> 
> 
> 

Comment 4 Jochen Schmitt 2007-03-29 13:08:06 EDT
question:

What should this be?

export LANG='C'; rpm -i bsh-1.3.0-10jpp.1.fc7.src.rpm
error: open of <!DOCTYPE failed: No such file or directory
error: open of HTML failed: No such file or directory
error: open of PUBLIC failed: No such file or directory
Comment 5 Permaine Cheung 2007-03-29 13:45:28 EDT
hmm.. not quite sure what caused that, but I uploaded the srpm, could you please
try again?
Comment 6 Jochen Schmitt 2007-03-29 14:00:22 EDT
Good:
+ Local build works fine.

Bad:
+ Tar ball seems not to match with tar ball created from cvs reporistory
a63a33e2580aea1884a9f3b0b9f62972  bsh-1.3.0-src.tar.bz2
[s4504kr@zeus temp]$ md5sum /home/s4504kr/redhat/SOURCES/bsh-1.3.0-src.tar.bz2
3d8c14c2a223aa577108efa8bd17bdd3  /home/s4504kr/redhat/SOURCES/bsh-1.3.0-src.tar.bz2

Comment 7 Permaine Cheung 2007-03-29 15:33:38 EDT
Is the tar ball created by following the commands in the spec file?
If so, the md5sum will not match because of different ownership, in that case, a
diff -r on the extracted tar ball is needed to check if the tar ball are the same.
Comment 8 Permaine Cheung 2007-04-25 15:05:53 EDT
Any update on this?
Comment 9 Jochen Schmitt 2007-04-26 11:56:28 EDT
Good:
+ Naming is ok (perhaps may be BeanShell)
+ Tar ball matches with update when using diff -r
+ Mock build works fine.
+ Binary rpms are ok.

*** APPROVED ***


 
Comment 10 Permaine Cheung 2007-04-26 13:19:48 EDT
I'll keep the name as bsh as it has been shipped in previous Fedora release in
that name.
The package has been built, should hit rawhide soon.
Comment 11 Jochen Schmitt 2007-04-26 13:29:53 EDT
Thats ok, it was only a mind flash from me.
Comment 12 Jochen Schmitt 2007-05-22 10:43:14 EDT
Please close this bug after building the package.

Note You need to log in before you can comment on or make changes to this bug.