Bug 225629 - Merge Review: bug-buddy
Merge Review: bug-buddy
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 12:48 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 22:41:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bdpepple: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 12:48:01 EST
Fedora Merge Review: bug-buddy

http://cvs.fedora.redhat.com/viewcvs/devel/bug-buddy/
Initial Owner: rstrode@redhat.com
Comment 1 Ray Strode [halfline] 2007-02-02 14:25:55 EST
it uses %makeinstall .  I'm going to change it to use make install
DESTDIR=$RPM_BUILD_ROOT
Comment 2 Ray Strode [halfline] 2007-02-02 14:35:36 EST
there is some cruft:

## http://bugzilla.gnome.org/show_bug.cgi?id=89356
perl -pi -e
's/Categories=Application;Development$/Categories=Application;Development;/'
$RPM_BUILD_ROOT%{_datadir}/applications/*

that should just get pulled out.
Comment 3 Ray Strode [halfline] 2007-02-02 14:47:31 EST
I'm going to remove --vendor gnome from the desktop-file-install call. It
doesn't serve any useful purpose and is only there because historically it's
been a required command-line argument.

I've just removed that requirement upstream.
Comment 4 Ray Strode [halfline] 2007-02-02 14:57:59 EST
getting rid of --add-category X-Red-Hat-Extra .  We don't use that anymore afaik.
Comment 5 Brian Pepple 2007-02-03 18:14:22 EST
Good:
* Source URL is canonical
* Upstream source tarball verified
* Group Tag is from the official list
* Buildroot has all required elements
* All paths begin with macros
* All directories are owned by this or other packages
* All necessary BuildRequires listed.

Need to Check:
* Ray, you might want to check w/ Rex Dieter about removing the vendor on the
desktop file.  I believe the vendor needs to remain constant for the life of a
package due to menu-editing (which bases off of .desktop file/path names).

Minor Non-Blocker:
* * Duplicate BuildRequires: libbonobo-devel (by libgnomeui-devel), pango-devel
(by libgnomeui-devel), libgnomecanvas-devel (by libgnomeui-devel), gtk2-devel
(by libgnomeui-devel), gnome-vfs2-devel (by libgnomeui-devel), glib2-devel (by
libgnomeui-devel), libxml2-devel (by libgnomeui-devel), libgnome-devel (by
libgnomeui-devel), libglade2-devel (by libgnomeui-devel), libgnomeui-devel (by
gnome-desktop-devel)
Comment 6 Matthias Clasen 2007-02-03 19:49:59 EST
I think it is not a good idea to remove BR for things that are explicitly
required by configure, just because they happen to also be dragged in by
something else.
Comment 7 Ray Strode [halfline] 2007-02-05 16:31:17 EST
So to be clear, the issue is that removing the vendor will change the filename
and the menu editor keys off the of the filename when making changes to the menu.

That seems a bit icky.  It means we can never clean up the --vendor cruft, but
for now I'll just add --vendor back until we can figure out a better solution.
Comment 8 Matthias Clasen 2007-06-16 23:59:59 EDT
Brian, why is there a - in the fedora-review field ? 

I don't see any blocking issue in your comment above. 
Comment 9 Brian Pepple 2007-06-17 10:02:12 EDT
(In reply to comment #8)
> Brian, why is there a - in the fedora-review field ? 
> 
> I don't see any blocking issue in your comment above.

Not really sure either.  changing to +.

Comment 10 Matthias Clasen 2007-08-10 22:41:54 EDT
Ok, review done.

Note You need to log in before you can comment on or make changes to this bug.