This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 225632 - Merge Review: byacc
Merge Review: byacc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 12:48 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 11:38:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
matthias: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 12:48:38 EST
Fedora Merge Review: byacc

http://cvs.fedora.redhat.com/viewcvs/devel/byacc/
Initial Owner: pmachata@redhat.com
Comment 1 Petr Machata 2007-02-02 09:51:21 EST
Commited and built for rawhide updated and tidied-up version.  Rpmlint silent
for both binary and source rpm.
Comment 2 Rafał Psota 2007-02-25 16:26:36 EST
Needs work:
* Missing SMP flags. If it doesn't build with it, please add a comment
  (wiki: PackagingGuidelines#parallelmake)
* Spec file: some paths are not replaced with RPM macros (/usr/bin → %{_bindir})
* Source tag should use macros
* Some files (CHANGES, README, etc.) should be in %doc
Comment 3 Petr Machata 2007-03-01 13:21:15 EST
Cleaned up and commited.
Comment 4 Matthias Saou 2007-08-31 11:21:48 EDT
Good work at keeping the package clean! I've started the formal review. I see no
blockers, only possible improvements. Find here an updated spec file and a patch
to the current development one :
http://thias.fedorapeople.org/merge-review/byacc/

- Update to the 20070509 release.
- Update URL and summary.
- Remove useless doc copying in install section.
- Add NOTES and NO_WARRANTY docs.
Comment 5 Matthias Saou 2007-09-12 07:17:54 EDT
Ping? It would be nice to get this package cleaned up for Fedora 8.
Maybe the version update could be skipped because of the feature freeze, though.
Comment 6 Petr Machata 2007-09-12 11:10:28 EDT
I removed the update part, but other than that, I applied the patch unmodified.
 Thanks.  I rebuilt the package:
http://koji.fedoraproject.org/koji/taskinfo?taskID=156588

I will push new version post F8.
Comment 7 Matthias Saou 2007-09-12 11:38:04 EDT
Great, thanks! I've double checked everything, and it all looks good. Review
finished ;-)

Note You need to log in before you can comment on or make changes to this bug.