Bug 22568 - The following error occurred during package checking while installing using downloaded boot.img from bigfatpipe.net
The following error occurred during package checking while installing using d...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-19 23:44 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-21 14:22:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-19 23:44:11 EST
Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", 
line 33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: kbdconfig

Local variables in innermost frame:
self: <comps.HeaderList instance at 82710f8>
item: kbdconfig

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>
Comment 1 Michael Fulbright 2000-12-21 14:22:07 EST
Files are missing or corrupted in the hard drive install image you are using.
Make sure you've copied all the required files in a binary safe method.
Comment 2 Need Real Name 2000-12-21 14:58:14 EST
Thanks for the response, but, I think the problem is not with the boot.image.  The kbdconfig routine can't find a match for my keyboard and fails, rather 
than assign a generic type.  I'm installing on a new ( 11/2000 ) HP 6726-R Celeron w/ Windoze ME on it.  I've booted from a DOS disk to run fips.exe, 
created a 2nd DOS partition, did the ftp of the boot image in binary mode and used rawrite.exe to put it on diskette.  I got the same error with the 
pcmcia.image, too.  And I applied the 20001009-updates-image and still the same.  I think I'm doing the right things, but, I don't think the installer knows 
my new keyboard.  My 10 year old son is interested in Linux and the install is for him.  I've got some options to try and prove where the problem lies ( 
alternate keyboard, 2nd machine ), so while I'm doing that, could you see if new keyboard is the problem.

Note You need to log in before you can comment on or make changes to this bug.