Bug 225690 - Merge Review: dhcdbd
Summary: Merge Review: dhcdbd
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Package Reviews List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 18:26 UTC by Nobody's working on this, feel free to take it
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 17:21:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
clumens: fedora-review+


Attachments (Terms of Use)

Description Nobody's working on this, feel free to take it 2007-01-31 18:26:28 UTC
Fedora Merge Review: dhcdbd

http://cvs.fedora.redhat.com/viewcvs/devel/dhcdbd/
Initial Owner: dcantrell@redhat.com

Comment 1 Chris Lumens 2007-06-08 20:56:19 UTC
rpmlint output:
W: dhcdbd macro-in-%changelog post
W: dhcdbd macro-in-%changelog doc
E: dhcdbd no-cleaning-of-buildroot %install

macro usage:
Should Patch0 be specified with %{name}-%{version}-initscript.patch, and the
same for Patch1?

Requires:
Remember that we don't like file requires, so you could just Requires(...)
chkconfig and initscripts.  The guidelines say it's allowed as long as the files
are in /sbin, though.  Your call.

Scriptlets:
Be consistent about checking conditions before running the preun and postun
scriptlets.  Right now, they use different forms of the same test. 


Comment 2 David Cantrell 2007-06-11 17:08:50 UTC
(In reply to comment #1)
> rpmlint output:
> W: dhcdbd macro-in-%changelog post
> W: dhcdbd macro-in-%changelog doc
> E: dhcdbd no-cleaning-of-buildroot %install

Fixed.

> macro usage:
> Should Patch0 be specified with %{name}-%{version}-initscript.patch, and the
> same for Patch1?

I would think so, but someone said %{name}-VERSION is preferred because you want
the patch to indicate the version of the software is was made against.  So while
you may upgrade to version 3.0 of software foo, the patches against 2.5 may
still apply.

> Requires:
> Remember that we don't like file requires, so you could just Requires(...)
> chkconfig and initscripts.  The guidelines say it's allowed as long as the files
> are in /sbin, though.  Your call.

Yeah, I picked those up from the packaging guidelines.  I'll require the
packages though.

Fixed.

> Scriptlets:
> Be consistent about checking conditions before running the preun and postun
> scriptlets.  Right now, they use different forms of the same test. 

Fixed.

Changes made to devel branch.

Comment 3 Chris Lumens 2007-06-11 17:21:17 UTC
Looks good to me.


Note You need to log in before you can comment on or make changes to this bug.