Bug 225704 - Merge Review: docbook-style-xsl
Merge Review: docbook-style-xsl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 13:29 EST by Nobody's working on this, feel free to take it
Modified: 2008-01-12 10:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-12 10:20:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+
wtogami: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:29:20 EST
Fedora Merge Review: docbook-style-xsl

http://cvs.fedora.redhat.com/viewcvs/devel/docbook-style-xsl/
Initial Owner: twaugh@redhat.com
Comment 1 Ondrej Vasik 2007-07-27 04:17:40 EDT
Package Change Request
======================
Package Name: docbook-style-xsl
Updated Fedora Owners: ovasik@redhat.com
Comment 2 Parag AN(पराग) 2007-07-27 04:43:33 EDT
Can it be possible to ask "fedora-cvs?" without formal review?
Comment 3 Parag AN(पराग) 2007-11-05 11:47:41 EST
1) rpmlint gave me 
   file-not-utf8 on all files installed /usr/share/doc
you can use iconv to make them utf8 compatible


2)change buildroot to standard acceptable one.
http://fedoraproject.org/wiki/Packaging/Guidelines#head-b4fdd45fa76cbf54c885ef0836361319ab962473

3)Preserve timestamps
http://fedoraproject.org/wiki/Packaging/Guidelines#head-0239576e441f9ef53d175c4aec8c12868dffb5ab

4) defattr should be %defattr (-,root,root,-)
   I think this should be used.

5) Use macros instead of hard-coded directory names
http://fedoraproject.org/wiki/Packaging/Guidelines#head-255d52ff18f82fa184a32946b82ed81e4fd8885a


Comment 4 Parag AN(पराग) 2007-11-05 11:50:17 EST
source url should use 
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
as per given in http://fedoraproject.org/wiki/Packaging/SourceURL
Comment 5 Ondrej Vasik 2007-11-06 04:01:21 EST
I got rpmlint warning about file-not-utf8 only on reference.pdf.gz which is
inside the tarball and I don't think that is good idea to use iconv on it.

Buildroot changed, timestamps preserved, defattr changed, macros used instead of
hard-coded dirs. 

That SourceURL can't be changed to the format you mentioned, because upstream
name is docbook-xsl and fedora name is docbook-style-xsl, therefore I will leave
as it is (with s/prdownloads/downloads, although it is the same)

Are the changes sufficient for you?
Comment 6 Parag AN(पराग) 2007-11-06 06:29:47 EST
those changes will look sufficient but I rechecked and found nearly all files
under /user/share/doc gave me rpmlint warning of utf8.

can you recheck that rpmlint output on noarch rpm?
Comment 7 Ondrej Vasik 2007-11-06 06:47:09 EST
Ok, no problem ... 
with rpmlint-0.80-3.fc6:

installed package:
$ rpm -q docbook-style-xsl;rpmlint -iv docbook-style-xsl
docbook-style-xsl-1.73.2-3.fc9
I: docbook-style-xsl checking
W: docbook-style-xsl file-not-utf8
/usr/share/doc/docbook-style-xsl-1.73.2/doc/reference.pdf.gz
The character encoding of this file is not UTF-8.  Consider converting it
in the specfile for example using iconv(1).

noarch rpm:
rpmlint -iv docbook-style-xsl-1.73.2-3.fc9.noarch.rpm 
I: docbook-style-xsl checking
W: docbook-style-xsl file-not-utf8
/usr/share/doc/docbook-style-xsl-1.73.2/doc/reference.pdf.gz
The character encoding of this file is not UTF-8.  Consider converting it
in the specfile for example using iconv(1).
Comment 8 Ondrej Vasik 2007-11-06 09:01:40 EST
Built with requested changes(without UTF-8 conversion of reference.pdf.gz) as
docbook-style-xsl-1.73.2-4.fc9
Comment 9 Parag AN(पराग) 2007-11-14 01:10:19 EST
with latest updates mock build is ok but rpmlint gave me
nearly all files under /usr/share/doc gave me rpmlint warning of utf8.
Comment 10 Ondrej Vasik 2007-11-27 04:11:46 EST
What kind of information you need? 
Comment 11 Parag AN(पराग) 2007-11-27 04:18:32 EST
Should I approve package with those utf-8 warnings?
Comment 12 Ondrej Vasik 2007-11-27 04:27:31 EST
With my rpmlint(rpmlint version 0.80 Copyright (C) 1999-2006 Frederic Lepied,
Mandriva) I have only one warning - and this is ok for me - but if your rpmlint
is complaining about all docs, that is wrong. Could you please provide your
rpmlint version and how do you get this warning about all doc files?
I'm using rpmlint -iv <package>.noarch.rpm ...
Comment 13 Parag AN(पराग) 2007-11-27 05:04:38 EST
rpm -qa rpmlint gave me
rpmlint-0.81-1.fc8
Comment 14 Ondrej Vasik 2007-11-27 06:01:34 EST
My version is rpmlint-0.80-3.fc6 - ok, I will try it with the latest one...
Comment 15 Ondrej Vasik 2007-11-27 06:09:03 EST
Ok, with rpmlint-0.81-1.fc9 I have a lot of warnings about not UTF-8 ... strange
... will try to fix that ...
Comment 16 Ondrej Vasik 2007-11-27 07:46:45 EST
I added following section to the prep which silenced all latest rpmlint warning
about non UTF-8. Html files after conversion seems to be readable by web
browser. Do you see something wrong/dangerous in that spec construction?

# fix of non UTF-8 files rpmlint warnings 
for fhtml in $(find ./doc -name '*.html' -type f)
do
iconv -f ISO-8859-1 -t UTF-8 "$fhtml" -o "$fhtml".tmp
mv -f "$fhtml".tmp "$fhtml"
sed -i 's/ISO-8859-1/UTF-8/' "$fhtml"
done
Comment 17 Parag AN(पराग) 2007-11-29 01:02:58 EST
Looks good.
Do you want to build package for me for final review ?
Comment 18 Ondrej Vasik 2007-11-29 04:51:56 EST
Built as docbook-style-xsl-1.73.2-5.fc9 with small tweak of the html file change
(sed -i 's/charset=ISO-8859-1/charset=UTF-8' "$fhtml") - it is safer - previous
version changed one html file text.
Comment 19 Parag AN(पराग) 2007-11-29 05:50:44 EST
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM But NOT for RPM.
docbook-style-xsl.noarch: W: file-not-utf8
/usr/share/doc/docbook-style-xsl-1.73.2/doc/reference.pdf.gz
=> these messages can be ignored for this package.
+ source files match upstream.
7dd72a38c7d25e1396fa26b6ee53eae9  docbook-xsl-1.73.2.tar.gz
d41ce59b783b60383cca765902a41039  docbook-xsl-doc-1.73.2.tar.bz2
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc files present.
+ BuildRequires are proper.
+ defattr usage is correct.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code.
+ no static libraries.
+ no .pc file present.
+ no -devel subpackage exists.
+ no .la files.
+ no translations are available.
+ Does owns the directories it creates.
+ no duplicates in %files.
+ file permissions are appropriate.
+ no scriptlets are used.
+ package docbook-style-xsl-1.73.2-5.fc9 ->
  Provides: docbook-xsl = 1.73.2
  Requires: docbook-dtd-xml xml-common >= 0.6.3-8
+ Not a GUI app.

APPROVED.
Comment 20 Patrice Dumas 2007-11-29 06:08:35 EST
(In reply to comment #16)
> I added following section to the prep which silenced all latest rpmlint warning
> about non UTF-8. Html files after conversion seems to be readable by web
> browser. Do you see something wrong/dangerous in that spec construction?

I think it is wrong. You can do it if you like but the files are
as useful when encoded in latin1. In my opinion this is unuseful 
complexity. Rpmlint should just be ignored in that case.

(I have a different point of view for non utf8 files that don't 
have the encoding advertised in the file. For example README
text files).

Note You need to log in before you can comment on or make changes to this bug.