Bug 2257436 - kubectl zsh completion file is installed to the wrong directory
Summary: kubectl zsh completion file is installed to the wrong directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kubernetes
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brad Smith
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-01-09 16:16 UTC by Andrew Gunnerson
Modified: 2024-01-18 01:46 UTC (History)
5 users (show)

Fixed In Version: kubernetes-1.26.12-3.fc38 kubernetes-1.27.9-3.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-01-18 01:26:02 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Andrew Gunnerson 2024-01-09 16:16:26 UTC
Description of problem:

The zsh completion file for kubectl in the kubernetes-client package is currently being installed as /usr/share/zsh-completion/completions/kubectl, but the correct path for zsh is /usr/share/zsh/site-functions/_kubectl.

This seems to have been fixed in rawhide with https://src.fedoraproject.org/rpms/kubernetes/c/f0eebfbf420f35e04b4e1083e2f340580e7b552f?branch=rawhide, but the issue is still present in Fedora 39's package.

Version-Release number of selected component (if applicable):

1.27.9-1.fc39

Comment 1 Fedora Update System 2024-01-09 19:25:01 UTC
FEDORA-2024-69f5d96cd6 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2024-69f5d96cd6

Comment 2 Fedora Update System 2024-01-09 19:25:02 UTC
FEDORA-2024-ec3dc4a751 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2024-ec3dc4a751

Comment 3 Brad Smith 2024-01-09 19:28:09 UTC
Thanks for taking the time to file this bug. Updates to kubernetes for F39 and F38 that utilize the rpm shell completion macro for more correct shell completion paths. These updates will land in the production repositories in about a week.

Comment 4 Andrew Gunnerson 2024-01-09 19:44:03 UTC
Thanks for the super quick update!

Comment 5 Fedora Update System 2024-01-10 01:49:06 UTC
FEDORA-2024-69f5d96cd6 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-69f5d96cd6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-69f5d96cd6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2024-01-10 01:58:46 UTC
FEDORA-2024-ec3dc4a751 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-ec3dc4a751`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-ec3dc4a751

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2024-01-18 01:26:02 UTC
FEDORA-2024-ec3dc4a751 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2024-01-18 01:46:16 UTC
FEDORA-2024-69f5d96cd6 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.