Bug 225805 - Crash of Software Manager first use after rhn_register
Crash of Software Manager first use after rhn_register
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 13:49 EST by Joel Berman
Modified: 2013-01-10 04:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 17:07:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump (1.37 KB, text/plain)
2007-01-31 13:49 EST, Joel Berman
no flags Details

  None (edit)
Description Joel Berman 2007-01-31 13:49:51 EST
Description of problem:

Produced a dump when selecting add-remove software from menu.  DUmp attached
Version-Release number of selected component (if applicable):


Component: Software Manager
Summary: TB321c7849 sqlitecachec.py:32:getPrimary:TypeError: Parsing primary.xml
error: Input is not proper UTF-8, indicate encoding !
Bytes: 0xA9 0x20 0x31 0x39


Traceback (most recent call last):
  File "/usr/sbin/pirut", line 453, in ?
    main()
  File "/usr/sbin/pirut", line 449, in main
    pm.run()
  File "/usr/sbin/pirut", line 358, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 373, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 159, in reposSetup
    self.doSackSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 331, in doSackSetup
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 203, in populateSack
    sack.populate(repo, with, callback, cacheonly)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 91, in populate
    dobj = repo.cacheHandler.getPrimary(xml, csum)
  File "/usr/lib/python2.4/site-packages/sqlitecachec.py", line 32, in getPrimary
    self.callback))
TypeError: Parsing primary.xml error: Input is not proper UTF-8, indicate encoding !
Bytes: 0xA9 0x20 0x31 0x39


Local variables in innermost frame:
checksum: 7de6aa81e6cf9e84bd21cc1f39b8f05a7e78fec8
self: <sqlitecachec.RepodataParserSqlite instance at 0x8deefcc>
location: //var/cache/yum/rhel-i386-server-5/primary.xml.gz
Comment 1 Joel Berman 2007-01-31 13:49:51 EST
Created attachment 147039 [details]
dump
Comment 2 James Bowes 2007-02-01 13:05:24 EST
Was this against webqa? If so, it was a server-side issue from the last push
that has since been resolved.
Comment 3 Joel Berman 2007-02-01 13:15:34 EST
Yes it was with webqa.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.