Bug 225816 - Merge Review: gnome-doc-utils
Merge Review: gnome-doc-utils
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jens Petersen
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 13:50 EST by Nobody's working on this, feel free to take it
Modified: 2008-06-30 02:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: F9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-30 02:45:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
petersen: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:50:59 EST
Fedora Merge Review: gnome-doc-utils

http://cvs.fedora.redhat.com/viewcvs/devel/gnome-doc-utils/
Initial Owner: mbarnes@redhat.com
Comment 1 Jens Petersen 2007-03-26 03:47:26 EDT
Output from rpmlint:

srpm
W: gnome-doc-utils buildprereq-use libxml2-devel >= 2.6.12
W: gnome-doc-utils buildprereq-use libxslt-devel >= 1.1.8

rpm
E: gnome-doc-utils explicit-lib-dependency libxml2-python
W: gnome-doc-utils devel-file-in-non-devel-package /usr/share/pkgconfig/xml2po.pc
W: gnome-doc-utils devel-file-in-non-devel-package
/usr/share/pkgconfig/gnome-doc-utils.pc

Comment 2 Matthias Clasen 2007-06-17 00:26:29 EDT
I've fixed up Requires and BuildRequires a bit.


E: gnome-doc-utils explicit-lib-dependency libxml2-python

This sounds like rpmlint is smoking something...


W: gnome-doc-utils devel-file-in-non-devel-package /usr/share/pkgconfig/xml2po.pc
W: gnome-doc-utils devel-file-in-non-devel-package
/usr/share/pkgconfig/gnome-doc-utils.pc

These are just rpmlint not knowing that gnome-doc-utils is
a devel package.
Comment 3 Jens Petersen 2007-06-19 04:25:41 EDT
Thanks.  I agree those can certainly be waived.

About the license field, would it be better to list it as GPL/LGPL?
I am not sure what is the best way to designate that it is a mixture
of GPL and LGPL scripts?

Anyway COPYING, COPYING.GPL and COPYING.LGPL must be included in %doc.
Comment 4 Jens Petersen 2007-10-02 04:20:55 EDT
% rpmlint gnome-doc-utils-0.12.0-1.fc8.noarch.rpm
gnome-doc-utils.noarch: E: explicit-lib-dependency libxml2-python
gnome-doc-utils.noarch: W: invalid-license GFDL+

According to http://fedoraproject.org/wiki/Licensing
the short name is GFDL.
Comment 5 Jens Petersen 2007-10-08 01:44:46 EDT
Here is my review:

Good:
+ meets packaging and naming guidelines
+ project is GPL
+ spec file is clearly written
+ source is pristine
5934c08d12407d8233416343cd73df24  gnome-doc-utils-0.12.0.tar.bz2
+ lists buildrequires
+ file ownership looks good (except yelp problem mentioned also below)

Needs attention:
- rpmlint output
gnome-doc-utils.src: W: invalid-license GFDL+
gnome-doc-utils.noarch: E: explicit-lib-dependency libxml2-python
gnome-doc-utils.noarch: W: invalid-license GFDL+
gnome-doc-utils-stylesheets.noarch: W: no-documentation
gnome-doc-utils-stylesheets.noarch: W: devel-file-in-non-devel-package
/usr/share/pkgconfig/gnome-doc-utils.pc
gnome-doc-utils-stylesheets.noarch: W: devel-file-in-non-devel-package
/usr/share/pkgconfig/xml2po.pc
- /usr/share/gnome/help ownership:
Dunno if it would make sense have a different package (like filesystem) to
own this dir rather than yelp if it is problematic to require yelp?

If GFDL is mentioned as an additional license for the .xml files then I think
LGPL+ should also be mentioned for the .xsl files.
The GFDL license is not included though, so since it is embedded I am
not sure if it is strictly necessary to mention GFDL in the License field.

Otherwise the package looks good to me.
Comment 6 Jens Petersen 2007-11-13 01:40:17 EST
ping
Comment 7 Jens Petersen 2008-02-18 02:33:37 EST
Dropping review for lack of response.
Comment 8 Parag AN(पराग) 2008-02-18 06:07:23 EST
Can we drop this package from fedora if nobody willing to maintain this or mark
this as orphaned?
Comment 9 Huzaifa S. Sidhpurwala 2008-02-18 07:17:29 EST
I want to maintain this package, If there are no objections?
Comment 10 Matthew Barnes 2008-02-18 11:35:34 EST
(In reply to comment #5)
> gnome-doc-utils.src: W: invalid-license GFDL+

Changed to GFDL.

> gnome-doc-utils-stylesheets.noarch: W: no-documentation

Fixed some time ago.

> gnome-doc-utils.noarch: E: explicit-lib-dependency libxml2-python
> gnome-doc-utils-stylesheets.noarch: W: devel-file-in-non-devel-package
> /usr/share/pkgconfig/gnome-doc-utils.pc
> gnome-doc-utils-stylesheets.noarch: W: devel-file-in-non-devel-package
> /usr/share/pkgconfig/xml2po.pc

Invalid.  See comment #2.

> - /usr/share/gnome/help ownership:
> Dunno if it would make sense have a different package (like filesystem) to
> own this dir rather than yelp if it is problematic to require yelp?

Please reopen bug #205799 if this is still an issue.

> If GFDL is mentioned as an additional license for the .xml files then I think
> LGPL+ should also be mentioned for the .xsl files.

Added LGPLv2+.

License changes applied to gnome-doc-utils-0.12.1-2.fc9.
Comment 11 Debarshi Ray 2008-05-25 15:37:44 EDT
Is this review still "(stalled)" ?
Comment 12 Jens Petersen 2008-06-30 02:34:12 EDT
(In reply to comment #11)
> Is this review still "(stalled)" ?

Yes - feel free to continue it.
Comment 13 Jens Petersen 2008-06-30 02:45:06 EDT
Thanks for the update in comment 10.

Based on this I think the package is ok now.

APPROVED

Note You need to log in before you can comment on or make changes to this bug.