Bug 225846 - Merge Review: gnu-efi
Merge Review: gnu-efi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 13:56 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 13:26:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dcantrell: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:56:08 EST
Fedora Merge Review: gnu-efi

http://cvs.fedora.redhat.com/viewcvs/devel/gnu-efi/
Initial Owner: clumens@redhat.com
Comment 1 David Cantrell 2007-06-11 14:21:12 EDT
W: gnu-efi no-url-tag
W: gnu-efi setup-not-quiet
E: gnu-efi hardcoded-library-path in $RPM_BUILD_ROOT/usr/lib/gnuefi
E: gnu-efi hardcoded-library-path in $RPM_BUILD_ROOT/usr/lib/*.o
E: gnu-efi hardcoded-library-path in $RPM_BUILD_ROOT/usr/lib/gnuefi
E: gnu-efi hardcoded-library-path in /usr/lib/*

Release has no %{?dist} tag.  Do we need that?  I kind of like them, but I guess
it doesn't matter.

BuildRoot needs to be the huge version:
%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

Use %{?_smp_mflags} if it works in %build.

Line 19 has a trailing space.  Line 30 begins with a tab.  Fugly.

In the %files section, use %defattr(-,root,root,-)

In the %install and %files sections, use path macros.

And you know my personal opinion on %{buildroot} vs. $RPM_BUILD_ROOT.
Comment 2 Chris Lumens 2007-06-12 12:29:06 EDT
(In reply to comment #1)
> W: gnu-efi no-url-tag
> W: gnu-efi setup-not-quiet
> E: gnu-efi hardcoded-library-path in $RPM_BUILD_ROOT/usr/lib/gnuefi
> E: gnu-efi hardcoded-library-path in $RPM_BUILD_ROOT/usr/lib/*.o
> E: gnu-efi hardcoded-library-path in $RPM_BUILD_ROOT/usr/lib/gnuefi
> E: gnu-efi hardcoded-library-path in /usr/lib/*
> 
> Release has no %{?dist} tag.  Do we need that?  I kind of like them, but I guess
> it doesn't matter.
> 
> BuildRoot needs to be the huge version:
> %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
> 
> Use %{?_smp_mflags} if it works in %build.
> 
> Line 19 has a trailing space.  Line 30 begins with a tab.  Fugly.
> 
> In the %files section, use %defattr(-,root,root,-)
> 
> In the %install and %files sections, use path macros.
> 
> And you know my personal opinion on %{buildroot} vs. $RPM_BUILD_ROOT.

Fixed, but can't rebuild because it's another ia64 package.
Comment 3 David Cantrell 2007-06-12 13:19:08 EDT
Looks good.  Line 40 has a trailing space.  ExclusiveArch is set to ia64 and
i386.    Could you do:  koji build --arch-override=i386 dist-fc8 *.src.rpm

to build it in Fedora?
Comment 4 Chris Lumens 2007-06-12 13:21:13 EDT
I did a test build in dist-5E to verify that it builds correctly.  Since we have
the package in i386 for Fedora, I'll rebuild there too.

Note You need to log in before you can comment on or make changes to this bug.