Bug 225859 - Merge Review: groff
Merge Review: groff
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Package Reviews List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 13:58 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 09:15:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
varekova: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:58:31 EST
Fedora Merge Review: groff

http://cvs.fedora.redhat.com/viewcvs/devel/groff/
Initial Owner: mmaslano@redhat.com
Comment 1 Ivana Varekova 2007-02-26 11:15:23 EST
- missing dist tag
- change the buildroot to recomanded:
%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
- add %{?_smp_mflags}
- change defattr to (-,root,root,-)
- is the dependency on netpbm-progs necessary?
- is it possible to remove %makeinstall macro and use make install command?
- there should be used -p to preserve the timestamps


rpmlint output:
* srpm
W: groff summary-ended-with-dot A document formatting system.
E: groff tag-not-utf8 %changelog
E: groff non-utf8-spec-file groff.spec
W: groff prereq-use /sbin/install-info
W: groff unversioned-explicit-obsoletes groff-tools
W: groff unversioned-explicit-provides nroff-i18n
W: groff buildprereq-use byacc
E: groff hardcoded-library-path in $RPM_BUILD_ROOT/usr/lib/X11/app-defaults
W: groff mixed-use-of-spaces-and-tabs (spaces: line 145, tab: line 105)
W: groff patch-not-applied Patch14: groff-xlibs.patch
W: groff patch-not-applied Patch22: groff-1.18.1.1-bigendian.patch

*rpm
W: groff summary-ended-with-dot A document formatting system.
E: groff tag-not-utf8 %changelog
E: groff obsolete-not-provided groff-tools
E: groff only-non-binary-in-usr-lib
E: groff non-executable-script
/usr/share/groff/1.18.1.4/font/devps/generate/symbol.sed 0644
E: groff zero-length /usr/share/groff/1.18.1.4/tmac/mm/locale
E: groff non-executable-script
/usr/share/groff/1.18.1.4/font/devdvi/generate/CompileFonts 0644
E: groff non-executable-script /usr/lib/groff/groffer/version.sh 0644
E: groff zero-length /usr/share/groff/1.18.1.4/tmac/mm/se_locale
E: groff non-executable-script
/usr/share/groff/1.18.1.4/font/devps/generate/afmname 0644
E: groff-debuginfo tag-not-utf8 %changelog
W: groff-gxditview summary-ended-with-dot An X previewer for groff text
processor output.
E: groff-gxditview tag-not-utf8 %changelog
W: groff-gxditview no-documentation
W: groff-perl summary-ended-with-dot Parts of the groff formatting system that
require Perl.
E: groff-perl tag-not-utf8 %changelog
Comment 2 Marcela Mašláňová 2007-02-28 08:59:11 EST
Fix in groff-1.18.1.4-4.fc7
Comment 3 Ivana Varekova 2007-09-04 07:10:13 EDT
There remain some problem: 
* in spec there is mmissing %{?_smp_mflags} flag.. is there any reason for this?

* rpmlint output on *.rpm is not empty
E: groff non-executable-script /usr/share/groff/1.18.1.4/groffer/version.sh 0644
E: groff non-executable-script
/usr/share/groff/1.18.1.4/font/devps/generate/symbol.sed 0644
E: groff zero-length /usr/share/groff/1.18.1.4/tmac/mm/locale
E: groff non-executable-script
/usr/share/groff/1.18.1.4/font/devdvi/generate/CompileFonts 0644
E: groff zero-length /usr/share/groff/1.18.1.4/tmac/mm/se_locale
E: groff non-executable-script
/usr/share/groff/1.18.1.4/font/devps/generate/afmname 0644
W: groff invalid-license GPL
W: groff-debuginfo invalid-license GPL
W: groff-gxditview no-documentation
W: groff-gxditview invalid-license GPL
W: groff-perl invalid-license GPL


Comment 4 Marcela Mašláňová 2007-09-11 09:17:41 EDT
Only these problems stayed:
E: groff zero-length /usr/share/groff/1.18.1.4/tmac/mm/locale
E: groff zero-length /usr/share/groff/1.18.1.4/tmac/mm/se_locale

I can't remove these files, because they are needed for the correct functionality.
Comment 5 Todd Zullinger 2007-09-14 08:59:42 EDT
Hi Marcela,

The License tag for the GNU Free Documentation License should be GFDL rather
than FDL[1]. Otherwise rpmlint will still flag the license as invalid.

[1]
http://fedoraproject.org/wiki/Licensing#head-19fc3ef10add085a28cb06784dc34ef8b05a9bd6-2
Comment 6 Marcela Mašláňová 2007-09-17 04:23:24 EDT
License tag has been fixed.
Comment 7 Ivana Varekova 2007-09-17 09:15:04 EDT
Looks ok for me, fedora release ack granted.

Note You need to log in before you can comment on or make changes to this bug.