Bug 225878 - Merge Review: gzip
Merge Review: gzip
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Package Reviews List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:01 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-23 22:20:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:01:36 EST
Fedora Merge Review: gzip

http://cvs.fedora.redhat.com/viewcvs/devel/gzip/
Initial Owner: varekova@redhat.com
Comment 1 Kevin Fenzi 2007-02-04 10:50:21 EST
I'd be happy to review this package, look for a full review in a bit. 
Comment 2 Kevin Fenzi 2007-02-04 11:13:37 EST
OK - Spec has consistant macro usage.
OK - Meets Packaging Guidelines.
OK - License (GPL)
OK - License field in spec matches
OK - License file included in package
OK - Spec in American English
OK - Spec is legible.
See below - Sources match upstream md5sum:
OK - BuildRequires correct
OK - Package has %defattr and permissions on files is good.
OK - Package has a correct %clean section.
See below - Package has correct buildroot
OK - Package is code or permissible content.
OK - Packages %doc files don't affect runtime.

OK - Package compiles and builds on at least one arch.
OK - Package has no duplicate files in %files.
OK - Package doesn't own any directories other packages own.
OK - Package owns all the directories it creates.
OK - No rpmlint output.
OK - final provides and requires are sane:

SHOULD Items:

OK - Should build in mock.
OK - Should build on all supported archs
OK - Should function as described.
OK - Should have dist tag
See below - Should package latest version
0 open bugs - check for outstanding bugs on package.

Issues:

1. This version doesn't seem to be available upstream.
There is a 1.3.8 and a 1.3.10. Perhaps upgrading to 1.3.10 should be
the thing to do? Was 1.3.9 removed due to some problem?

2. Buildroot should be the standard one.
Comment 3 Ivana Varekova 2007-02-06 05:43:08 EST
Fixed in gzip-1.3.10-1.fc7.
Comment 4 Kevin Fenzi 2007-02-06 22:43:38 EST
Excellent. Everything looks good from here... this package is APPROVED. 

I think the plan is to keep it there open and assigned to you until
it's determined how to import all the approved packages into the new CVS. 

Thanks for your prompt response and fixes...
Comment 5 Warren Togami 2007-02-12 16:20:42 EST
Unsetting fedora-cvs, as Core Merge Reviews are already in CVS, and will be part
of the mass move when we are ready to merge the distro later.
Comment 6 Kevin Fenzi 2007-02-23 22:20:44 EST
Per the new official review guidelines, I am going to reassign this to me
(the reviewer) and close it rawhide (since the changes are already available
there). 

Note You need to log in before you can comment on or make changes to this bug.