Bug 22589 - wack display on SiS series chipset.
wack display on SiS series chipset.
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2000-12-20 12:48 EST by jean-marc rioux
Modified: 2007-03-26 23:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-01-29 14:50:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description jean-marc rioux 2000-12-20 12:48:31 EST
    .. ive got probleme with Xconfigurator.. the monitor i got figure in 
the list... (Compaq 151FS).. i choose all the correct option regarding 
this monitor and tryed all the resolution available... and the result 
really sux.. the windows are all screwed up... 

wha can i do? =|

Comment 1 Need Real Name 2001-01-06 15:51:36 EST
Rh7.0 (CDR004-1, etc.)
Xconfigurator autoprobes, detects SiS630 AGP, selects SiS620.

Have SiS630 & 8mB ram.

Monitor is Panasonic C-1591E (on list), select 24bit, 1024x680, 1280x1024 resolution

When X initially starts, the dialog box asking if it can be seen is off the the far right instead of
the center and short dark horizontal lines widely separated appear on right & left edges
of display. Right & left edges also appear jittery. There appears to be scan overlap in center
and 1/3 of width of display from left. Vertical centering is good. Horisontal centering is offset
to right.

When window manager  starts, one window appears in two places and not where it should--
if it's to be in center, it appears twice to right, the rightmost falling off right edge. 

Selecting "unlisted card" and XF86_SVGA server also has same result.
Using --prefxf3 option and --expert has same result.
Worked fine w/ XFree86 v3.xx in Rh6.2 using CF86_SVGA server, 24bit @ 1280x1024.

Comment 2 Preston Brown 2001-01-29 14:50:19 EST
Mike:  looks to be a SiS driver issue.
Comment 3 Preston Brown 2001-02-26 14:40:43 EST
fixed in rawhide -- use the XFree86 4.0.x sis driver.

Note You need to log in before you can comment on or make changes to this bug.