This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 225892 - Merge Review: hwbrowser
Merge Review: hwbrowser
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:04 EST by Nobody's working on this, feel free to take it
Modified: 2009-09-21 16:35 EDT (History)
1 user (show)

See Also:
Fixed In Version: hwbrowser-0.32-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 02:26:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
panemade: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:04:16 EST
Fedora Merge Review: hwbrowser

http://cvs.fedora.redhat.com/viewcvs/devel/hwbrowser/
Initial Owner: nphilipp@redhat.com
Comment 1 Parag AN(पराग) 2007-02-26 05:13:16 EST
You may like to use following patch to SPEC.

--- hwbrowser.spec      2006-11-24 19:49:55.000000000 +0530
+++ hwbrowser-modified.spec     2007-02-26 15:29:41.000000000 +0530
@@ -1,4 +1,4 @@
-Summary: A hardware browser.
+Summary: A hardware browser
 Name: hwbrowser
 Version: 0.30
 Release: 1%{?dist}
@@ -32,6 +32,10 @@
     --sysconfdir=%{_sysconfdir} --includedir=%{_includedir} \
     --libdir=%{_libdir} --bindir=%{_bindir}

+for source in *.py; do
+    sed -i -e '/^#!\/usr/d' $source
+done
+
 %build

 make
@@ -55,15 +59,15 @@
 %defattr(-,root,root)
 %doc README AUTHORS COPYING
 %{_bindir}/hwbrowser
-%{_sysconfdir}/pam.d/*
-%{_sysconfdir}/security/console.apps/*
+%config(noreplace) %{_sysconfdir}/pam.d/*
+%config(noreplace) %{_sysconfdir}/security/console.apps/*
 %{_datadir}/hwbrowser
 %{_datadir}/kontrol-panel/icons/hwbrowser.png
 %{_datadir}/pixmaps/hwbrowser.png
 %{_datadir}/applications/redhat-hwbrowser.desktop

 %changelog
-* Fri Nov 24 2006 Nils Philippsen <nphilipp@redhat.com> - 0.30
+* Fri Nov 24 2006 Nils Philippsen <nphilipp@redhat.com> - 0.30-1
 - pick up updated translations (#216597)
Comment 2 Parag AN(पराग) 2007-03-30 09:25:18 EDT
Any updates?
Comment 3 Nils Philippsen 2007-03-30 10:53:40 EDT
(In reply to comment #1)

> -Summary: A hardware browser.
> +Summary: A hardware browser

I've removed the article as well ("Hardware browser").

> +for source in *.py; do
> +    sed -i -e '/^#!\/usr/d' $source
> +done

I've removed the hash-bang in the files that are only modules (DeviceList.py is
callable).

> +%config(noreplace) %{_sysconfdir}/pam.d/*
> +%config(noreplace) %{_sysconfdir}/security/console.apps/*

OK

>  %{_datadir}/hwbrowser
>  %{_datadir}/kontrol-panel/icons/hwbrowser.png

I've removed that (we don't ship a kontrol-panel desktop file anyway).

>  %changelog
> -* Fri Nov 24 2006 Nils Philippsen <nphilipp@redhat.com> - 0.30
> +* Fri Nov 24 2006 Nils Philippsen <nphilipp@redhat.com> - 0.30-1

No, I need this to discriminate between stuff directly built from the "upstream"
spec file and stuff with additional patches (e.g. in RHEL).

hwbrowser-0.31 is building right now with these changes.
Comment 4 Nils Philippsen 2007-04-24 07:54:43 EDT
ping?
Comment 5 Parag AN(पराग) 2007-04-24 08:01:22 EDT
pong. sure let me check what mock gives me
Comment 6 Parag AN(पराग) 2007-04-24 08:06:56 EDT
build.log showed me
+ desktop-file-install --vendor redhat --delete-original --dir
/var/tmp/hwbrowser-0.31-1.fc7-root-mockbuild/usr/share/applications
/var/tmp/hwbrowser-0.31-1.fc7-root-mockbuild/usr/share/applications/hwbrowser.desktop
/var/tmp/hwbrowser-0.31-1.fc7-root-mockbuild/usr/share/applications/redhat-hwbrowser.desktop:
warning: boolean key "Terminal" has value "0", boolean values should be "false"
or "true", although "0" and "1" are allowed in this field for backwards
compatibility
/var/tmp/hwbrowser-0.31-1.fc7-root-mockbuild/usr/share/applications/redhat-hwbrowser.desktop:
warning: The 'Application' category is not defined by the desktop entry
specification.  Please use one of "AudioVideo", "Audio", "Video", "Development",
"Education", "Game", "Graphics", "Network", "Office", "Settings", "System",
"Utility" instead

ALSO
rpmlint reported on SRPM
W: hwbrowser macro-in-%changelog _datadir
Macros are expanded in %changelog too, which can in unfortunate cases lead
to the package not building at all, or other subtle unexpected conditions that
affect the build.  Even when that doesn't happen, the expansion results in
possibly "rewriting history" on subsequent package revisions and generally
odd entries eg. in source rpms, which is rarely wanted.  Avoid use of macros
in %changelog altogether, or use two '%'s to escape them, like '%%foo'.

And on RPM
W: hwbrowser incoherent-version-in-changelog 0.31 0.31-1.fc7
The last entry in %changelog contains a version identifier that is not
coherent with the epoch:version-release tuple of the package.

E: hwbrowser non-executable-script /usr/share/hwbrowser/DeviceList.py 0644
This text file contains a shebang or is located in a path dedicated for
executables, but lacks the executable bits and cannot thus be executed.  If
the file is meant to be an executable script, add the executable bits,
otherwise remove the shebang or move the file elsewhere.

Kindly correct those things and update the package.
Comment 7 Nils Philippsen 2007-04-24 09:07:38 EDT
(In reply to comment #6)
> build.log showed me
> + desktop-file-install --vendor redhat --delete-original --dir
> /var/tmp/hwbrowser-0.31-1.fc7-root-mockbuild/usr/share/applications
>
/var/tmp/hwbrowser-0.31-1.fc7-root-mockbuild/usr/share/applications/hwbrowser.desktop
>
/var/tmp/hwbrowser-0.31-1.fc7-root-mockbuild/usr/share/applications/redhat-hwbrowser.desktop:
> warning: boolean key "Terminal" has value "0", boolean values should be "false"
> or "true", although "0" and "1" are allowed in this field for backwards
> compatibility

fixed

>
/var/tmp/hwbrowser-0.31-1.fc7-root-mockbuild/usr/share/applications/redhat-hwbrowser.desktop:
> warning: The 'Application' category is not defined by the desktop entry
> specification.  Please use one of "AudioVideo", "Audio", "Video", "Development",
> "Education", "Game", "Graphics", "Network", "Office", "Settings", "System",
> "Utility" instead

fixed

> 
> ALSO
> rpmlint reported on SRPM
> W: hwbrowser macro-in-%changelog _datadir
> Macros are expanded in %changelog too, which can in unfortunate cases lead
> to the package not building at all, or other subtle unexpected conditions that
> affect the build.  Even when that doesn't happen, the expansion results in
> possibly "rewriting history" on subsequent package revisions and generally
> odd entries eg. in source rpms, which is rarely wanted.  Avoid use of macros
> in %changelog altogether, or use two '%'s to escape them, like '%%foo'.
> 

fixed

> And on RPM
> W: hwbrowser incoherent-version-in-changelog 0.31 0.31-1.fc7
> The last entry in %changelog contains a version identifier that is not
> coherent with the epoch:version-release tuple of the package.

this will stay, as we're upstream for hwbrowser, thus releases will almost
always be "1{?dist}"

> 
> E: hwbrowser non-executable-script /usr/share/hwbrowser/DeviceList.py 0644
> This text file contains a shebang or is located in a path dedicated for
> executables, but lacks the executable bits and cannot thus be executed.  If
> the file is meant to be an executable script, add the executable bits,
> otherwise remove the shebang or move the file elsewhere.

fixed

> 
> Kindly correct those things and update the package.

hwbrowser-0.32 is building right now.
Comment 8 manuel wolfshant 2007-04-24 09:22:16 EDT
WRT to changelog entry: just use 0.31-1 (or 0.32-1, etc) and you'll make rpmlint
happy. Even if you are upstream, maybe you'll decide that a minor change is not
worth a version bump but just a release bump.
Comment 9 Nils Philippsen 2007-04-24 09:45:39 EDT
If you insist... I've added the release tag to the changelog entry in upstream
CVS as a reminder, i.e. when there's a new version, rpmlint will be happy then
(hopefully I won't forget it ;-).
Comment 10 Parag AN(पराग) 2007-04-24 23:34:44 EDT
Ok now rpmlint gave me
W: hwbrowser incoherent-version-in-changelog 0.32 0.32-1.fc7
The last entry in %changelog contains a version identifier that is not
coherent with the epoch:version-release tuple of the package.
Comment 11 Parag AN(पराग) 2007-04-24 23:42:10 EDT
You just need to replace
* Tue Apr 24 2007 Nils Philippsen <nphilipp@redhat.com> - 0.32
 with
* Tue Apr 24 2007 Nils Philippsen <nphilipp@redhat.com> - 0.32-1

and rpmlint will be silent then. I don't think its related with whether upstream
is using release tag in tarball name or not.

Comment 12 manuel wolfshant 2007-04-25 03:38:01 EDT
Parag: Nils is the upstream for the package and - if I have understood correctly
- he implied that rather then incrementing the release tag, he prefers to
increase the version tag each time he modifies something. Basically this comes
down to the fact that he does not intend to really use the release tag, which is
why he ignores it in the Changelog. Only that this decision makes rpmlint unhappy.
Comment 13 Parag AN(पराग) 2007-04-25 05:46:52 EDT
OK. As maintainer is also upstream developer so no issues then.

Review:
+ package builds in mock (development i386).
+ rpmlint is silent for for RPM.
- rpmlint is NOT silent for SRPM.
+ source files match upstream.
c817a01e5bf60e30458df5b4b90d27d7  hwbrowser-0.32.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text COPYING is included in package.
+ %doc is small so no need of -doc subpackage.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no static libraries.
+ no .pc files are present.
+ no -devel subpackage exists.
+ no .la files.
+ translations are available.
+ Does owns the directories it creates.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Desktop file installed correctly.
+ no scriptlets are used.
+ Provides: config(hwbrowser) = 0.32-1.fc7
+ GUI app.
APPROVED.
Comment 14 Nils Philippsen 2007-04-25 08:06:47 EDT
Parag, I already changed the version string in the changelog to "0.32-1", but
only in the "upstream" CVS, not the actual built package. Once a new version
(0.33) gets out, I'll surely remember why I put the -release in the changelog
and will continue to do so.

BTW, isn't someone supposed to close this if it is approved? Just curious...
Comment 15 manuel wolfshant 2007-04-25 09:23:32 EDT
Nils, once your package is approved you are supposed to ask creation of the CVS
bits (see warren's mail, "cvs with flags" ) and after you import the package and
build it in plague you are the one who should close this bz ticket.
Comment 16 Parag AN(पराग) 2007-04-25 10:51:01 EDT
(In reply to comment #14)
> Parag, I already changed the version string in the changelog to "0.32-1", but
> only in the "upstream" CVS, not the actual built package. Once a new version
> (0.33) gets out, I'll surely remember why I put the -release in the changelog
> and will continue to do so.
> 
> BTW, isn't someone supposed to close this if it is approved? Just curious...

anyone can CLOSE this bug. The reason I have not closed it immediately is that I
thought you may also want to create EPEL cvs branch request.
As package is always in CVS there is no requirement for setting fedora-cvs flag
for Merge-Review packages.
So you can close this review.
Comment 17 Nils Philippsen 2007-04-25 11:04:50 EDT
Manuel, Parag, as this is a merge review I don't think I should be asking for
any CVS creation just yet: It will be in the combined Core+Extras for Fedora 7
and is part of RHEL5 anyway...
Comment 18 manuel wolfshant 2007-04-25 11:58:28 EDT
Me too I was thinking about EPEL when I was speaking about CVS. Anyway, I'd say
that the answer to closing the bug is here:
https://www.redhat.com/archives/fedora-extras-list/2007-February/msg00380.html

Please do correct me if I am wrong.
Comment 19 Parag AN(पराग) 2007-05-03 02:26:42 EDT
CLOSING this bug for now as reviewed version hwbrowser-0.32-1.fc7 of this
package is already in rawhide.

Note You need to log in before you can comment on or make changes to this bug.