Bug 225910 - Merge Review: ipv6calc
Merge Review: ipv6calc
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:06 EST by Nobody's working on this, feel free to take it
Modified: 2014-08-19 07:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-23 08:20:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
varekova: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:06:48 EST
Fedora Merge Review: ipv6calc

http://cvs.fedora.redhat.com/viewcvs/devel/ipv6calc/
Initial Owner: mmaslano@redhat.com
Comment 1 Ivana Varekova 2007-02-26 11:32:04 EST
- missing dist tag
- change the buildroot tag to recomanded:
%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
- add %{?_smp_mflags}
- change defattr to (-,root,root,-)
- URL tag is wrong
- there should be used -p to preserve the timestamps

rpmlint output:
* srpm
W: ipv6calc invalid-license GNU GPL version 2
W: ipv6calc macro-in-%changelog description
W: ipv6calc macro-in-%changelog files
W: ipv6calc macro-in-%changelog build
W: ipv6calc mixed-use-of-spaces-and-tabs (spaces: line 164, tab: line 1)

* rpm
W: ipv6calc invalid-license GNU GPL version 2
W: ipv6calc doc-file-dependency
/usr/share/doc/ipv6calc-0.61/ipv6logstats/collect_ipv6logstats.pl /usr/bin/perl
W: ipv6calc doc-file-dependency
/usr/share/doc/ipv6calc-0.61/ipv6logconv/run_analog.sh /bin/sh
W: ipv6calc doc-file-dependency
/usr/share/doc/ipv6calc-0.61/ipv6logstats/example_ipv6logstats.sh /bin/sh
W: ipv6calc-debuginfo invalid-license GNU GPL version 2
Comment 2 Marcela Mašláňová 2007-02-27 06:07:58 EST
Fixed in ipv6calc-0.61-2.fc7. 

W: ipv6calc doc-file-dependency
/usr/share/doc/ipv6calc-0.61/ipv6logstats/collect_ipv6logstats.pl /usr/bin/perl
W: ipv6calc doc-file-dependency
/usr/share/doc/ipv6calc-0.61/ipv6logconv/run_analog.sh /bin/sh
W: ipv6calc doc-file-dependency
/usr/share/doc/ipv6calc-0.61/ipv6logstats/example_ipv6logstats.sh /bin/sh
W: ipv6calc-debuginfo invalid-license GNU GPL version 2
These problems stay, because in doc are example scripts, which has to be
executable, also they make the dependency on perl, bash.
Comment 3 Ivana Varekova 2007-03-01 08:39:57 EST
Looks ok for me. 
Comment 4 Peter Bieringer 2014-08-17 13:42:29 EDT
Package Change Request
======================
Package Name: ipv6calc
New Branches: el6 epel7
Owners: pbiering
Comment 5 Robert Scheck 2014-08-18 12:51:09 EDT
Peter, if you really want to get this done, don't forget the fedora-cvs ;-)
Comment 6 Peter Bieringer 2014-08-18 16:43:18 EDT
fedora-cvs? Can it be that this is replaced by fedora-scm using git?

Package info:

https://admin.fedoraproject.org/pkgdb/package/ipv6calc/

for f19,f20,f21,f22 used git URL in fedora-scm: pkgs.fedoraproject.org/ipv6calc

More information required?


BTW: I've created already el6 and el7 (and also el5) packages using koji for test purposes some weeks ago:

EL5: http://koji.fedoraproject.org/koji/taskinfo?taskID=7232783
EL6: http://koji.fedoraproject.org/koji/taskinfo?taskID=7232794
EL7: http://koji.fedoraproject.org/koji/taskinfo?taskID=7232839
Comment 7 Robert Scheck 2014-08-18 17:35:40 EDT
(In reply to Peter Bieringer from comment #6)
> fedora-cvs? Can it be that this is replaced by fedora-scm using git?

I might be not up-to-date but IMHO is "fedora-cvs" as RHBZ flag still state
of the art to notifiy that SCM admin requests in RHBZ are getting processed;
http://fedoraproject.org/wiki/Package_SCM_admin_requests#Package_Change_Requests_for_existing_packages
Comment 8 Jon Ciesla 2014-08-19 07:44:36 EDT
Git done (by process-git-requests).

Note You need to log in before you can comment on or make changes to this bug.